aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gstreamer1-plugins-good/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-04-27 20:56:38 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-04-27 20:56:38 +0000
commit05d2886d27cb71e18dd917003926e7a165f40fa1 (patch)
treef41470c54496d3f979b6727ed30042270de45c74 /multimedia/gstreamer1-plugins-good/Makefile
parentf52d0a56a81ecf2c86d06a719ee9cb91b7d5d005 (diff)
downloadports-05d2886d27cb71e18dd917003926e7a165f40fa1.tar.gz
ports-05d2886d27cb71e18dd917003926e7a165f40fa1.zip
Notes
Diffstat (limited to 'multimedia/gstreamer1-plugins-good/Makefile')
-rw-r--r--multimedia/gstreamer1-plugins-good/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/multimedia/gstreamer1-plugins-good/Makefile b/multimedia/gstreamer1-plugins-good/Makefile
new file mode 100644
index 000000000000..fb00a9188416
--- /dev/null
+++ b/multimedia/gstreamer1-plugins-good/Makefile
@@ -0,0 +1,39 @@
+# Created by: Michael Johnson <ahze@FreeBSD.org>
+# $FreeBSD$
+# $MCom: ports/multimedia/gstreamer1-plugins-good/Makefile,v 1.4 2013/01/15 21:43:45 kwm Exp $
+
+PORTREVISION= 0
+CATEGORIES= multimedia
+
+COMMENT= Good gstreamer-plugins
+
+GST_PLUGIN= good
+GST_PLUGIN_SUFFIX= -good
+
+MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer1-plugins
+
+CONFIGURE_ARGS+=--enable-monoscope
+
+BUILD_DEPENDS+= gstreamer1-plugins>=${GST1_VERSION}${GST1_MINIMAL_VERSION}:${PORTSDIR}/multimedia/gstreamer1-plugins
+RUN_DEPENDS+= gstreamer1-plugins>=${GST1_VERSION}${GST1_MINIMAL_VERSION}:${PORTSDIR}/multimedia/gstreamer1-plugins
+
+DIST= good
+GOOD_GST_DIRS= gst sys po
+
+PLIST= ${.CURDIR}/pkg-plist
+FILESDIR= ${.CURDIR}/files
+PATCHDIR= ${.CURDIR}/files
+NO_GSTREAMER_COMMON= yes
+
+do-build:
+.for dir in ${GOOD_GST_DIRS}
+ @(cd ${BUILD_WRKSRC}/${dir}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET})
+.endfor
+
+do-install:
+.for dir in ${GOOD_GST_DIRS}
+ @(cd ${INSTALL_WRKSRC}/${dir} && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET})
+
+.endfor
+
+.include "${MASTERDIR}/Makefile"