aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gstreamer1-plugins
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2018-11-03 11:58:10 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2018-11-03 11:58:10 +0000
commit54c5444eba1973f2f6e1c0f576cf13cb1fa7f055 (patch)
treeb334f264681f2e08e196f19340f62a77ab5d75ec /multimedia/gstreamer1-plugins
parented3db43e3e696487cae99eb82b53f50be03a8c54 (diff)
downloadports-54c5444eba1973f2f6e1c0f576cf13cb1fa7f055.tar.gz
ports-54c5444eba1973f2f6e1c0f576cf13cb1fa7f055.zip
Update GStreamer to 1.14.4.
PR: 231406 Submitted by: Greg V <greg@unrelenting.technology> Exp-run by: antoine Approved by: portmgr (antoine)
Notes
Notes: svn path=/head/; revision=483887
Diffstat (limited to 'multimedia/gstreamer1-plugins')
-rw-r--r--multimedia/gstreamer1-plugins/Makefile12
-rw-r--r--multimedia/gstreamer1-plugins/Makefile.common43
-rw-r--r--multimedia/gstreamer1-plugins/distinfo18
-rw-r--r--multimedia/gstreamer1-plugins/pkg-plist17
4 files changed, 60 insertions, 30 deletions
diff --git a/multimedia/gstreamer1-plugins/Makefile b/multimedia/gstreamer1-plugins/Makefile
index 266051a1f0d9..9ee46d1a1675 100644
--- a/multimedia/gstreamer1-plugins/Makefile
+++ b/multimedia/gstreamer1-plugins/Makefile
@@ -5,7 +5,7 @@ PORTNAME= gstreamer
PORTVERSION?= ${BASE_PORTVERSION}
# When chasing a shared library for a plug-in bump the PORTREVISION in the
# plug-in port instead, like ${category}/gstreamer1-plugin-${PLUGIN}.
-PORTREVISION?= 2
+PORTREVISION?= 0
CATEGORIES?= multimedia audio
MASTER_SITES= http://gstreamer.freedesktop.org/src/gst-plugins-base/:base \
http://gstreamer.freedesktop.org/src/gst-plugins-bad/:bad \
@@ -26,16 +26,16 @@ RUN_DEPENDS+= iso-codes>=0:misc/iso-codes
PORTSCOUT= limitw:1,even
-BASE_PORTVERSION= 1.12.3
+BASE_PORTVERSION= 1.14.4
BASE_DISTNAME= gst-plugins-base-${BASE_PORTVERSION}
BASE_DISTFILE= ${BASE_DISTNAME}${EXTRACT_SUFX}
-BAD_PORTVERSION= 1.12.3
+BAD_PORTVERSION= 1.14.4
BAD_DISTNAME= gst-plugins-bad-${BAD_PORTVERSION}
BAD_DISTFILE= ${BAD_DISTNAME}${EXTRACT_SUFX}
-GOOD_PORTVERSION= 1.12.3
+GOOD_PORTVERSION= 1.14.4
GOOD_DISTNAME= gst-plugins-good-${GOOD_PORTVERSION}
GOOD_DISTFILE= ${GOOD_DISTNAME}${EXTRACT_SUFX}
-UGLY_PORTVERSION= 1.12.3
+UGLY_PORTVERSION= 1.14.4
UGLY_DISTNAME= gst-plugins-ugly-${UGLY_PORTVERSION}
UGLY_DISTFILE= ${UGLY_DISTNAME}${EXTRACT_SUFX}
DIST?= base
@@ -60,7 +60,7 @@ IGNORE= DIST not specified
.endif
VERSION= 1.0
-SOVERSION= 0.1203.0
+SOVERSION= 0.1404.0
PLIST_SUB+= VERSION="${VERSION}" \
SOVERSION="${SOVERSION}"
diff --git a/multimedia/gstreamer1-plugins/Makefile.common b/multimedia/gstreamer1-plugins/Makefile.common
index e434824eba3a..4ad511311733 100644
--- a/multimedia/gstreamer1-plugins/Makefile.common
+++ b/multimedia/gstreamer1-plugins/Makefile.common
@@ -3,9 +3,11 @@
BASE_GST_ALL_PLUGINS= \
alsa \
cdparanoia \
+ gl \
ivorbis \
libvisual \
ogg \
+ opengl \
opus \
pango \
theora \
@@ -14,6 +16,7 @@ BASE_GST_ALL_PLUGINS= \
xvideo
BAD_GST_ALL_PLUGINS+= \
+ aom \
assrender \
bs2b \
chromaprint \
@@ -42,13 +45,12 @@ BAD_GST_ALL_PLUGINS+= \
openal \
opencv \
openexr \
- opengl \
openh264 \
openjpeg \
+ openmpt \
resindvd \
rtmp \
rsvg \
- schro \
smoothstreaming \
sndfile \
soundtouch \
@@ -57,6 +59,7 @@ BAD_GST_ALL_PLUGINS+= \
srtp \
ttml \
vdpau \
+ vulkan \
wayland \
webp \
webrtcdsp \
@@ -84,11 +87,11 @@ BAD_GST_NON_PLUGINS+= \
--disable-directsound \
--disable-msdk \
--disable-nvenc \
+ --disable-nvdec \
--disable-sbc \
--disable-tinyalsa \
--disable-uvch264 \
--disable-vcd \
- --disable-vulkan \
--disable-wasapi \
--disable-wgl \
--disable-winks \
@@ -102,14 +105,17 @@ GOOD_GST_ALL_PLUGINS+= \
gst_v4l2 \
jack \
jpeg \
+ lame \
libcaca \
libdv \
libpng \
+ mpg123 \
pulse \
shout2 \
soup \
speex \
taglib \
+ twolame \
vpx \
wavpack \
x
@@ -132,11 +138,8 @@ UGLY_GST_ALL_PLUGINS+= \
amrwb \
cdio \
dvdread \
- lame \
mpeg2dec \
- mpg123 \
sidplay \
- twolame \
x264
UGLY_GST_NON_PLUGINS=
@@ -206,6 +209,9 @@ gst_amrwb_LIB_DEPENDS= libopencore-amrwb.so:audio/opencore-amr
gst_amrwb_GST_PLUGIN_DIR= ext/amrwbdec
gst_amrwb_PLIST_FILES= ${GST_LIB_DIR}/libgstamrwbdec.so
+# aom
+gst_aom_LIB_DEPENDS= libaom.so:multimedia/aom
+
# assrender
gst_assrender_LIB_DEPENDS= libass.so:multimedia/libass
@@ -266,10 +272,13 @@ gst_gdk_pixbuf_USE_GNOME= gdkpixbuf2
gst_gdk_pixbuf_PLIST_FILES= ${GST_LIB_DIR}/libgstgdkpixbuf.so
# gl
+gst_gl_USES= gl
gst_gl_USE_GL= gl glu glesv2 egl
-gst_gl_LIB_DEPENDS= libgraphene-1.0.so:graphics/graphene
+gst_gl_BUILD_DEPENDS= ${LOCALBASE}/include/linux/input.h:multimedia/v4l_compat
+gst_gl_LIB_DEPENDS= libgraphene-1.0.so:graphics/graphene \
+ libwayland-egl.so:graphics/wayland
gst_gl_CONFIGURE_ARGS= --enable-gl --enable-glx \
- --enable-egl --enable-gles2
+ --enable-egl --enable-gles2 --enable-wayland
gst_gl_GST_PLUGIN_DIR= gst-libs/gst/gl ext/gl
gst_gl_PLIST_FILES= #
@@ -280,6 +289,8 @@ gst_gme_LIB_DEPENDS= libgme.so:audio/libgme
gst_gsm_LIB_DEPENDS= libgsm.so:audio/gsm
# gtk3
+gst_gtk3_USES= gnome
+gst_gtk3_USE_GSTREAMER1= gl
gst_gtk3_USE_GNOME= cairo gdkpixbuf2 gtk30
gst_gtk3_CONFIGURE_ARGS=--enable-gtk3
gst_gtk3_GST_PLUGIN_DIR=ext/gtk
@@ -313,6 +324,7 @@ gst_libcaca_PLIST_FILES= ${GST_LIB_DIR}/libgstcacasink.so
# libde265
gst_libde265_LIB_DEPENDS= libde265.so:multimedia/libde265
+gst_libde265_PLIST_FILES= ${GST_LIB_DIR}/libgstde265.so
# libmms
gst_libmms_LIB_DEPENDS= libmms.so:net/libmms
@@ -370,6 +382,9 @@ gst_openjpeg_LIB_DEPENDS= libopenjp2.so:graphics/openjpeg
# openh264
gst_openh264_LIB_DEPENDS= libopenh264.so:multimedia/openh264
+# openmpt
+gst_openmpt_LIB_DEPENDS= libopenmpt.so:audio/libopenmpt
+
# opus
gst_opus_LIB_DEPENDS= libopus.so:audio/opus
@@ -420,11 +435,7 @@ gst_spc_LIB_DEPENDS= libopenspc.so:audio/libopenspc
gst_speex_LIB_DEPENDS= libspeex.so:audio/speex
# srtp
-gst_srtp_LIB_DEPENDS= libsrtp.so:net/libsrtp
-
-# schroedinger or schro for short
-gst_schro_LIB_DEPENDS= libschroedinger-1.0.so:multimedia/schroedinger
-gst_schro_GST_PLUGIN_DIR= ext/schroedinger
+gst_srtp_LIB_DEPENDS= libsrtp2.so:net/libsrtp2
# taglib
gst_taglib_LIB_DEPENDS= libtag.so:audio/taglib
@@ -460,6 +471,12 @@ gst_vpx_PLIST_FILES= ${GST_LIB_DIR}/libgstvpx.so \
gst_vdpau_LIB_DEPENDS= libvdpau.so:multimedia/libvdpau
gst_vdpau_GST_PLUGIN_DIR= sys/vdpau
+# vulkan
+gst_vulkan_BUILD_DEPENDS= ${LOCALBASE}/include/vulkan/vulkan.h:devel/vulkan-headers
+gst_vulkan_LIB_DEPENDS= libvulkan.so:graphics/vulkan-loader \
+ libwayland-client.so:graphics/wayland
+gst_vulkan_CONFIGURE_ARGS= --enable-wayland
+
# webp
gst_webp_LIB_DEPENDS= libwebp.so:graphics/webp
diff --git a/multimedia/gstreamer1-plugins/distinfo b/multimedia/gstreamer1-plugins/distinfo
index 3d6c2f8cb847..d37352e73cca 100644
--- a/multimedia/gstreamer1-plugins/distinfo
+++ b/multimedia/gstreamer1-plugins/distinfo
@@ -1,9 +1,9 @@
-TIMESTAMP = 1506168324
-SHA256 (gst-plugins-base-1.12.3.tar.xz) = d3d37b8489d37fa0018973d850bd2067b98af335fef2fa543ee7d40359e3cea5
-SIZE (gst-plugins-base-1.12.3.tar.xz) = 3117364
-SHA256 (gst-plugins-bad-1.12.3.tar.xz) = 36d059761852bed0f1a7fcd3ef64a8aeecab95d2bca53cd6aa0f08054b1cbfec
-SIZE (gst-plugins-bad-1.12.3.tar.xz) = 4707000
-SHA256 (gst-plugins-ugly-1.12.3.tar.xz) = e88ca584c94ea78eeecbf3af00ef7f134b66bdee7408aa4aa6c547235e060052
-SIZE (gst-plugins-ugly-1.12.3.tar.xz) = 903784
-SHA256 (gst-plugins-good-1.12.3.tar.xz) = 13e7f479296891fef5a686438f20ba7d534680becf2269ecc5ee24aa83b45f03
-SIZE (gst-plugins-good-1.12.3.tar.xz) = 3487448
+TIMESTAMP = 1539380228
+SHA256 (gst-plugins-base-1.14.4.tar.xz) = ca6139490e48863e7706d870ff4e8ac9f417b56f3b9e4b3ce490c13b09a77461
+SIZE (gst-plugins-base-1.14.4.tar.xz) = 3703232
+SHA256 (gst-plugins-bad-1.14.4.tar.xz) = 910b4e0e2e897e8b6d06767af1779d70057c309f67292f485ff988d087aa0de5
+SIZE (gst-plugins-bad-1.14.4.tar.xz) = 4678032
+SHA256 (gst-plugins-ugly-1.14.4.tar.xz) = ac02d837f166c35ff6ce0738e281680d0b90052cfb1f0255dcf6aaca5f0f6d23
+SIZE (gst-plugins-ugly-1.14.4.tar.xz) = 889632
+SHA256 (gst-plugins-good-1.14.4.tar.xz) = 5f8b553260cb0aac56890053d8511db1528d53cae10f0287cfce2cb2acc70979
+SIZE (gst-plugins-good-1.14.4.tar.xz) = 3792524
diff --git a/multimedia/gstreamer1-plugins/pkg-plist b/multimedia/gstreamer1-plugins/pkg-plist
index b7eeb074d125..ce4eae9cbdaf 100644
--- a/multimedia/gstreamer1-plugins/pkg-plist
+++ b/multimedia/gstreamer1-plugins/pkg-plist
@@ -1,10 +1,13 @@
bin/gst-device-monitor-%%VERSION%%
bin/gst-discoverer-%%VERSION%%
bin/gst-play-%%VERSION%%
+include/gstreamer-%%VERSION%%/gst/allocators/allocators-prelude.h
include/gstreamer-%%VERSION%%/gst/allocators/allocators.h
include/gstreamer-%%VERSION%%/gst/allocators/gstdmabuf.h
include/gstreamer-%%VERSION%%/gst/allocators/gstfdmemory.h
+include/gstreamer-%%VERSION%%/gst/allocators/gstphysmemory.h
include/gstreamer-%%VERSION%%/gst/app/app-enumtypes.h
+include/gstreamer-%%VERSION%%/gst/app/app-prelude.h
include/gstreamer-%%VERSION%%/gst/app/app.h
include/gstreamer-%%VERSION%%/gst/app/gstappsink.h
include/gstreamer-%%VERSION%%/gst/app/gstappsrc.h
@@ -14,9 +17,11 @@ include/gstreamer-%%VERSION%%/gst/audio/audio-converter.h
include/gstreamer-%%VERSION%%/gst/audio/audio-enumtypes.h
include/gstreamer-%%VERSION%%/gst/audio/audio-format.h
include/gstreamer-%%VERSION%%/gst/audio/audio-info.h
+include/gstreamer-%%VERSION%%/gst/audio/audio-prelude.h
include/gstreamer-%%VERSION%%/gst/audio/audio-quantize.h
include/gstreamer-%%VERSION%%/gst/audio/audio-resampler.h
include/gstreamer-%%VERSION%%/gst/audio/audio.h
+include/gstreamer-%%VERSION%%/gst/audio/gstaudioaggregator.h
include/gstreamer-%%VERSION%%/gst/audio/gstaudiobasesink.h
include/gstreamer-%%VERSION%%/gst/audio/gstaudiobasesrc.h
include/gstreamer-%%VERSION%%/gst/audio/gstaudiocdsrc.h
@@ -29,7 +34,9 @@ include/gstreamer-%%VERSION%%/gst/audio/gstaudiometa.h
include/gstreamer-%%VERSION%%/gst/audio/gstaudioringbuffer.h
include/gstreamer-%%VERSION%%/gst/audio/gstaudiosink.h
include/gstreamer-%%VERSION%%/gst/audio/gstaudiosrc.h
+include/gstreamer-%%VERSION%%/gst/audio/gstaudiostreamalign.h
include/gstreamer-%%VERSION%%/gst/audio/streamvolume.h
+include/gstreamer-%%VERSION%%/gst/fft/fft-prelude.h
include/gstreamer-%%VERSION%%/gst/fft/fft.h
include/gstreamer-%%VERSION%%/gst/fft/gstfft.h
include/gstreamer-%%VERSION%%/gst/fft/gstfftf32.h
@@ -46,9 +53,11 @@ include/gstreamer-%%VERSION%%/gst/pbutils/gstpluginsbaseversion.h
include/gstreamer-%%VERSION%%/gst/pbutils/install-plugins.h
include/gstreamer-%%VERSION%%/gst/pbutils/missing-plugins.h
include/gstreamer-%%VERSION%%/gst/pbutils/pbutils-enumtypes.h
+include/gstreamer-%%VERSION%%/gst/pbutils/pbutils-prelude.h
include/gstreamer-%%VERSION%%/gst/pbutils/pbutils.h
include/gstreamer-%%VERSION%%/gst/riff/riff-ids.h
include/gstreamer-%%VERSION%%/gst/riff/riff-media.h
+include/gstreamer-%%VERSION%%/gst/riff/riff-prelude.h
include/gstreamer-%%VERSION%%/gst/riff/riff-read.h
include/gstreamer-%%VERSION%%/gst/riff/riff.h
include/gstreamer-%%VERSION%%/gst/rtp/gstrtcpbuffer.h
@@ -60,6 +69,7 @@ include/gstreamer-%%VERSION%%/gst/rtp/gstrtpbuffer.h
include/gstreamer-%%VERSION%%/gst/rtp/gstrtpdefs.h
include/gstreamer-%%VERSION%%/gst/rtp/gstrtphdrext.h
include/gstreamer-%%VERSION%%/gst/rtp/gstrtppayloads.h
+include/gstreamer-%%VERSION%%/gst/rtp/rtp-prelude.h
include/gstreamer-%%VERSION%%/gst/rtp/rtp.h
include/gstreamer-%%VERSION%%/gst/rtsp/gstrtsp-enumtypes.h
include/gstreamer-%%VERSION%%/gst/rtsp/gstrtsp.h
@@ -70,14 +80,17 @@ include/gstreamer-%%VERSION%%/gst/rtsp/gstrtspmessage.h
include/gstreamer-%%VERSION%%/gst/rtsp/gstrtsprange.h
include/gstreamer-%%VERSION%%/gst/rtsp/gstrtsptransport.h
include/gstreamer-%%VERSION%%/gst/rtsp/gstrtspurl.h
+include/gstreamer-%%VERSION%%/gst/rtsp/rtsp-prelude.h
include/gstreamer-%%VERSION%%/gst/rtsp/rtsp.h
include/gstreamer-%%VERSION%%/gst/sdp/gstmikey.h
include/gstreamer-%%VERSION%%/gst/sdp/gstsdp.h
include/gstreamer-%%VERSION%%/gst/sdp/gstsdpmessage.h
+include/gstreamer-%%VERSION%%/gst/sdp/sdp-prelude.h
include/gstreamer-%%VERSION%%/gst/sdp/sdp.h
include/gstreamer-%%VERSION%%/gst/tag/gsttagdemux.h
include/gstreamer-%%VERSION%%/gst/tag/gsttagmux.h
include/gstreamer-%%VERSION%%/gst/tag/tag-enumtypes.h
+include/gstreamer-%%VERSION%%/gst/tag/tag-prelude.h
include/gstreamer-%%VERSION%%/gst/tag/tag.h
include/gstreamer-%%VERSION%%/gst/tag/xmpwriter.h
include/gstreamer-%%VERSION%%/gst/video/colorbalance.h
@@ -104,6 +117,7 @@ include/gstreamer-%%VERSION%%/gst/video/video-frame.h
include/gstreamer-%%VERSION%%/gst/video/video-info.h
include/gstreamer-%%VERSION%%/gst/video/video-multiview.h
include/gstreamer-%%VERSION%%/gst/video/video-overlay-composition.h
+include/gstreamer-%%VERSION%%/gst/video/video-prelude.h
include/gstreamer-%%VERSION%%/gst/video/video-resampler.h
include/gstreamer-%%VERSION%%/gst/video/video-scaler.h
include/gstreamer-%%VERSION%%/gst/video/video-tile.h
@@ -114,7 +128,6 @@ include/gstreamer-%%VERSION%%/gst/video/videooverlay.h
lib/girepository-1.0/GstAllocators-%%VERSION%%.typelib
lib/girepository-1.0/GstApp-%%VERSION%%.typelib
lib/girepository-1.0/GstAudio-%%VERSION%%.typelib
-lib/girepository-1.0/GstFft-%%VERSION%%.typelib
lib/girepository-1.0/GstPbutils-%%VERSION%%.typelib
lib/girepository-1.0/GstRtp-%%VERSION%%.typelib
lib/girepository-1.0/GstRtsp-%%VERSION%%.typelib
@@ -124,6 +137,7 @@ lib/girepository-1.0/GstVideo-%%VERSION%%.typelib
lib/gstreamer-%%VERSION%%/libgstadder.so
lib/gstreamer-%%VERSION%%/libgstapp.so
lib/gstreamer-%%VERSION%%/libgstaudioconvert.so
+lib/gstreamer-%%VERSION%%/libgstaudiomixer.so
lib/gstreamer-%%VERSION%%/libgstaudiorate.so
lib/gstreamer-%%VERSION%%/libgstaudioresample.so
lib/gstreamer-%%VERSION%%/libgstaudiotestsrc.so
@@ -191,7 +205,6 @@ man/man1/gst-play-%%VERSION%%.1.gz
share/gir-1.0/GstAllocators-%%VERSION%%.gir
share/gir-1.0/GstApp-%%VERSION%%.gir
share/gir-1.0/GstAudio-%%VERSION%%.gir
-share/gir-1.0/GstFft-%%VERSION%%.gir
share/gir-1.0/GstPbutils-%%VERSION%%.gir
share/gir-1.0/GstRtp-%%VERSION%%.gir
share/gir-1.0/GstRtsp-%%VERSION%%.gir