aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gstreamer1-plugins
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2015-06-22 18:33:20 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2015-06-22 18:33:20 +0000
commit6e5719ca80bba1b1c1a97fa29ba2147a5c1ba81e (patch)
treebdb6dbf3e5d4ada04784a3327eb91e0145530524 /multimedia/gstreamer1-plugins
parentb8355694f11dec2ab058a135acfc1a0f3c8967c0 (diff)
downloadports-6e5719ca80bba1b1c1a97fa29ba2147a5c1ba81e.tar.gz
ports-6e5719ca80bba1b1c1a97fa29ba2147a5c1ba81e.zip
Convert to USES=jpeg
Notes
Notes: svn path=/head/; revision=390310
Diffstat (limited to 'multimedia/gstreamer1-plugins')
-rw-r--r--multimedia/gstreamer1-plugins/Makefile5
-rw-r--r--multimedia/gstreamer1-plugins/Makefile.common4
2 files changed, 6 insertions, 3 deletions
diff --git a/multimedia/gstreamer1-plugins/Makefile b/multimedia/gstreamer1-plugins/Makefile
index cc546fa332d3..a73b927070a7 100644
--- a/multimedia/gstreamer1-plugins/Makefile
+++ b/multimedia/gstreamer1-plugins/Makefile
@@ -65,7 +65,8 @@ SOVERSION= 0.405.0
PLIST_SUB+= VERSION="${VERSION}" \
SOVERSION="${SOVERSION}"
-.include <bsd.port.pre.mk>
+# Include bsd.port.options.mk and not bsd.port.pre.mk to be able to use USES
+.include <bsd.port.options.mk>
.if ${GST_PLUGIN} == "base"
DIST= base
@@ -171,4 +172,4 @@ USE_GCC= any
pre-install:
${MKDIR} ${STAGEDIR}${PREFIX}/lib/gstreamer-1.0
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/multimedia/gstreamer1-plugins/Makefile.common b/multimedia/gstreamer1-plugins/Makefile.common
index f997f60643ad..6ac0d280847c 100644
--- a/multimedia/gstreamer1-plugins/Makefile.common
+++ b/multimedia/gstreamer1-plugins/Makefile.common
@@ -271,7 +271,7 @@ gst_gsm_LIB_DEPENDS= libgsm.so:${PORTSDIR}/audio/gsm
gst_jack_LIB_DEPENDS= libjack.so:${PORTSDIR}/audio/jack
# jpeg
-gst_jpeg_LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg
+gst_jpeg_USES= jpeg
# kate
gst_kate_LIB_DEPENDS= libkate.so:${PORTSDIR}/multimedia/libkate
@@ -428,6 +428,7 @@ gst_zbar_LIB_DEPENDS= libzbar.so:${PORTSDIR}/graphics/zbar
gst_${GST_PLUGIN}_BUILD_DEPENDS?=
gst_${GST_PLUGIN}_LIB_DEPENDS?=
gst_${GST_PLUGIN}_RUN_DEPENDS?=
+gst_${GST_PLUGIN}_USES?=
gst_${GST_PLUGIN}_USE_XORG?=
gst_${GST_PLUGIN}_PLIST_FILES?= \
${GST_LIB_DIR}/libgst${GST_PLUGIN}${GST_PLIST_SUFFIX}.so
@@ -445,6 +446,7 @@ gst_${GST_PLUGIN}_USE_GSTREAMER1?=
BUILD_DEPENDS+= ${gst_${GST_PLUGIN}_BUILD_DEPENDS}
LIB_DEPENDS+= ${gst_${GST_PLUGIN}_LIB_DEPENDS}
RUN_DEPENDS+= ${gst_${GST_PLUGIN}_RUN_DEPENDS}
+USES+= ${gst_${GST_PLUGIN}_USES}
PLIST_FILES= ${gst_${GST_PLUGIN}_PLIST_FILES}
EXTRA_LIBS+= ${gst_${GST_PLUGIN}_EXTRA_LIBS}
USE_XORG+= ${gst_${GST_PLUGIN}_USE_XORG}