aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gstreamer1-qt4
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2014-10-12 11:32:20 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2014-10-12 11:32:20 +0000
commitc49ebfcb6a42f13298e6b5ad0c66d5600599cc0f (patch)
treeae2fc3b178463ed631dcdef720d657ffe3892468 /multimedia/gstreamer1-qt4
parent0f77513f639fb25d62bb31b1f204b969680bc477 (diff)
downloadports-c49ebfcb6a42f13298e6b5ad0c66d5600599cc0f.tar.gz
ports-c49ebfcb6a42f13298e6b5ad0c66d5600599cc0f.zip
Notes
Diffstat (limited to 'multimedia/gstreamer1-qt4')
-rw-r--r--multimedia/gstreamer1-qt4/Makefile31
-rw-r--r--multimedia/gstreamer1-qt4/distinfo2
-rw-r--r--multimedia/gstreamer1-qt4/pkg-descr5
-rw-r--r--multimedia/gstreamer1-qt4/pkg-plist137
4 files changed, 175 insertions, 0 deletions
diff --git a/multimedia/gstreamer1-qt4/Makefile b/multimedia/gstreamer1-qt4/Makefile
new file mode 100644
index 000000000000..694ca248f32e
--- /dev/null
+++ b/multimedia/gstreamer1-qt4/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= gstreamer
+PORTVERSION= 1.2.0
+CATEGORIES= multimedia
+MASTER_SITES= http://gstreamer.freedesktop.org/src/qt-${PORTNAME}/
+PKGNAMESUFFIX= 1-qt4
+DISTNAME= qt-${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Qt 4 bindings for GStreamer 1.x multimedia library
+
+LIB_DEPENDS= libboost_thread.so:${PORTSDIR}/devel/boost-libs
+
+CONFLICTS_INSTALL= gstreamer-qt4-*
+
+USES= bison cmake:outsource gmake pkgconfig tar:xz
+USE_GSTREAMER1= yes
+USE_QT4= corelib gui opengl declarative \
+ qmake_build moc_build rcc_build uic_build qtestlib_build
+USE_LDCONFIG= yes
+CMAKE_ARGS= -DUSE_GST_PLUGIN_DIR=off \
+ -DUSE_QT_PLUGIN_DIR=off
+
+PLIST_SUB= SHLIB_VER="${PORTVERSION}"
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|$${CMAKE_INSTALL_LIBDIR}/pkgconfig|libdata/pkgconfig|' \
+ ${WRKSRC}/CMakeLists.txt
+
+.include <bsd.port.mk>
diff --git a/multimedia/gstreamer1-qt4/distinfo b/multimedia/gstreamer1-qt4/distinfo
new file mode 100644
index 000000000000..46f8570742a2
--- /dev/null
+++ b/multimedia/gstreamer1-qt4/distinfo
@@ -0,0 +1,2 @@
+SHA256 (qt-gstreamer-1.2.0.tar.xz) = 9f3b492b74cad9be918e4c4db96df48dab9c012f2ae5667f438b64a4d92e8fd4
+SIZE (qt-gstreamer-1.2.0.tar.xz) = 313632
diff --git a/multimedia/gstreamer1-qt4/pkg-descr b/multimedia/gstreamer1-qt4/pkg-descr
new file mode 100644
index 000000000000..915674259660
--- /dev/null
+++ b/multimedia/gstreamer1-qt4/pkg-descr
@@ -0,0 +1,5 @@
+QtGStreamer is a set of libraries providing C++ bindings for GStreamer
+with a Qt-style API, plus some helper classes and elements for
+integrating GStreamer better in Qt applications.
+
+WWW: http://gstreamer.freedesktop.org/
diff --git a/multimedia/gstreamer1-qt4/pkg-plist b/multimedia/gstreamer1-qt4/pkg-plist
new file mode 100644
index 000000000000..147ca9e68d3c
--- /dev/null
+++ b/multimedia/gstreamer1-qt4/pkg-plist
@@ -0,0 +1,137 @@
+include/QtGStreamer/QGlib/Connect
+include/QtGStreamer/QGlib/Error
+include/QtGStreamer/QGlib/Global
+include/QtGStreamer/QGlib/Init
+include/QtGStreamer/QGlib/Object
+include/QtGStreamer/QGlib/ParamSpec
+include/QtGStreamer/QGlib/Quark
+include/QtGStreamer/QGlib/RefPointer
+include/QtGStreamer/QGlib/Signal
+include/QtGStreamer/QGlib/Type
+include/QtGStreamer/QGlib/Value
+include/QtGStreamer/QGlib/connect.h
+include/QtGStreamer/QGlib/connectimpl.h
+include/QtGStreamer/QGlib/emitimpl.h
+include/QtGStreamer/QGlib/error.h
+include/QtGStreamer/QGlib/global.h
+include/QtGStreamer/QGlib/init.h
+include/QtGStreamer/QGlib/object.h
+include/QtGStreamer/QGlib/paramspec.h
+include/QtGStreamer/QGlib/qglib_signal.h
+include/QtGStreamer/QGlib/quark.h
+include/QtGStreamer/QGlib/refpointer.h
+include/QtGStreamer/QGlib/type.h
+include/QtGStreamer/QGlib/value.h
+include/QtGStreamer/QGlib/wrap.h
+include/QtGStreamer/QGst/Allocator
+include/QtGStreamer/QGst/Bin
+include/QtGStreamer/QGst/Buffer
+include/QtGStreamer/QGst/BufferList
+include/QtGStreamer/QGst/Bus
+include/QtGStreamer/QGst/Caps
+include/QtGStreamer/QGst/ChildProxy
+include/QtGStreamer/QGst/Clock
+include/QtGStreamer/QGst/ClockTime
+include/QtGStreamer/QGst/ColorBalance
+include/QtGStreamer/QGst/Discoverer
+include/QtGStreamer/QGst/DoubleRange
+include/QtGStreamer/QGst/Element
+include/QtGStreamer/QGst/ElementFactory
+include/QtGStreamer/QGst/Event
+include/QtGStreamer/QGst/Fourcc
+include/QtGStreamer/QGst/Fraction
+include/QtGStreamer/QGst/FractionRange
+include/QtGStreamer/QGst/GhostPad
+include/QtGStreamer/QGst/Global
+include/QtGStreamer/QGst/Init
+include/QtGStreamer/QGst/Int64Range
+include/QtGStreamer/QGst/IntRange
+include/QtGStreamer/QGst/Memory
+include/QtGStreamer/QGst/Message
+include/QtGStreamer/QGst/MiniObject
+include/QtGStreamer/QGst/Object
+include/QtGStreamer/QGst/Pad
+include/QtGStreamer/QGst/Parse
+include/QtGStreamer/QGst/Pipeline
+include/QtGStreamer/QGst/PluginFeature
+include/QtGStreamer/QGst/Query
+include/QtGStreamer/QGst/Sample
+include/QtGStreamer/QGst/Segment
+include/QtGStreamer/QGst/StreamVolume
+include/QtGStreamer/QGst/Structure
+include/QtGStreamer/QGst/TagList
+include/QtGStreamer/QGst/Ui/GraphicsVideoSurface
+include/QtGStreamer/QGst/Ui/GraphicsVideoWidget
+include/QtGStreamer/QGst/Ui/VideoWidget
+include/QtGStreamer/QGst/Ui/global.h
+include/QtGStreamer/QGst/Ui/graphicsvideosurface.h
+include/QtGStreamer/QGst/Ui/graphicsvideowidget.h
+include/QtGStreamer/QGst/Ui/videowidget.h
+include/QtGStreamer/QGst/UriHandler
+include/QtGStreamer/QGst/Utils/ApplicationSink
+include/QtGStreamer/QGst/Utils/ApplicationSource
+include/QtGStreamer/QGst/Utils/applicationsink.h
+include/QtGStreamer/QGst/Utils/applicationsource.h
+include/QtGStreamer/QGst/Utils/global.h
+include/QtGStreamer/QGst/VideoOrientation
+include/QtGStreamer/QGst/VideoOverlay
+include/QtGStreamer/QGst/allocator.h
+include/QtGStreamer/QGst/bin.h
+include/QtGStreamer/QGst/buffer.h
+include/QtGStreamer/QGst/bufferlist.h
+include/QtGStreamer/QGst/bus.h
+include/QtGStreamer/QGst/caps.h
+include/QtGStreamer/QGst/childproxy.h
+include/QtGStreamer/QGst/clock.h
+include/QtGStreamer/QGst/clocktime.h
+include/QtGStreamer/QGst/colorbalance.h
+include/QtGStreamer/QGst/discoverer.h
+include/QtGStreamer/QGst/element.h
+include/QtGStreamer/QGst/elementfactory.h
+include/QtGStreamer/QGst/enums.h
+include/QtGStreamer/QGst/event.h
+include/QtGStreamer/QGst/ghostpad.h
+include/QtGStreamer/QGst/global.h
+include/QtGStreamer/QGst/init.h
+include/QtGStreamer/QGst/memory.h
+include/QtGStreamer/QGst/message.h
+include/QtGStreamer/QGst/miniobject.h
+include/QtGStreamer/QGst/object.h
+include/QtGStreamer/QGst/pad.h
+include/QtGStreamer/QGst/parse.h
+include/QtGStreamer/QGst/pipeline.h
+include/QtGStreamer/QGst/pluginfeature.h
+include/QtGStreamer/QGst/query.h
+include/QtGStreamer/QGst/sample.h
+include/QtGStreamer/QGst/segment.h
+include/QtGStreamer/QGst/streamvolume.h
+include/QtGStreamer/QGst/structs.h
+include/QtGStreamer/QGst/structure.h
+include/QtGStreamer/QGst/taglist.h
+include/QtGStreamer/QGst/urihandler.h
+include/QtGStreamer/QGst/videoorientation.h
+include/QtGStreamer/QGst/videooverlay.h
+lib/cmake/QtGStreamer/QtGStreamerConfig.cmake
+lib/cmake/QtGStreamer/QtGStreamerConfigCommon.cmake
+lib/cmake/QtGStreamer/QtGStreamerConfigVersion.cmake
+lib/cmake/QtGStreamer/QtGStreamerTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/QtGStreamer/QtGStreamerTargets.cmake
+lib/gstreamer-1.0/libgstqtvideosink.so
+lib/libQtGLib-2.0.so
+lib/libQtGLib-2.0.so.0
+lib/libQtGLib-2.0.so.%%SHLIB_VER%%
+lib/libQtGStreamer-1.0.so
+lib/libQtGStreamer-1.0.so.0
+lib/libQtGStreamer-1.0.so.%%SHLIB_VER%%
+lib/libQtGStreamerUi-1.0.so
+lib/libQtGStreamerUi-1.0.so.0
+lib/libQtGStreamerUi-1.0.so.%%SHLIB_VER%%
+lib/libQtGStreamerUtils-1.0.so
+lib/libQtGStreamerUtils-1.0.so.0
+lib/libQtGStreamerUtils-1.0.so.%%SHLIB_VER%%
+%%QT_IMPORTDIR%%/QtGStreamer/libQtGStreamerQuick1.so
+%%QT_IMPORTDIR%%/QtGStreamer/qmldir
+libdata/pkgconfig/QtGLib-2.0.pc
+libdata/pkgconfig/QtGStreamer-1.0.pc
+libdata/pkgconfig/QtGStreamerUi-1.0.pc
+libdata/pkgconfig/QtGStreamerUtils-1.0.pc