aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gstreamer1
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2015-09-26 14:36:23 +0000
committerKoop Mast <kwm@FreeBSD.org>2015-09-26 14:36:23 +0000
commit7b97259096b0df72f16568f5b49a9a33cf1b4958 (patch)
tree6e57fabcf96c9308178f83f5236aab5d8f1b0127 /multimedia/gstreamer1
parent79947ef8956812db831bc1ed9541b5dcbb27a3ad (diff)
Notes
Diffstat (limited to 'multimedia/gstreamer1')
-rw-r--r--multimedia/gstreamer1/Makefile15
-rw-r--r--multimedia/gstreamer1/distinfo4
-rw-r--r--multimedia/gstreamer1/files/patch-Makefile.in10
-rw-r--r--multimedia/gstreamer1/pkg-plist27
4 files changed, 29 insertions, 27 deletions
diff --git a/multimedia/gstreamer1/Makefile b/multimedia/gstreamer1/Makefile
index b57ac08cd93b..8fae5771abeb 100644
--- a/multimedia/gstreamer1/Makefile
+++ b/multimedia/gstreamer1/Makefile
@@ -1,12 +1,11 @@
# Created by: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
# $FreeBSD$
-PORTNAME= gstreamer1
-PORTVERSION= 1.4.5
-PORTREVISION= 1
+PORTNAME= gstreamer
+PORTVERSION= 1.6.0
CATEGORIES= multimedia
MASTER_SITES= http://gstreamer.freedesktop.org/src/gstreamer/
-DISTNAME= ${PORTNAME:S/1//}-${PORTVERSION}
+PKGNAMESUFFIX= 1
MAINTAINER= multimedia@FreeBSD.org
COMMENT= Media applications framework
@@ -28,7 +27,7 @@ CONFIGURE_ARGS= --disable-tests \
CONFIGURE_ENV= ac_cv_func_register_printf_function="no"
INSTALL_TARGET= install-strip
PLIST_SUB= VERSION=${GST10_VERSION} \
- SOVERSION=0.405.0
+ SOVERSION=0.600.0
USE_LDCONFIG= yes
GST10_VERSION= 1.0
@@ -40,12 +39,6 @@ LIBCHECK_LIB_DEPENDS= libcheck.so:${PORTSDIR}/devel/libcheck
.include <bsd.port.options.mk>
-# workaround a crash in clang 3.3 crash llvm bug # 15840
-.if ((${OSVERSION} >= 901504 && ${OSVERSION} < 902502) || \
- (${OSVERSION} >= 1000037 && ${OSVERSION} < 1000056))
-USE_GCC= any
-.endif
-
.if ${OSVERSION} < 1000033
BUILD_DEPENDS+= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex
CONFIGURE_ENV+= FLEX_PATH="${LOCALBASE}/bin/flex"
diff --git a/multimedia/gstreamer1/distinfo b/multimedia/gstreamer1/distinfo
index 6ed90eef4a3c..7a00bc3f4cd6 100644
--- a/multimedia/gstreamer1/distinfo
+++ b/multimedia/gstreamer1/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gstreamer-1.4.5.tar.xz) = 40801aa7f979024526258a0e94707ba42b8ab6f7d2206e56adbc4433155cb0ae
-SIZE (gstreamer-1.4.5.tar.xz) = 3324052
+SHA256 (gstreamer-1.6.0.tar.xz) = 52ef885647afef11c8b7645a9afefe04aa09e8971c4b932e7717872ab8a30fcc
+SIZE (gstreamer-1.6.0.tar.xz) = 3549712
diff --git a/multimedia/gstreamer1/files/patch-Makefile.in b/multimedia/gstreamer1/files/patch-Makefile.in
index f498bef39ee3..6071ec62adf9 100644
--- a/multimedia/gstreamer1/files/patch-Makefile.in
+++ b/multimedia/gstreamer1/files/patch-Makefile.in
@@ -1,11 +1,11 @@
---- Makefile.in.orig 2013-03-10 14:50:08.000000000 +0000
-+++ Makefile.in 2013-03-10 14:50:24.000000000 +0000
-@@ -499,7 +499,7 @@
+--- Makefile.in.orig 2015-06-07 12:59:34.071555000 +0200
++++ Makefile.in 2015-06-07 13:00:02.869339000 +0200
+@@ -564,7 +564,7 @@
DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc --enable-docbook
aclocaldir = $(datadir)/aclocal
aclocal_DATA = gst-element-check-@GST_API_VERSION@.m4
--SUBDIRS = pkgconfig gst libs plugins tests docs po m4 common \
-+SUBDIRS = pkgconfig gst libs plugins tests po m4 common \
+-SUBDIRS = pkgconfig gst libs plugins tests docs po m4 common data \
++SUBDIRS = pkgconfig gst libs plugins tests po m4 common data \
$(am__append_1)
# These are all the possible subdirs
diff --git a/multimedia/gstreamer1/pkg-plist b/multimedia/gstreamer1/pkg-plist
index 93e2a58a23b4..ee898d8c33d9 100644
--- a/multimedia/gstreamer1/pkg-plist
+++ b/multimedia/gstreamer1/pkg-plist
@@ -4,8 +4,6 @@ bin/gst-typefind-%%VERSION%%
include/gstreamer-%%VERSION%%/gst/base/base.h
include/gstreamer-%%VERSION%%/gst/base/gstadapter.h
include/gstreamer-%%VERSION%%/gst/base/gstbaseparse.h
-include/gstreamer-%%VERSION%%/gst/base/gstdataqueue.h
-include/gstreamer-%%VERSION%%/gst/base/gstqueuearray.h
include/gstreamer-%%VERSION%%/gst/base/gstbasesink.h
include/gstreamer-%%VERSION%%/gst/base/gstbasesrc.h
include/gstreamer-%%VERSION%%/gst/base/gstbasetransform.h
@@ -13,21 +11,24 @@ include/gstreamer-%%VERSION%%/gst/base/gstbitreader.h
include/gstreamer-%%VERSION%%/gst/base/gstbytereader.h
include/gstreamer-%%VERSION%%/gst/base/gstbytewriter.h
include/gstreamer-%%VERSION%%/gst/base/gstcollectpads.h
+include/gstreamer-%%VERSION%%/gst/base/gstdataqueue.h
include/gstreamer-%%VERSION%%/gst/base/gstflowcombiner.h
include/gstreamer-%%VERSION%%/gst/base/gstpushsrc.h
+include/gstreamer-%%VERSION%%/gst/base/gstqueuearray.h
include/gstreamer-%%VERSION%%/gst/base/gsttypefindhelper.h
%%LIBCHECK%%include/gstreamer-%%VERSION%%/gst/check/check.h
%%LIBCHECK%%include/gstreamer-%%VERSION%%/gst/check/gstbufferstraw.h
%%LIBCHECK%%include/gstreamer-%%VERSION%%/gst/check/gstcheck.h
%%LIBCHECK%%include/gstreamer-%%VERSION%%/gst/check/gstconsistencychecker.h
+%%LIBCHECK%%include/gstreamer-%%VERSION%%/gst/check/gstharness.h
%%LIBCHECK%%include/gstreamer-%%VERSION%%/gst/check/gsttestclock.h
%%LIBCHECK%%include/gstreamer-%%VERSION%%/gst/check/internal-check.h
include/gstreamer-%%VERSION%%/gst/controller/controller.h
include/gstreamer-%%VERSION%%/gst/controller/gstargbcontrolbinding.h
include/gstreamer-%%VERSION%%/gst/controller/gstdirectcontrolbinding.h
-include/gstreamer-%%VERSION%%/gst/controller/gsttimedvaluecontrolsource.h
include/gstreamer-%%VERSION%%/gst/controller/gstinterpolationcontrolsource.h
include/gstreamer-%%VERSION%%/gst/controller/gstlfocontrolsource.h
+include/gstreamer-%%VERSION%%/gst/controller/gsttimedvaluecontrolsource.h
include/gstreamer-%%VERSION%%/gst/controller/gsttriggercontrolsource.h
include/gstreamer-%%VERSION%%/gst/glib-compat.h
include/gstreamer-%%VERSION%%/gst/gst.h
@@ -43,7 +44,6 @@ include/gstreamer-%%VERSION%%/gst/gstcapsfeatures.h
include/gstreamer-%%VERSION%%/gst/gstchildproxy.h
include/gstreamer-%%VERSION%%/gst/gstclock.h
include/gstreamer-%%VERSION%%/gst/gstcompat.h
-include/gstreamer-%%VERSION%%/gst/gstconfig.h
include/gstreamer-%%VERSION%%/gst/gstcontext.h
include/gstreamer-%%VERSION%%/gst/gstcontrolbinding.h
include/gstreamer-%%VERSION%%/gst/gstcontrolsource.h
@@ -78,6 +78,7 @@ include/gstreamer-%%VERSION%%/gst/gstplugin.h
include/gstreamer-%%VERSION%%/gst/gstpluginfeature.h
include/gstreamer-%%VERSION%%/gst/gstpoll.h
include/gstreamer-%%VERSION%%/gst/gstpreset.h
+include/gstreamer-%%VERSION%%/gst/gstprotection.h
include/gstreamer-%%VERSION%%/gst/gstquery.h
include/gstreamer-%%VERSION%%/gst/gstregistry.h
include/gstreamer-%%VERSION%%/gst/gstsample.h
@@ -97,17 +98,20 @@ include/gstreamer-%%VERSION%%/gst/gstutils.h
include/gstreamer-%%VERSION%%/gst/gstvalue.h
include/gstreamer-%%VERSION%%/gst/gstversion.h
include/gstreamer-%%VERSION%%/gst/math-compat.h
-include/gstreamer-%%VERSION%%/gst/net/net.h
include/gstreamer-%%VERSION%%/gst/net/gstnet.h
include/gstreamer-%%VERSION%%/gst/net/gstnetaddressmeta.h
include/gstreamer-%%VERSION%%/gst/net/gstnetclientclock.h
+include/gstreamer-%%VERSION%%/gst/net/gstnetcontrolmessagemeta.h
include/gstreamer-%%VERSION%%/gst/net/gstnettimepacket.h
include/gstreamer-%%VERSION%%/gst/net/gstnettimeprovider.h
+include/gstreamer-%%VERSION%%/gst/net/gstptpclock.h
+include/gstreamer-%%VERSION%%/gst/net/net.h
lib/girepository-1.0/Gst-%%VERSION%%.typelib
lib/girepository-1.0/GstBase-%%VERSION%%.typelib
%%LIBCHECK%%lib/girepository-1.0/GstCheck-%%VERSION%%.typelib
lib/girepository-1.0/GstController-%%VERSION%%.typelib
lib/girepository-1.0/GstNet-%%VERSION%%.typelib
+lib/gstreamer-%%VERSION%%/include/gst/gstconfig.h
lib/gstreamer-%%VERSION%%/libgstcoreelements.so
lib/libgstbase-%%VERSION%%.so
lib/libgstbase-%%VERSION%%.so.0
@@ -130,10 +134,15 @@ libdata/pkgconfig/gstreamer-base-%%VERSION%%.pc
libdata/pkgconfig/gstreamer-controller-%%VERSION%%.pc
libdata/pkgconfig/gstreamer-net-%%VERSION%%.pc
libexec/gstreamer-%%VERSION%%/gst-plugin-scanner
-man/man1/gst-inspect-1.0.1.gz
-man/man1/gst-launch-1.0.1.gz
-man/man1/gst-typefind-1.0.1.gz
+libexec/gstreamer-%%VERSION%%/gst-ptp-helper
+man/man1/gst-inspect-%%VERSION%%.1.gz
+man/man1/gst-launch-%%VERSION%%.1.gz
+man/man1/gst-typefind-%%VERSION%%.1.gz
share/aclocal/gst-element-check-%%VERSION%%.m4
+share/bash-completion/completions/gst-inspect-%%VERSION%%
+share/bash-completion/completions/gst-launch-%%VERSION%%
+share/bash-completion/helpers/gst
+share/bash-completion/helpers/gst-completion-helper-%%VERSION%%
share/gir-1.0/Gst-%%VERSION%%.gir
share/gir-1.0/GstBase-%%VERSION%%.gir
%%LIBCHECK%%share/gir-1.0/GstCheck-%%VERSION%%.gir
@@ -150,8 +159,8 @@ share/locale/de/LC_MESSAGES/gstreamer-%%VERSION%%.mo
share/locale/el/LC_MESSAGES/gstreamer-%%VERSION%%.mo
share/locale/en_GB/LC_MESSAGES/gstreamer-%%VERSION%%.mo
share/locale/eo/LC_MESSAGES/gstreamer-%%VERSION%%.mo
-share/locale/eu/LC_MESSAGES/gstreamer-%%VERSION%%.mo
share/locale/es/LC_MESSAGES/gstreamer-%%VERSION%%.mo
+share/locale/eu/LC_MESSAGES/gstreamer-%%VERSION%%.mo
share/locale/fi/LC_MESSAGES/gstreamer-%%VERSION%%.mo
share/locale/fr/LC_MESSAGES/gstreamer-%%VERSION%%.mo
share/locale/gl/LC_MESSAGES/gstreamer-%%VERSION%%.mo