aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gstreamer1
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-11-21 19:06:50 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-11-21 19:06:50 +0000
commit6fd348728dbe0537c4062da63f86c2a9d183ab24 (patch)
treefd78fb0814d9fd2484b56c17bbf4c520634884b4 /multimedia/gstreamer1
parent280f584d8670b3858b6961cd808e71b8a0afcfec (diff)
downloadports-6fd348728dbe0537c4062da63f86c2a9d183ab24.tar.gz
ports-6fd348728dbe0537c4062da63f86c2a9d183ab24.zip
Notes
Diffstat (limited to 'multimedia/gstreamer1')
-rw-r--r--multimedia/gstreamer1/Makefile11
-rw-r--r--multimedia/gstreamer1/distinfo4
-rw-r--r--multimedia/gstreamer1/files/patch-gst_gstdatetime.c12
-rw-r--r--multimedia/gstreamer1/pkg-plist14
4 files changed, 15 insertions, 26 deletions
diff --git a/multimedia/gstreamer1/Makefile b/multimedia/gstreamer1/Makefile
index d4da8794686f..ae524f195f53 100644
--- a/multimedia/gstreamer1/Makefile
+++ b/multimedia/gstreamer1/Makefile
@@ -3,7 +3,7 @@
# $MCom: ports/multimedia/gstreamer1/Makefile,v 1.5 2013/01/15 21:43:45 kwm Exp $
PORTNAME= gstreamer1
-PORTVERSION= 1.0.10
+PORTVERSION= 1.2.1
CATEGORIES= multimedia
MASTER_SITES= http://gstreamer.freedesktop.org/src/gstreamer/
DISTNAME= ${PORTNAME:S/1//}-${PORTVERSION}
@@ -18,20 +18,17 @@ PORTSCOUT= limitw:1,even
CFLAGS:= ${CFLAGS} -O2 -Wno-format
USES= bison gettext gmake pathfix pkgconfig
USE_XZ= yes
-USE_GNOME= glib20 gnomehier introspection:build ltverhack:0 ltasneededhack
-USE_AUTOTOOLS= libtool
+USE_GNOME= glib20 gnomehier introspection:build ltverhack
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-tests \
--disable-examples \
--disable-failing-tests \
--disable-fatal-warnings \
--disable-gtk-doc
-#--enable-gst-debug --enable-debug
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ENV= ac_cv_func_register_printf_function="no"
PLIST_SUB= VERSION=${GST10_VERSION}
USE_LDCONFIG= yes
-GST10_VERSION= ${PORTVERSION:R}
+GST10_VERSION= 1.0
OPTIONS_DEFINE= LIBCHECK
LIBCHECK_DESC= Unit tests support
diff --git a/multimedia/gstreamer1/distinfo b/multimedia/gstreamer1/distinfo
index 4d970b27d1c3..1dc16cc3497d 100644
--- a/multimedia/gstreamer1/distinfo
+++ b/multimedia/gstreamer1/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gstreamer-1.0.10.tar.xz) = 8e0aa9f41370586171a2616326fbc508bc4b61ffc4d55b2a8c4c3459d0cc1130
-SIZE (gstreamer-1.0.10.tar.xz) = 3140588
+SHA256 (gstreamer-1.2.1.tar.xz) = a4523d2471bca6cd0059a32e3b042f50faa4dadc6439852af8b43ca3f17d1fc9
+SIZE (gstreamer-1.2.1.tar.xz) = 3191504
diff --git a/multimedia/gstreamer1/files/patch-gst_gstdatetime.c b/multimedia/gstreamer1/files/patch-gst_gstdatetime.c
deleted file mode 100644
index 8eac4d8c76d4..000000000000
--- a/multimedia/gstreamer1/files/patch-gst_gstdatetime.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- gst/gstdatetime.c.orig 2013-10-20 16:05:12.000000000 +0200
-+++ gst/gstdatetime.c 2013-10-20 16:05:24.000000000 +0200
-@@ -21,8 +21,8 @@
- #include "config.h"
- #endif
-
--#include "glib-compat-private.h"
- #include "gst_private.h"
-+#include "glib-compat-private.h"
- #include "gstdatetime.h"
- #include "gstvalue.h"
- #include <glib.h>
diff --git a/multimedia/gstreamer1/pkg-plist b/multimedia/gstreamer1/pkg-plist
index 398249d75c87..ce1af138c20e 100644
--- a/multimedia/gstreamer1/pkg-plist
+++ b/multimedia/gstreamer1/pkg-plist
@@ -1,8 +1,11 @@
bin/gst-inspect-%%VERSION%%
bin/gst-launch-%%VERSION%%
bin/gst-typefind-%%VERSION%%
+include/gstreamer-%%VERSION%%/gst/base/base.h
include/gstreamer-%%VERSION%%/gst/base/gstadapter.h
include/gstreamer-%%VERSION%%/gst/base/gstbaseparse.h
+include/gstreamer-%%VERSION%%/gst/base/gstdataqueue.h
+include/gstreamer-%%VERSION%%/gst/base/gstqueuearray.h
include/gstreamer-%%VERSION%%/gst/base/gstbasesink.h
include/gstreamer-%%VERSION%%/gst/base/gstbasesrc.h
include/gstreamer-%%VERSION%%/gst/base/gstbasetransform.h
@@ -12,10 +15,13 @@ include/gstreamer-%%VERSION%%/gst/base/gstbytewriter.h
include/gstreamer-%%VERSION%%/gst/base/gstcollectpads.h
include/gstreamer-%%VERSION%%/gst/base/gstpushsrc.h
include/gstreamer-%%VERSION%%/gst/base/gsttypefindhelper.h
+%%CHECK%%include/gstreamer-%%VERSION%%/gst/check/check.h
%%CHECK%%include/gstreamer-%%VERSION%%/gst/check/gstbufferstraw.h
%%CHECK%%include/gstreamer-%%VERSION%%/gst/check/gstcheck.h
%%CHECK%%include/gstreamer-%%VERSION%%/gst/check/gstconsistencychecker.h
+%%CHECK%%include/gstreamer-%%VERSION%%/gst/check/gsttestclock.h
%%CHECK%%include/gstreamer-%%VERSION%%/gst/check/internal-check.h
+include/gstreamer-%%VERSION%%/gst/controller/controller.h
include/gstreamer-%%VERSION%%/gst/controller/gstargbcontrolbinding.h
include/gstreamer-%%VERSION%%/gst/controller/gstdirectcontrolbinding.h
include/gstreamer-%%VERSION%%/gst/controller/gsttimedvaluecontrolsource.h
@@ -32,10 +38,12 @@ include/gstreamer-%%VERSION%%/gst/gstbufferlist.h
include/gstreamer-%%VERSION%%/gst/gstbufferpool.h
include/gstreamer-%%VERSION%%/gst/gstbus.h
include/gstreamer-%%VERSION%%/gst/gstcaps.h
+include/gstreamer-%%VERSION%%/gst/gstcapsfeatures.h
include/gstreamer-%%VERSION%%/gst/gstchildproxy.h
include/gstreamer-%%VERSION%%/gst/gstclock.h
include/gstreamer-%%VERSION%%/gst/gstcompat.h
include/gstreamer-%%VERSION%%/gst/gstconfig.h
+include/gstreamer-%%VERSION%%/gst/gstcontext.h
include/gstreamer-%%VERSION%%/gst/gstcontrolbinding.h
include/gstreamer-%%VERSION%%/gst/gstcontrolsource.h
include/gstreamer-%%VERSION%%/gst/gstdatetime.h
@@ -84,6 +92,7 @@ include/gstreamer-%%VERSION%%/gst/gstutils.h
include/gstreamer-%%VERSION%%/gst/gstvalue.h
include/gstreamer-%%VERSION%%/gst/gstversion.h
include/gstreamer-%%VERSION%%/gst/math-compat.h
+include/gstreamer-%%VERSION%%/gst/net/net.h
include/gstreamer-%%VERSION%%/gst/net/gstnet.h
include/gstreamer-%%VERSION%%/gst/net/gstnetaddressmeta.h
include/gstreamer-%%VERSION%%/gst/net/gstnetclientclock.h
@@ -96,23 +105,18 @@ lib/girepository-1.0/GstController-%%VERSION%%.typelib
lib/girepository-1.0/GstNet-%%VERSION%%.typelib
lib/gstreamer-%%VERSION%%/libgstcoreelements.la
lib/gstreamer-%%VERSION%%/libgstcoreelements.so
-lib/libgstbase-%%VERSION%%.a
lib/libgstbase-%%VERSION%%.la
lib/libgstbase-%%VERSION%%.so
lib/libgstbase-%%VERSION%%.so.0
-%%CHECK%%lib/libgstcheck-%%VERSION%%.a
%%CHECK%%lib/libgstcheck-%%VERSION%%.la
%%CHECK%%lib/libgstcheck-%%VERSION%%.so
%%CHECK%%lib/libgstcheck-%%VERSION%%.so.0
-lib/libgstcontroller-%%VERSION%%.a
lib/libgstcontroller-%%VERSION%%.la
lib/libgstcontroller-%%VERSION%%.so
lib/libgstcontroller-%%VERSION%%.so.0
-lib/libgstnet-%%VERSION%%.a
lib/libgstnet-%%VERSION%%.la
lib/libgstnet-%%VERSION%%.so
lib/libgstnet-%%VERSION%%.so.0
-lib/libgstreamer-%%VERSION%%.a
lib/libgstreamer-%%VERSION%%.la
lib/libgstreamer-%%VERSION%%.so
lib/libgstreamer-%%VERSION%%.so.0