aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gstreamer1
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-04-27 20:56:38 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-04-27 20:56:38 +0000
commit05d2886d27cb71e18dd917003926e7a165f40fa1 (patch)
treef41470c54496d3f979b6727ed30042270de45c74 /multimedia/gstreamer1
parentf52d0a56a81ecf2c86d06a719ee9cb91b7d5d005 (diff)
downloadports-05d2886d27cb71e18dd917003926e7a165f40fa1.tar.gz
ports-05d2886d27cb71e18dd917003926e7a165f40fa1.zip
Notes
Diffstat (limited to 'multimedia/gstreamer1')
-rw-r--r--multimedia/gstreamer1/Makefile62
-rw-r--r--multimedia/gstreamer1/distinfo2
-rw-r--r--multimedia/gstreamer1/files/patch-Makefile.in11
-rw-r--r--multimedia/gstreamer1/pkg-descr24
-rw-r--r--multimedia/gstreamer1/pkg-plist179
5 files changed, 278 insertions, 0 deletions
diff --git a/multimedia/gstreamer1/Makefile b/multimedia/gstreamer1/Makefile
new file mode 100644
index 000000000000..b93971b41351
--- /dev/null
+++ b/multimedia/gstreamer1/Makefile
@@ -0,0 +1,62 @@
+# Created by: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+# $FreeBSD$
+# $MCom: ports/multimedia/gstreamer1/Makefile,v 1.5 2013/01/15 21:43:45 kwm Exp $
+
+PORTNAME= gstreamer1
+PORTVERSION= 1.0.7
+CATEGORIES= multimedia
+MASTER_SITES= http://gstreamer.freedesktop.org/src/gstreamer/
+DISTNAME= ${PORTNAME:S/1//}-${PORTVERSION}
+
+MAINTAINER= multimedia@FreeBSD.org
+COMMENT= Media applications framework
+
+LICENSE= LGPL20
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex \
+ gobject-introspection>=1.31.1:${PORTSDIR}/devel/gobject-introspection
+RUN_DEPENDS= ${LOCALBASE}/share/gir-1.0/GLib-2.0.gir:${PORTSDIR}/devel/gobject-introspection
+
+CFLAGS:= ${CFLAGS} -O2 -Wno-format
+USES= bison gettext pathfix pkgconfig
+USE_XZ= yes
+USE_GMAKE= yes
+MAKE_JOBS_SAVE= yes
+USE_GNOME= glib20 ltverhack:0 ltasneededhack
+USE_AUTOTOOLS= libtool
+CONFIGURE_ARGS= --disable-tests \
+ --disable-examples \
+ --disable-failing-tests \
+ --disable-fatal-warnings \
+ --disable-gtk-doc
+#--enable-gst-debug --enable-debug
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV= ac_cv_func_register_printf_function="no" \
+ FLEX_PATH="${LOCALBASE}/bin/flex"
+PLIST_SUB= VERSION=${GST10_VERSION}
+USE_LDCONFIG= yes
+GST10_VERSION= ${PORTVERSION:R}
+
+MAN1= gst-inspect-${GST10_VERSION}.1 gst-launch-${GST10_VERSION}.1 \
+ gst-typefind-${GST10_VERSION}.1
+
+OPTIONS_DEFINE= LIBCHECK
+LIBCHECK_DESC= Unit tests support
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MLIBCHECK}
+LIB_DEPENDS+= check:${PORTSDIR}/devel/libcheck
+CONFIGURE_ARGS+=--enable-check
+PLIST_SUB+= CHECK=""
+.else
+CONFIGURE_ARGS+=--disable-check
+PLIST_SUB+= CHECK="@comment "
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-Wmissing-include-dirs||g' \
+ ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/multimedia/gstreamer1/distinfo b/multimedia/gstreamer1/distinfo
new file mode 100644
index 000000000000..86e2243240bc
--- /dev/null
+++ b/multimedia/gstreamer1/distinfo
@@ -0,0 +1,2 @@
+SHA256 (gstreamer-1.0.7.tar.xz) = 68cada7ee24ede23e15dc81ccde11898eed1a7a3c6a2d81a8c31596fccb1b5ce
+SIZE (gstreamer-1.0.7.tar.xz) = 3089280
diff --git a/multimedia/gstreamer1/files/patch-Makefile.in b/multimedia/gstreamer1/files/patch-Makefile.in
new file mode 100644
index 000000000000..f498bef39ee3
--- /dev/null
+++ b/multimedia/gstreamer1/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig 2013-03-10 14:50:08.000000000 +0000
++++ Makefile.in 2013-03-10 14:50:24.000000000 +0000
+@@ -499,7 +499,7 @@
+ DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc --enable-docbook
+ aclocaldir = $(datadir)/aclocal
+ aclocal_DATA = gst-element-check-@GST_API_VERSION@.m4
+-SUBDIRS = pkgconfig gst libs plugins tests docs po m4 common \
++SUBDIRS = pkgconfig gst libs plugins tests po m4 common \
+ $(am__append_1)
+
+ # These are all the possible subdirs
diff --git a/multimedia/gstreamer1/pkg-descr b/multimedia/gstreamer1/pkg-descr
new file mode 100644
index 000000000000..61a492cd9c68
--- /dev/null
+++ b/multimedia/gstreamer1/pkg-descr
@@ -0,0 +1,24 @@
+[ excerpt from developer's site ]
+- What is GStreamer?
+GStreamer allows the construction of graphs of media-handling
+components, ranging from simple mp3 playback to complex audio
+(mixing) and video (non-linear editing) processing. Applications
+can take advantage of advances in codec and filter technology
+transparently. Developers can add new codecs and filters by writing
+a simple plugin with a clean, generic interface. GStreamer is
+released under the LGPL, with many of the included plugins retaining
+the license of the code they were derived from, usually GPL or BSD.
+
+- Features:
+* Comprehensive Core Library
+* Intelligent Plugin Architecture
+* Extensive Development Tools
+
+- Is GStreamer a media player?
+No, GStreamer is a development framework for creating applications
+like media players, video editors, streaming media broadcasters and
+so on. That said, very good media players can easily be built on
+top of GStreamer and we even include a simple yet functional
+mediaplayer with GStreamer called Gst-Player
+
+WWW: http://gstreamer.freedesktop.org/
diff --git a/multimedia/gstreamer1/pkg-plist b/multimedia/gstreamer1/pkg-plist
new file mode 100644
index 000000000000..154475fda01d
--- /dev/null
+++ b/multimedia/gstreamer1/pkg-plist
@@ -0,0 +1,179 @@
+bin/gst-inspect-%%VERSION%%
+bin/gst-launch-%%VERSION%%
+bin/gst-typefind-%%VERSION%%
+include/gstreamer-%%VERSION%%/gst/base/gstadapter.h
+include/gstreamer-%%VERSION%%/gst/base/gstbaseparse.h
+include/gstreamer-%%VERSION%%/gst/base/gstbasesink.h
+include/gstreamer-%%VERSION%%/gst/base/gstbasesrc.h
+include/gstreamer-%%VERSION%%/gst/base/gstbasetransform.h
+include/gstreamer-%%VERSION%%/gst/base/gstbitreader.h
+include/gstreamer-%%VERSION%%/gst/base/gstbytereader.h
+include/gstreamer-%%VERSION%%/gst/base/gstbytewriter.h
+include/gstreamer-%%VERSION%%/gst/base/gstcollectpads.h
+include/gstreamer-%%VERSION%%/gst/base/gstpushsrc.h
+include/gstreamer-%%VERSION%%/gst/base/gsttypefindhelper.h
+%%CHECK%%include/gstreamer-%%VERSION%%/gst/check/gstbufferstraw.h
+%%CHECK%%include/gstreamer-%%VERSION%%/gst/check/gstcheck.h
+%%CHECK%%include/gstreamer-%%VERSION%%/gst/check/gstconsistencychecker.h
+%%CHECK%%include/gstreamer-%%VERSION%%/gst/check/internal-check.h
+include/gstreamer-%%VERSION%%/gst/controller/gstargbcontrolbinding.h
+include/gstreamer-%%VERSION%%/gst/controller/gstdirectcontrolbinding.h
+include/gstreamer-%%VERSION%%/gst/controller/gsttimedvaluecontrolsource.h
+include/gstreamer-%%VERSION%%/gst/controller/gstinterpolationcontrolsource.h
+include/gstreamer-%%VERSION%%/gst/controller/gstlfocontrolsource.h
+include/gstreamer-%%VERSION%%/gst/controller/gsttriggercontrolsource.h
+include/gstreamer-%%VERSION%%/gst/glib-compat.h
+include/gstreamer-%%VERSION%%/gst/gst.h
+include/gstreamer-%%VERSION%%/gst/gstallocator.h
+include/gstreamer-%%VERSION%%/gst/gstatomicqueue.h
+include/gstreamer-%%VERSION%%/gst/gstbin.h
+include/gstreamer-%%VERSION%%/gst/gstbuffer.h
+include/gstreamer-%%VERSION%%/gst/gstbufferlist.h
+include/gstreamer-%%VERSION%%/gst/gstbufferpool.h
+include/gstreamer-%%VERSION%%/gst/gstbus.h
+include/gstreamer-%%VERSION%%/gst/gstcaps.h
+include/gstreamer-%%VERSION%%/gst/gstchildproxy.h
+include/gstreamer-%%VERSION%%/gst/gstclock.h
+include/gstreamer-%%VERSION%%/gst/gstcompat.h
+include/gstreamer-%%VERSION%%/gst/gstconfig.h
+include/gstreamer-%%VERSION%%/gst/gstcontrolbinding.h
+include/gstreamer-%%VERSION%%/gst/gstcontrolsource.h
+include/gstreamer-%%VERSION%%/gst/gstdatetime.h
+include/gstreamer-%%VERSION%%/gst/gstdebugutils.h
+include/gstreamer-%%VERSION%%/gst/gstelement.h
+include/gstreamer-%%VERSION%%/gst/gstelementfactory.h
+include/gstreamer-%%VERSION%%/gst/gstelementmetadata.h
+include/gstreamer-%%VERSION%%/gst/gstenumtypes.h
+include/gstreamer-%%VERSION%%/gst/gsterror.h
+include/gstreamer-%%VERSION%%/gst/gstevent.h
+include/gstreamer-%%VERSION%%/gst/gstformat.h
+include/gstreamer-%%VERSION%%/gst/gstghostpad.h
+include/gstreamer-%%VERSION%%/gst/gstinfo.h
+include/gstreamer-%%VERSION%%/gst/gstiterator.h
+include/gstreamer-%%VERSION%%/gst/gstmacros.h
+include/gstreamer-%%VERSION%%/gst/gstmemory.h
+include/gstreamer-%%VERSION%%/gst/gstmessage.h
+include/gstreamer-%%VERSION%%/gst/gstmeta.h
+include/gstreamer-%%VERSION%%/gst/gstminiobject.h
+include/gstreamer-%%VERSION%%/gst/gstobject.h
+include/gstreamer-%%VERSION%%/gst/gstpad.h
+include/gstreamer-%%VERSION%%/gst/gstpadtemplate.h
+include/gstreamer-%%VERSION%%/gst/gstparamspecs.h
+include/gstreamer-%%VERSION%%/gst/gstparse.h
+include/gstreamer-%%VERSION%%/gst/gstpipeline.h
+include/gstreamer-%%VERSION%%/gst/gstplugin.h
+include/gstreamer-%%VERSION%%/gst/gstpluginfeature.h
+include/gstreamer-%%VERSION%%/gst/gstpoll.h
+include/gstreamer-%%VERSION%%/gst/gstpreset.h
+include/gstreamer-%%VERSION%%/gst/gstquery.h
+include/gstreamer-%%VERSION%%/gst/gstregistry.h
+include/gstreamer-%%VERSION%%/gst/gstsample.h
+include/gstreamer-%%VERSION%%/gst/gstsegment.h
+include/gstreamer-%%VERSION%%/gst/gststructure.h
+include/gstreamer-%%VERSION%%/gst/gstsystemclock.h
+include/gstreamer-%%VERSION%%/gst/gsttaglist.h
+include/gstreamer-%%VERSION%%/gst/gsttagsetter.h
+include/gstreamer-%%VERSION%%/gst/gsttask.h
+include/gstreamer-%%VERSION%%/gst/gsttaskpool.h
+include/gstreamer-%%VERSION%%/gst/gsttoc.h
+include/gstreamer-%%VERSION%%/gst/gsttocsetter.h
+include/gstreamer-%%VERSION%%/gst/gsttypefind.h
+include/gstreamer-%%VERSION%%/gst/gsttypefindfactory.h
+include/gstreamer-%%VERSION%%/gst/gsturi.h
+include/gstreamer-%%VERSION%%/gst/gstutils.h
+include/gstreamer-%%VERSION%%/gst/gstvalue.h
+include/gstreamer-%%VERSION%%/gst/gstversion.h
+include/gstreamer-%%VERSION%%/gst/math-compat.h
+include/gstreamer-%%VERSION%%/gst/net/gstnet.h
+include/gstreamer-%%VERSION%%/gst/net/gstnetaddressmeta.h
+include/gstreamer-%%VERSION%%/gst/net/gstnetclientclock.h
+include/gstreamer-%%VERSION%%/gst/net/gstnettimepacket.h
+include/gstreamer-%%VERSION%%/gst/net/gstnettimeprovider.h
+lib/girepository-1.0/Gst-%%VERSION%%.typelib
+lib/girepository-1.0/GstBase-%%VERSION%%.typelib
+%%CHECK%%lib/girepository-1.0/GstCheck-%%VERSION%%.typelib
+lib/girepository-1.0/GstController-%%VERSION%%.typelib
+lib/girepository-1.0/GstNet-%%VERSION%%.typelib
+lib/gstreamer-%%VERSION%%/libgstcoreelements.la
+lib/gstreamer-%%VERSION%%/libgstcoreelements.so
+lib/libgstbase-%%VERSION%%.a
+lib/libgstbase-%%VERSION%%.la
+lib/libgstbase-%%VERSION%%.so
+lib/libgstbase-%%VERSION%%.so.0
+%%CHECK%%lib/libgstcheck-%%VERSION%%.a
+%%CHECK%%lib/libgstcheck-%%VERSION%%.la
+%%CHECK%%lib/libgstcheck-%%VERSION%%.so
+%%CHECK%%lib/libgstcheck-%%VERSION%%.so.0
+lib/libgstcontroller-%%VERSION%%.a
+lib/libgstcontroller-%%VERSION%%.la
+lib/libgstcontroller-%%VERSION%%.so
+lib/libgstcontroller-%%VERSION%%.so.0
+lib/libgstnet-%%VERSION%%.a
+lib/libgstnet-%%VERSION%%.la
+lib/libgstnet-%%VERSION%%.so
+lib/libgstnet-%%VERSION%%.so.0
+lib/libgstreamer-%%VERSION%%.a
+lib/libgstreamer-%%VERSION%%.la
+lib/libgstreamer-%%VERSION%%.so
+lib/libgstreamer-%%VERSION%%.so.0
+libdata/pkgconfig/gstreamer-%%VERSION%%.pc
+libdata/pkgconfig/gstreamer-base-%%VERSION%%.pc
+%%CHECK%%libdata/pkgconfig/gstreamer-check-%%VERSION%%.pc
+libdata/pkgconfig/gstreamer-controller-%%VERSION%%.pc
+libdata/pkgconfig/gstreamer-net-%%VERSION%%.pc
+libexec/gstreamer-%%VERSION%%/gst-plugin-scanner
+share/aclocal/gst-element-check-%%VERSION%%.m4
+share/gir-1.0/Gst-%%VERSION%%.gir
+share/gir-1.0/GstBase-%%VERSION%%.gir
+%%CHECK%%share/gir-1.0/GstCheck-%%VERSION%%.gir
+share/gir-1.0/GstController-%%VERSION%%.gir
+share/gir-1.0/GstNet-%%VERSION%%.gir
+share/locale/af/LC_MESSAGES/gstreamer-%%VERSION%%.mo
+share/locale/az/LC_MESSAGES/gstreamer-%%VERSION%%.mo
+share/locale/be/LC_MESSAGES/gstreamer-%%VERSION%%.mo
+share/locale/bg/LC_MESSAGES/gstreamer-%%VERSION%%.mo
+share/locale/ca/LC_MESSAGES/gstreamer-%%VERSION%%.mo
+share/locale/cs/LC_MESSAGES/gstreamer-%%VERSION%%.mo
+share/locale/da/LC_MESSAGES/gstreamer-%%VERSION%%.mo
+share/locale/de/LC_MESSAGES/gstreamer-%%VERSION%%.mo
+share/locale/el/LC_MESSAGES/gstreamer-%%VERSION%%.mo
+share/locale/en_GB/LC_MESSAGES/gstreamer-%%VERSION%%.mo
+share/locale/eo/LC_MESSAGES/gstreamer-%%VERSION%%.mo
+share/locale/eu/LC_MESSAGES/gstreamer-%%VERSION%%.mo
+share/locale/es/LC_MESSAGES/gstreamer-%%VERSION%%.mo
+share/locale/fi/LC_MESSAGES/gstreamer-%%VERSION%%.mo
+share/locale/fr/LC_MESSAGES/gstreamer-%%VERSION%%.mo
+share/locale/gl/LC_MESSAGES/gstreamer-%%VERSION%%.mo
+share/locale/hr/LC_MESSAGES/gstreamer-%%VERSION%%.mo
+share/locale/hu/LC_MESSAGES/gstreamer-%%VERSION%%.mo
+share/locale/id/LC_MESSAGES/gstreamer-%%VERSION%%.mo
+share/locale/it/LC_MESSAGES/gstreamer-%%VERSION%%.mo
+share/locale/ja/LC_MESSAGES/gstreamer-%%VERSION%%.mo
+share/locale/lt/LC_MESSAGES/gstreamer-%%VERSION%%.mo
+share/locale/nb/LC_MESSAGES/gstreamer-%%VERSION%%.mo
+share/locale/nl/LC_MESSAGES/gstreamer-%%VERSION%%.mo
+share/locale/pl/LC_MESSAGES/gstreamer-%%VERSION%%.mo
+share/locale/pt_BR/LC_MESSAGES/gstreamer-%%VERSION%%.mo
+share/locale/ro/LC_MESSAGES/gstreamer-%%VERSION%%.mo
+share/locale/ru/LC_MESSAGES/gstreamer-%%VERSION%%.mo
+share/locale/rw/LC_MESSAGES/gstreamer-%%VERSION%%.mo
+share/locale/sk/LC_MESSAGES/gstreamer-%%VERSION%%.mo
+share/locale/sl/LC_MESSAGES/gstreamer-%%VERSION%%.mo
+share/locale/sq/LC_MESSAGES/gstreamer-%%VERSION%%.mo
+share/locale/sr/LC_MESSAGES/gstreamer-%%VERSION%%.mo
+share/locale/sv/LC_MESSAGES/gstreamer-%%VERSION%%.mo
+share/locale/tr/LC_MESSAGES/gstreamer-%%VERSION%%.mo
+share/locale/uk/LC_MESSAGES/gstreamer-%%VERSION%%.mo
+share/locale/vi/LC_MESSAGES/gstreamer-%%VERSION%%.mo
+share/locale/zh_CN/LC_MESSAGES/gstreamer-%%VERSION%%.mo
+share/locale/zh_TW/LC_MESSAGES/gstreamer-%%VERSION%%.mo
+@dirrmtry share/locale/rw/LC_MESSAGES
+@dirrmtry share/locale/rw
+@dirrm libexec/gstreamer-%%VERSION%%
+@dirrm lib/gstreamer-%%VERSION%%
+@dirrm include/gstreamer-%%VERSION%%/gst/net
+@dirrm include/gstreamer-%%VERSION%%/gst/controller
+%%CHECK%%@dirrm include/gstreamer-%%VERSION%%/gst/check
+@dirrm include/gstreamer-%%VERSION%%/gst/base
+@dirrm include/gstreamer-%%VERSION%%/gst
+@dirrm include/gstreamer-%%VERSION%%