aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gstreamer80
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-02-05 18:20:43 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-02-05 18:20:43 +0000
commit7e7d6898ef5b4821fe30c527280a949979bf7660 (patch)
tree0bb72ba6c823475b4c44a505cc6f6949041e725f /multimedia/gstreamer80
parentfc5b5860f412a36c544c5a8fdbc4c35bf93e157a (diff)
downloadports-7e7d6898ef5b4821fe30c527280a949979bf7660.tar.gz
ports-7e7d6898ef5b4821fe30c527280a949979bf7660.zip
Notes
Diffstat (limited to 'multimedia/gstreamer80')
-rw-r--r--multimedia/gstreamer80/Makefile32
-rw-r--r--multimedia/gstreamer80/distinfo2
-rw-r--r--multimedia/gstreamer80/files/patch-configure15
-rw-r--r--multimedia/gstreamer80/files/patch-gst::cothreads.c20
-rw-r--r--multimedia/gstreamer80/pkg-plist176
5 files changed, 130 insertions, 115 deletions
diff --git a/multimedia/gstreamer80/Makefile b/multimedia/gstreamer80/Makefile
index 5f29fdc44f5f..46343f66b4a8 100644
--- a/multimedia/gstreamer80/Makefile
+++ b/multimedia/gstreamer80/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gstreamer
-PORTVERSION= 0.4.2
+PORTVERSION= 0.6.0
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -34,6 +34,9 @@ CONFIGURE_ENV= PKG_CONFIG=${PKG_CONFIG} \
CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
CONFIGURE_TARGET=
+PLIST_SUB= \
+ VERSION="${PORTVERSION:C/..$//}" \
+ SHLIB_VERSION="${SHLIB_VERSION}"
INSTALLS_SHLIB= yes
MAN1= gst-complete.1 gst-compprep.1 gst-inspect.1 gst-launch.1 \
@@ -42,26 +45,17 @@ MAN1= gst-complete.1 gst-compprep.1 gst-inspect.1 gst-launch.1 \
PKG_CONFIG?="${LOCALBASE}/bin/pkg-config"
-post-patch:
-# use proper dir
-# remove version number from include dir name
- @${FIND} ${WRKSRC} -type f -name Makefile.in | \
- ${XARGS} -n 10 ${REINPLACE_CMD} -E \
- 's|^(lib[[:alpha:]]+includedir.+)-@VERSION@|\1|'
-# remove version number from include dir name AND
-# help dependent ports find popt.h
- @${REINPLACE_CMD} -E -e \
- 's|-@VERSION@||; \
- s|(-I\$${includedir})|\1 -I${LOCALBASE}/include|' \
- ${WRKSRC}/gstreamer.pc.in
-
-post-configure:
-# remove version number postfix from library names
- @${REINPLACE_CMD} -E -e 's|-release ${PORTVERSION}||' \
- ${WRKSRC}/gst/Makefile ${WRKSRC}/libs/gst/control/Makefile
+# library minor number
+SHLIB_VERSION= 0
post-install:
# register plugins
@${PREFIX}/bin/gst-register 2>/dev/null
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if exists(${X11BASE}/libdata/pkgconfig/libgnomeui-2.0.pc)
+LIB_DEPENDS+= gnomeui-2.0:${PORTSDIR}/x11-toolkits/libgnomeui
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/multimedia/gstreamer80/distinfo b/multimedia/gstreamer80/distinfo
index 209ebc90fac9..e747bb09183f 100644
--- a/multimedia/gstreamer80/distinfo
+++ b/multimedia/gstreamer80/distinfo
@@ -1 +1 @@
-MD5 (gstreamer-0.4.2.tar.bz2) = c9e4eed8bac71f52044e2b28356c81ef
+MD5 (gstreamer-0.6.0.tar.bz2) = 3d0dec37678b33bbcb23cb2e20a83fe4
diff --git a/multimedia/gstreamer80/files/patch-configure b/multimedia/gstreamer80/files/patch-configure
index 4e3e5d1953d8..b3935c7cb3df 100644
--- a/multimedia/gstreamer80/files/patch-configure
+++ b/multimedia/gstreamer80/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig Wed Jul 10 16:32:49 2002
-+++ configure Wed Jul 10 16:33:12 2002
-@@ -6620,6 +6620,7 @@
+--- configure.orig Wed Jan 22 09:17:40 2003
++++ configure Wed Jan 29 14:49:56 2003
+@@ -7520,6 +7520,7 @@
# This can be used to rebuild libtool when needed
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
@@ -8,3 +8,12 @@
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
+@@ -7712,7 +7713,7 @@
+ if test "x$COMPILER" = "xforte"; then
+ GST_ERROR=
+ else
+- if test "x$GST_CVS"="xyes"; then
++ if test "x$GST_CVS" = "xyes"; then
+ GST_ERROR="-Wall -Werror"
+ else
+ GST_ERROR="-Wall"
diff --git a/multimedia/gstreamer80/files/patch-gst::cothreads.c b/multimedia/gstreamer80/files/patch-gst::cothreads.c
index aed13b1a7891..3519fb0e7e01 100644
--- a/multimedia/gstreamer80/files/patch-gst::cothreads.c
+++ b/multimedia/gstreamer80/files/patch-gst::cothreads.c
@@ -1,6 +1,15 @@
---- gst/cothreads.c.orig Wed Nov 13 22:59:21 2002
-+++ gst/cothreads.c Wed Nov 13 22:59:38 2002
-@@ -41,11 +41,11 @@
+--- gst/cothreads.c.orig Sat Feb 1 19:09:00 2003
++++ gst/cothreads.c Mon Feb 3 10:57:44 2003
+@@ -41,12 +41,16 @@
+ #include <ucontext.h>
+ #endif
+
++#ifdef HAVE_MAKECONTEXT
++#include <ucontext.h>
++#endif
++
+ /* older glibc's have MAP_ANON instead of MAP_ANONYMOUS */
+ #ifndef MAP_ANONYMOUS
#define MAP_ANONYMOUS MAP_ANON
#endif
@@ -9,8 +18,3 @@
#define COTHREAD_MAGIC_NUMBER 0xabcdef
--#define COTHREAD_MAXTHREADS 16
-+#define COTHREAD_MAXTHREADS 8
- #define COTHREAD_STACKSIZE (STACK_SIZE/COTHREAD_MAXTHREADS)
-
- static void cothread_destroy (cothread_state *thread);
diff --git a/multimedia/gstreamer80/pkg-plist b/multimedia/gstreamer80/pkg-plist
index 4486c146ffd1..b42f950edaa1 100644
--- a/multimedia/gstreamer80/pkg-plist
+++ b/multimedia/gstreamer80/pkg-plist
@@ -1,4 +1,4 @@
-@unexec %D/bin/gst-register 2>/dev/null
+@unexec %D/bin/gst-register 2>/dev/null || true
bin/gst-complete
bin/gst-compprep
bin/gst-feedback
@@ -7,86 +7,94 @@ bin/gst-launch
bin/gst-md5sum
bin/gst-register
bin/gst-xmllaunch
-include/gstreamer/gst/bytestream/bytestream.h
-include/gstreamer/gst/control/control.h
-include/gstreamer/gst/control/dparam.h
-include/gstreamer/gst/control/dparam_smooth.h
-include/gstreamer/gst/control/dparamcommon.h
-include/gstreamer/gst/control/dparammanager.h
-include/gstreamer/gst/control/dplinearinterp.h
-include/gstreamer/gst/control/unitconvert.h
-include/gstreamer/gst/getbits/getbits.h
-include/gstreamer/gst/gst.h
-include/gstreamer/gst/gstatomic.h
-include/gstreamer/gst/gstautoplug.h
-include/gstreamer/gst/gstbin.h
-include/gstreamer/gst/gstbuffer.h
-include/gstreamer/gst/gstbufferpool-default.h
-include/gstreamer/gst/gstcaps.h
-include/gstreamer/gst/gstclock.h
-include/gstreamer/gst/gstconfig.h
-include/gstreamer/gst/gstcpu.h
-include/gstreamer/gst/gstdata.h
-include/gstreamer/gst/gstelement.h
-include/gstreamer/gst/gstenumtypes.h
-include/gstreamer/gst/gstevent.h
-include/gstreamer/gst/gstextratypes.h
-include/gstreamer/gst/gstformat.h
-include/gstreamer/gst/gstinfo.h
-include/gstreamer/gst/gstlog.h
-include/gstreamer/gst/gstmarshal.h
-include/gstreamer/gst/gstmemchunk.h
-include/gstreamer/gst/gstobject.h
-include/gstreamer/gst/gstpad.h
-include/gstreamer/gst/gstparse.h
-include/gstreamer/gst/gstpipeline.h
-include/gstreamer/gst/gstplugin.h
-include/gstreamer/gst/gstpluginfeature.h
-include/gstreamer/gst/gstprops.h
-include/gstreamer/gst/gstqueue.h
-include/gstreamer/gst/gstregistry.h
-include/gstreamer/gst/gstscheduler.h
-include/gstreamer/gst/gstsystemclock.h
-include/gstreamer/gst/gstthread.h
-include/gstreamer/gst/gsttimecache.h
-include/gstreamer/gst/gsttrace.h
-include/gstreamer/gst/gsttype.h
-include/gstreamer/gst/gsttypefind.h
-include/gstreamer/gst/gsttypes.h
-include/gstreamer/gst/gstutils.h
-include/gstreamer/gst/gstversion.h
-include/gstreamer/gst/gstxml.h
-include/gstreamer/gst/putbits/putbits.h
-lib/gst/libgstautoplugcache.so
-lib/gst/libgstautoplugger.so
-lib/gst/libgstbasicomegascheduler.so
-lib/gst/libgstbasicwingoscheduler.so
-lib/gst/libgstbytestream.so
-lib/gst/libgstelements.so
-lib/gst/libgstfastomegascheduler.so
-lib/gst/libgstfastwingoscheduler.so
-lib/gst/libgstgetbits.so
-lib/gst/libgstoptomegascheduler.so
-lib/gst/libgstputbits.so
-lib/gst/libgstspider.so
-lib/gst/libgststaticautoplug.so
-lib/gst/libgststaticautoplugrender.so
-lib/gst/libgsttypes.so
-lib/libgstcontrol.a
-lib/libgstcontrol.so
-lib/libgstcontrol.so.0
-lib/libgstreamer.a
-lib/libgstreamer.so
-lib/libgstreamer.so.0
-libdata/pkgconfig/gstreamer.pc
-@unexec rmdir %D/libdata/pkgconfig 2>/dev/null || true
-@dirrm lib/gst
-@dirrm include/gstreamer/gst/putbits
-@dirrm include/gstreamer/gst/getbits
-@dirrm include/gstreamer/gst/control
-@dirrm include/gstreamer/gst/bytestream
-@dirrm include/gstreamer/gst
-@dirrm include/gstreamer
-@exec %D/bin/gst-register 2>/dev/null
-@unexec rm %D/etc/gstreamer/registry.xml 2>/dev/null || true
-@unexec rmdir %D/etc/gstreamer 2>/dev/null || echo "There are some configuration files left in ${PKG_PREFIX}/etc/gstreamer, do not forget to remove them if you are permanently removing gstreamer port."
+include/gstreamer-%%VERSION%%/gst/bytestream/bytestream.h
+include/gstreamer-%%VERSION%%/gst/control/control.h
+include/gstreamer-%%VERSION%%/gst/control/dparam.h
+include/gstreamer-%%VERSION%%/gst/control/dparam_smooth.h
+include/gstreamer-%%VERSION%%/gst/control/dparamcommon.h
+include/gstreamer-%%VERSION%%/gst/control/dparammanager.h
+include/gstreamer-%%VERSION%%/gst/control/dplinearinterp.h
+include/gstreamer-%%VERSION%%/gst/control/unitconvert.h
+include/gstreamer-%%VERSION%%/gst/getbits/getbits.h
+include/gstreamer-%%VERSION%%/gst/gst.h
+include/gstreamer-%%VERSION%%/gst/gstatomic.h
+include/gstreamer-%%VERSION%%/gst/gstautoplug.h
+include/gstreamer-%%VERSION%%/gst/gstbin.h
+include/gstreamer-%%VERSION%%/gst/gstbuffer.h
+include/gstreamer-%%VERSION%%/gst/gstbufferpool-default.h
+include/gstreamer-%%VERSION%%/gst/gstcaps.h
+include/gstreamer-%%VERSION%%/gst/gstclock.h
+include/gstreamer-%%VERSION%%/gst/gstcompat.h
+include/gstreamer-%%VERSION%%/gst/gstconfig.h
+include/gstreamer-%%VERSION%%/gst/gstcpu.h
+include/gstreamer-%%VERSION%%/gst/gstdata.h
+include/gstreamer-%%VERSION%%/gst/gstelement.h
+include/gstreamer-%%VERSION%%/gst/gstenumtypes.h
+include/gstreamer-%%VERSION%%/gst/gstevent.h
+include/gstreamer-%%VERSION%%/gst/gstextratypes.h
+include/gstreamer-%%VERSION%%/gst/gstformat.h
+include/gstreamer-%%VERSION%%/gst/gstindex.h
+include/gstreamer-%%VERSION%%/gst/gstinfo.h
+include/gstreamer-%%VERSION%%/gst/gstlog.h
+include/gstreamer-%%VERSION%%/gst/gstmacros.h
+include/gstreamer-%%VERSION%%/gst/gstmarshal.h
+include/gstreamer-%%VERSION%%/gst/gstmemchunk.h
+include/gstreamer-%%VERSION%%/gst/gstobject.h
+include/gstreamer-%%VERSION%%/gst/gstpad.h
+include/gstreamer-%%VERSION%%/gst/gstparse.h
+include/gstreamer-%%VERSION%%/gst/gstpipeline.h
+include/gstreamer-%%VERSION%%/gst/gstplugin.h
+include/gstreamer-%%VERSION%%/gst/gstpluginfeature.h
+include/gstreamer-%%VERSION%%/gst/gstprobe.h
+include/gstreamer-%%VERSION%%/gst/gstprops.h
+include/gstreamer-%%VERSION%%/gst/gstquery.h
+include/gstreamer-%%VERSION%%/gst/gstqueue.h
+include/gstreamer-%%VERSION%%/gst/gstregistry.h
+include/gstreamer-%%VERSION%%/gst/gstscheduler.h
+include/gstreamer-%%VERSION%%/gst/gstsystemclock.h
+include/gstreamer-%%VERSION%%/gst/gstthread.h
+include/gstreamer-%%VERSION%%/gst/gsttrace.h
+include/gstreamer-%%VERSION%%/gst/gsttrashstack.h
+include/gstreamer-%%VERSION%%/gst/gsttype.h
+include/gstreamer-%%VERSION%%/gst/gsttypefind.h
+include/gstreamer-%%VERSION%%/gst/gsttypes.h
+include/gstreamer-%%VERSION%%/gst/gsturi.h
+include/gstreamer-%%VERSION%%/gst/gstutils.h
+include/gstreamer-%%VERSION%%/gst/gstversion.h
+include/gstreamer-%%VERSION%%/gst/gstxml.h
+include/gstreamer-%%VERSION%%/gst/putbits/putbits.h
+lib/gstreamer-%%VERSION%%/libgstautoplugcache.so
+lib/gstreamer-%%VERSION%%/libgstautoplugger.so
+lib/gstreamer-%%VERSION%%/libgstbasicomegascheduler.so
+lib/gstreamer-%%VERSION%%/libgstbasicwingoscheduler.so
+lib/gstreamer-%%VERSION%%/libgstbytestream.so
+lib/gstreamer-%%VERSION%%/libgstelements.so
+lib/gstreamer-%%VERSION%%/libgstgetbits.so
+lib/gstreamer-%%VERSION%%/libgstindexers.so
+lib/gstreamer-%%VERSION%%/libgstoptomegascheduler.so
+lib/gstreamer-%%VERSION%%/libgstoptscheduler.so
+lib/gstreamer-%%VERSION%%/libgstoptwingoscheduler.so
+lib/gstreamer-%%VERSION%%/libgstputbits.so
+lib/gstreamer-%%VERSION%%/libgstspider.so
+lib/gstreamer-%%VERSION%%/libgststaticautoplug.so
+lib/gstreamer-%%VERSION%%/libgststaticautoplugrender.so
+lib/gstreamer-%%VERSION%%/libgsttypes.so
+lib/libgstcontrol-%%VERSION%%.a
+lib/libgstcontrol-%%VERSION%%.so
+lib/libgstcontrol-%%VERSION%%.so.%%SHLIB_VERSION%%
+lib/libgstreamer-%%VERSION%%.a
+lib/libgstreamer-%%VERSION%%.so
+lib/libgstreamer-%%VERSION%%.so.%%SHLIB_VERSION%%
+libdata/pkgconfig/gstreamer-%%VERSION%%.pc
+libdata/pkgconfig/gstreamer-control-%%VERSION%%.pc
+@unexec rm %D/share/gnome/cache/gstreamer-%%VERSION%%/registry.xml 2>/dev/null || true
+@dirrm share/gnome/cache/gstreamer-%%VERSION%%
+@unexec rmdir %D/share/gnome/cache 2>/dev/null || true
+@dirrm lib/gstreamer-%%VERSION%%
+@dirrm include/gstreamer-%%VERSION%%/gst/putbits
+@dirrm include/gstreamer-%%VERSION%%/gst/getbits
+@dirrm include/gstreamer-%%VERSION%%/gst/control
+@dirrm include/gstreamer-%%VERSION%%/gst/bytestream
+@dirrm include/gstreamer-%%VERSION%%/gst
+@dirrm include/gstreamer-%%VERSION%%
+@exec %D/bin/gst-register 2>/dev/null || true