aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gstreamer80
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-04-05 03:11:39 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-04-05 03:11:39 +0000
commitc4851e78e4f63338fe9a4883e5b7a0370dce27f7 (patch)
tree3910aa2e83f782cec94f15b4547dadb741cd29ce /multimedia/gstreamer80
parentf82c84522b047dd99c6f9d85ce3e07217ccce7df (diff)
Notes
Diffstat (limited to 'multimedia/gstreamer80')
-rw-r--r--multimedia/gstreamer80/Makefile27
-rw-r--r--multimedia/gstreamer80/distinfo4
-rw-r--r--multimedia/gstreamer80/files/patch-configure30
-rw-r--r--multimedia/gstreamer80/files/patch-gst::cothreads.c12
-rw-r--r--multimedia/gstreamer80/files/patch-gst::gstthreaddummy.c10
-rw-r--r--multimedia/gstreamer80/files/patch-libs::ext::cothreads::cothreads::cothreads.c19
-rw-r--r--multimedia/gstreamer80/files/patch-libs::ext::cothreads::tests::Makefile.in11
-rw-r--r--multimedia/gstreamer80/files/patch-ltmain.sh30
-rw-r--r--multimedia/gstreamer80/pkg-plist44
9 files changed, 86 insertions, 101 deletions
diff --git a/multimedia/gstreamer80/Makefile b/multimedia/gstreamer80/Makefile
index 3f7a4303ae02..e523e02d7034 100644
--- a/multimedia/gstreamer80/Makefile
+++ b/multimedia/gstreamer80/Makefile
@@ -6,11 +6,12 @@
#
PORTNAME= gstreamer
-PORTVERSION= 0.6.4
-PORTREVISION= 2
+PORTVERSION= 0.8.0
+PORTREVISION= 1
CATEGORIES= multimedia
-MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.6
+MASTER_SITES= ${MASTER_SITE_GNOME} \
+ http://gstreamer.freedesktop.org/src/gstreamer/
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.8
DIST_SUBDIR= gnome2
MAINTAINER= lioux@FreeBSD.org
@@ -21,39 +22,41 @@ LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
USE_X_PREFIX= yes
USE_BISON= yes
USE_BZIP2= yes
+USE_PYTHON= yes
USE_GMAKE= yes
+USE_REINPLACE= yes
WANT_GNOME= yes
USE_GNOME= gnomehack \
gnomeprefix \
glib20 \
pkgconfig \
libxml2
-USE_SIZE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-tests \
--disable-failing-tests
CONFIGURE_ENV= PKG_CONFIG=${PKG_CONFIG} \
CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
-CONFIGURE_TARGET=
PLIST_SUB= \
- VERSION="${PORTVERSION:C/..$//}" \
+ VERSION="${GST_VERSION}" \
SHLIB_VERSION="${SHLIB_VERSION}"
INSTALLS_SHLIB= yes
-MAN1= gst-complete.1 gst-compprep.1 gst-inspect.1 gst-launch.1 \
- gst-feedback.1 gst-md5sum.1 \
- gst-typefind.1 \
- gst-register.1 gst-xmllaunch.1
+MAN1= gst-complete-${GST_VERSION}.1 gst-compprep-${GST_VERSION}.1 \
+ gst-feedback-${GST_VERSION}.1 gst-inspect-${GST_VERSION}.1 \
+ gst-launch-${GST_VERSION}.1 gst-md5sum-${GST_VERSION}.1 \
+ gst-register-${GST_VERSION}.1 gst-typefind-${GST_VERSION}.1 \
+ gst-xmllaunch-${GST_VERSION}.1
PKG_CONFIG?="${LOCALBASE}/bin/pkg-config"
+GST_VERSION=${PORTVERSION:C/..$//}
# library minor number
SHLIB_VERSION= 1
post-install:
# register plugins
- @${PREFIX}/bin/gst-register 2>/dev/null
+ -@${PREFIX}/bin/gst-register-${GST_VERSION} 2>/dev/null
.include <bsd.port.pre.mk>
diff --git a/multimedia/gstreamer80/distinfo b/multimedia/gstreamer80/distinfo
index 2fd78bcd5366..a0fd0e772b25 100644
--- a/multimedia/gstreamer80/distinfo
+++ b/multimedia/gstreamer80/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/gstreamer-0.6.4.tar.bz2) = d607f42d4a6de9e79d74ccaa6469ded6
-SIZE (gnome2/gstreamer-0.6.4.tar.bz2) = 1108361
+MD5 (gnome2/gstreamer-0.8.0.tar.bz2) = 275384c4001c6b934f159952f39e2f36
+SIZE (gnome2/gstreamer-0.8.0.tar.bz2) = 1120465
diff --git a/multimedia/gstreamer80/files/patch-configure b/multimedia/gstreamer80/files/patch-configure
index 11e54cb76694..4dafb1ddde0d 100644
--- a/multimedia/gstreamer80/files/patch-configure
+++ b/multimedia/gstreamer80/files/patch-configure
@@ -1,6 +1,15 @@
---- configure.orig Sat Sep 27 14:13:57 2003
-+++ configure Sat Sep 27 14:18:37 2003
-@@ -8173,7 +8173,7 @@
+--- configure.orig Thu Feb 26 14:03:31 2004
++++ configure Thu Feb 26 14:03:31 2004
+@@ -21858,7 +21858,7 @@
+
+
+ EXP_VAR=LOCALEDIR
+- FROM_VAR=$datadir/locale
++ FROM_VAR=$prefix/share/locale
+
+ prefix_save=$prefix
+ exec_prefix_save=$exec_prefix
+@@ -21961,7 +21961,7 @@
echo $ECHO_N "checking to see if compiler understands -Werror... $ECHO_C" >&6
save_CFLAGS="$CFLAGS"
@@ -8,8 +17,8 @@
+ CFLAGS="$CFLAGS"
cat >conftest.$ac_ext <<_ACEOF
- #line $LINENO "configure"
-@@ -8214,7 +8214,7 @@
+ /* confdefs.h. */
+@@ -22011,7 +22011,7 @@
CFLAGS="$save_CFLAGS"
if test "X$flag_ok" = Xyes ; then
@@ -17,13 +26,4 @@
+ GST_ERROR="$GST_ERROR"
true
else
-
-@@ -9607,7 +9607,7 @@
- :
- fi
-
--if test "$ac_cv_check_mcsc" == "yes"; then
-+if test "$ac_cv_check_mcsc" = "yes"; then
-
- cat >>confdefs.h <<_ACEOF
- #define HAVE_MAKECONTEXT $HAVE_MAKECONTEXT
+ GST_ERROR="$GST_ERROR"
diff --git a/multimedia/gstreamer80/files/patch-gst::cothreads.c b/multimedia/gstreamer80/files/patch-gst::cothreads.c
index 3519fb0e7e01..b66b7062f37b 100644
--- a/multimedia/gstreamer80/files/patch-gst::cothreads.c
+++ b/multimedia/gstreamer80/files/patch-gst::cothreads.c
@@ -1,6 +1,6 @@
---- gst/cothreads.c.orig Sat Feb 1 19:09:00 2003
-+++ gst/cothreads.c Mon Feb 3 10:57:44 2003
-@@ -41,12 +41,16 @@
+--- gst/cothreads.c.orig Mon Feb 2 06:56:53 2004
++++ gst/cothreads.c Fri Feb 6 13:05:26 2004
+@@ -42,6 +42,10 @@
#include <ucontext.h>
#endif
@@ -8,9 +8,11 @@
+#include <ucontext.h>
+#endif
+
- /* older glibc's have MAP_ANON instead of MAP_ANONYMOUS */
#ifndef MAP_ANONYMOUS
- #define MAP_ANONYMOUS MAP_ANON
+ #ifdef MAP_ANON
+ /* older glibc's have MAP_ANON instead of MAP_ANONYMOUS */
+@@ -52,7 +56,7 @@
+ #endif
#endif
-#define STACK_SIZE 0x200000
diff --git a/multimedia/gstreamer80/files/patch-gst::gstthreaddummy.c b/multimedia/gstreamer80/files/patch-gst::gstthreaddummy.c
index 479a05ba9c9b..71bace4805c9 100644
--- a/multimedia/gstreamer80/files/patch-gst::gstthreaddummy.c
+++ b/multimedia/gstreamer80/files/patch-gst::gstthreaddummy.c
@@ -1,12 +1,10 @@
---- gst/gstthreaddummy.c.orig Sat Aug 30 19:30:10 2003
-+++ gst/gstthreaddummy.c Sat Aug 30 19:30:34 2003
-@@ -17,7 +17,9 @@
+--- gst/gstthreaddummy.c.orig Mon Jun 30 14:31:13 2003
++++ gst/gstthreaddummy.c Fri Nov 14 15:36:22 2003
+@@ -17,6 +17,7 @@
* Boston, MA 02111-1307, USA.
*/
+#include <sys/types.h>
+ #include <unistd.h>
#include <sys/time.h>
-+#include <unistd.h>
#include <glib.h>
- #include "gstlog.h"
-
diff --git a/multimedia/gstreamer80/files/patch-libs::ext::cothreads::cothreads::cothreads.c b/multimedia/gstreamer80/files/patch-libs::ext::cothreads::cothreads::cothreads.c
deleted file mode 100644
index e0e229f97524..000000000000
--- a/multimedia/gstreamer80/files/patch-libs::ext::cothreads::cothreads::cothreads.c
+++ /dev/null
@@ -1,19 +0,0 @@
---- libs/ext/cothreads/cothreads/cothreads.c.orig Sat Feb 1 16:09:23 2003
-+++ libs/ext/cothreads/cothreads/cothreads.c Mon Mar 17 13:33:43 2003
-@@ -22,6 +22,7 @@
-
- #include "pth_p.h" /* this pulls in everything */
- #include <sys/mman.h>
-+#include <sys/time.h>
- #include <sys/resource.h>
- #include <stdlib.h>
-
-@@ -422,7 +423,7 @@
- *stack = malloc (_cothreads_chunk_size * (1.0 + 1.0/_cothreads_count));
- if (!stack)
- return FALSE;
-- *stack = (void*)((int)*stack &~ (int)(_cothreads_chunk_size / _cothreads_count - 1));
-+ *stack = (void*)((intptr_t)*stack &~ (intptr_t)(_cothreads_chunk_size / _cothreads_count - 1));
- *stack += 1;
- #endif
-
diff --git a/multimedia/gstreamer80/files/patch-libs::ext::cothreads::tests::Makefile.in b/multimedia/gstreamer80/files/patch-libs::ext::cothreads::tests::Makefile.in
deleted file mode 100644
index 4470b93eef61..000000000000
--- a/multimedia/gstreamer80/files/patch-libs::ext::cothreads::tests::Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- libs/ext/cothreads/tests/Makefile.in.orig Mon Oct 13 15:10:38 2003
-+++ libs/ext/cothreads/tests/Makefile.in Mon Oct 13 15:11:13 2003
-@@ -83,7 +83,7 @@
- GLIB_CFLAGS = @GLIB_CFLAGS@
- GLIB_LIBS = @GLIB_LIBS@
- GTHREAD_CFLAGS = @GTHREAD_CFLAGS@
--GTHREAD_LIBS = @GTHREAD_LIBS@
-+GTHREAD_LIBS = -lc @GTHREAD_LIBS@
- INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
- LIBTOOL = @LIBTOOL@
- LN_S = @LN_S@
diff --git a/multimedia/gstreamer80/files/patch-ltmain.sh b/multimedia/gstreamer80/files/patch-ltmain.sh
index 284a2d7b15df..9b5b1ec3b9aa 100644
--- a/multimedia/gstreamer80/files/patch-ltmain.sh
+++ b/multimedia/gstreamer80/files/patch-ltmain.sh
@@ -1,15 +1,15 @@
---- ltmain.sh.orig Mon Oct 13 14:17:09 2003
-+++ ltmain.sh Sat Feb 21 15:44:32 2004
-@@ -1075,7 +1075,7 @@
+--- ltmain.sh.orig Tue Oct 28 09:26:50 2003
++++ ltmain.sh Sat Feb 21 15:30:25 2004
+@@ -1280,7 +1280,7 @@
esac
- elif test "X$arg" = "X-lc_r"; then
- case $host in
+ elif test "X$arg" = "X-lc_r"; then
+ case $host in
- *-*-openbsd* | *-*-freebsd*)
+ *-*-openbsd* | *-*-freebsd4*)
- # Do not include libc_r directly, use -pthread flag.
- continue
- ;;
-@@ -1085,8 +1085,16 @@
+ # Do not include libc_r directly, use -pthread flag.
+ continue
+ ;;
+@@ -1290,8 +1290,16 @@
continue
;;
@@ -26,17 +26,17 @@
continue
;;
-@@ -2503,6 +2511,9 @@
- *-*-openbsd* | *-*-freebsd*)
- # Do not include libc due to us having libc/libc_r.
+@@ -3000,6 +3008,9 @@
+ # problems, so we reset it completely
+ verstring=
;;
+ *-*-freebsd*)
+ # FreeBSD doesn't need this...
+ ;;
*)
- # Add libc to deplibs on all other systems if necessary.
- if test $build_libtool_need_lc = "yes"; then
-@@ -4330,10 +4341,12 @@
+ verstring="0.0"
+ ;;
+@@ -5428,10 +5439,12 @@
fi
# Install the pseudo-library for information purposes.
diff --git a/multimedia/gstreamer80/pkg-plist b/multimedia/gstreamer80/pkg-plist
index bb840023d420..1e43cd5e04cf 100644
--- a/multimedia/gstreamer80/pkg-plist
+++ b/multimedia/gstreamer80/pkg-plist
@@ -1,13 +1,23 @@
-@unexec %D/bin/gst-register 2>/dev/null || true
bin/gst-complete
+bin/gst-complete-%%VERSION%%
bin/gst-compprep
+bin/gst-compprep-%%VERSION%%
bin/gst-feedback
+bin/gst-feedback-%%VERSION%%
bin/gst-inspect
+bin/gst-inspect-%%VERSION%%
bin/gst-launch
+bin/gst-launch-%%VERSION%%
bin/gst-md5sum
+bin/gst-md5sum-%%VERSION%%
bin/gst-register
+bin/gst-register-%%VERSION%%
bin/gst-typefind
+bin/gst-typefind-%%VERSION%%
+bin/gst-xmlinspect
+bin/gst-xmlinspect-%%VERSION%%
bin/gst-xmllaunch
+bin/gst-xmllaunch-%%VERSION%%
include/gstreamer-%%VERSION%%/gst/bytestream/bytestream.h
include/gstreamer-%%VERSION%%/gst/control/control.h
include/gstreamer-%%VERSION%%/gst/control/dparam.h
@@ -19,10 +29,8 @@ include/gstreamer-%%VERSION%%/gst/control/unitconvert.h
include/gstreamer-%%VERSION%%/gst/getbits/getbits.h
include/gstreamer-%%VERSION%%/gst/gst.h
include/gstreamer-%%VERSION%%/gst/gstatomic.h
-include/gstreamer-%%VERSION%%/gst/gstautoplug.h
include/gstreamer-%%VERSION%%/gst/gstbin.h
include/gstreamer-%%VERSION%%/gst/gstbuffer.h
-include/gstreamer-%%VERSION%%/gst/gstbufferpool-default.h
include/gstreamer-%%VERSION%%/gst/gstcaps.h
include/gstreamer-%%VERSION%%/gst/gstclock.h
include/gstreamer-%%VERSION%%/gst/gstcompat.h
@@ -31,11 +39,13 @@ include/gstreamer-%%VERSION%%/gst/gstcpu.h
include/gstreamer-%%VERSION%%/gst/gstdata.h
include/gstreamer-%%VERSION%%/gst/gstelement.h
include/gstreamer-%%VERSION%%/gst/gstenumtypes.h
+include/gstreamer-%%VERSION%%/gst/gsterror.h
include/gstreamer-%%VERSION%%/gst/gstevent.h
-include/gstreamer-%%VERSION%%/gst/gstextratypes.h
+include/gstreamer-%%VERSION%%/gst/gstfilter.h
include/gstreamer-%%VERSION%%/gst/gstformat.h
include/gstreamer-%%VERSION%%/gst/gstindex.h
include/gstreamer-%%VERSION%%/gst/gstinfo.h
+include/gstreamer-%%VERSION%%/gst/gstinterface.h
include/gstreamer-%%VERSION%%/gst/gstlog.h
include/gstreamer-%%VERSION%%/gst/gstmacros.h
include/gstreamer-%%VERSION%%/gst/gstmarshal.h
@@ -47,28 +57,28 @@ include/gstreamer-%%VERSION%%/gst/gstpipeline.h
include/gstreamer-%%VERSION%%/gst/gstplugin.h
include/gstreamer-%%VERSION%%/gst/gstpluginfeature.h
include/gstreamer-%%VERSION%%/gst/gstprobe.h
-include/gstreamer-%%VERSION%%/gst/gstprops.h
include/gstreamer-%%VERSION%%/gst/gstquery.h
include/gstreamer-%%VERSION%%/gst/gstqueue.h
include/gstreamer-%%VERSION%%/gst/gstregistry.h
+include/gstreamer-%%VERSION%%/gst/gstregistrypool.h
include/gstreamer-%%VERSION%%/gst/gstscheduler.h
+include/gstreamer-%%VERSION%%/gst/gststructure.h
include/gstreamer-%%VERSION%%/gst/gstsystemclock.h
+include/gstreamer-%%VERSION%%/gst/gsttag.h
+include/gstreamer-%%VERSION%%/gst/gsttaginterface.h
include/gstreamer-%%VERSION%%/gst/gstthread.h
include/gstreamer-%%VERSION%%/gst/gsttrace.h
include/gstreamer-%%VERSION%%/gst/gsttrashstack.h
-include/gstreamer-%%VERSION%%/gst/gsttype.h
include/gstreamer-%%VERSION%%/gst/gsttypefind.h
include/gstreamer-%%VERSION%%/gst/gsttypes.h
include/gstreamer-%%VERSION%%/gst/gsturi.h
+include/gstreamer-%%VERSION%%/gst/gsturitype.h
include/gstreamer-%%VERSION%%/gst/gstutils.h
+include/gstreamer-%%VERSION%%/gst/gstvalue.h
include/gstreamer-%%VERSION%%/gst/gstversion.h
include/gstreamer-%%VERSION%%/gst/gstxml.h
-include/gstreamer-%%VERSION%%/gst/putbits/putbits.h
-lib/gstreamer-%%VERSION%%/libgstautoplugcache.so
-lib/gstreamer-%%VERSION%%/libgstautoplugger.so
lib/gstreamer-%%VERSION%%/libgstbasicgthreadscheduler.so
lib/gstreamer-%%VERSION%%/libgstbasicomegascheduler.so
-lib/gstreamer-%%VERSION%%/libgstbasicwingoscheduler.so
lib/gstreamer-%%VERSION%%/libgstbytestream.so
lib/gstreamer-%%VERSION%%/libgstelements.so
lib/gstreamer-%%VERSION%%/libgstgetbits.so
@@ -76,12 +86,7 @@ lib/gstreamer-%%VERSION%%/libgstindexers.so
lib/gstreamer-%%VERSION%%/libgstoptgthreadscheduler.so
lib/gstreamer-%%VERSION%%/libgstoptomegascheduler.so
lib/gstreamer-%%VERSION%%/libgstoptscheduler.so
-lib/gstreamer-%%VERSION%%/libgstoptwingoscheduler.so
-lib/gstreamer-%%VERSION%%/libgstputbits.so
lib/gstreamer-%%VERSION%%/libgstspider.so
-lib/gstreamer-%%VERSION%%/libgststaticautoplug.so
-lib/gstreamer-%%VERSION%%/libgststaticautoplugrender.so
-lib/gstreamer-%%VERSION%%/libgsttypes.so
lib/libgstcontrol-%%VERSION%%.a
lib/libgstcontrol-%%VERSION%%.so
lib/libgstcontrol-%%VERSION%%.so.%%SHLIB_VERSION%%
@@ -91,11 +96,18 @@ lib/libgstreamer-%%VERSION%%.so.%%SHLIB_VERSION%%
libdata/pkgconfig/gstreamer-%%VERSION%%.pc
libdata/pkgconfig/gstreamer-control-%%VERSION%%.pc
share/aclocal/gst-element-check-%%VERSION%%.m4
+share/locale/fr/LC_MESSAGES/gstreamer-%%VERSION%%.mo
+share/locale/nl/LC_MESSAGES/gstreamer-%%VERSION%%.mo
+share/locale/sr/LC_MESSAGES/gstreamer-%%VERSION%%.mo
@unexec rm %D/share/gnome/cache/gstreamer-%%VERSION%%/registry.xml 2>/dev/null || true
+@dirrm share/gnome/doc/gstreamer-%%VERSION%%.0/pwg
+@dirrm share/gnome/doc/gstreamer-%%VERSION%%.0/manual
+@dirrm share/gnome/doc/gstreamer-%%VERSION%%.0/faq
+@dirrm share/gnome/doc/gstreamer-%%VERSION%%.0
@dirrm share/gnome/cache/gstreamer-%%VERSION%%
@unexec rmdir %D/share/gnome/cache 2>/dev/null || true
@dirrm lib/gstreamer-%%VERSION%%
-@dirrm include/gstreamer-%%VERSION%%/gst/putbits
+@dirrm include/gstreamer-%%VERSION%%/gst/tag
@dirrm include/gstreamer-%%VERSION%%/gst/getbits
@dirrm include/gstreamer-%%VERSION%%/gst/control
@dirrm include/gstreamer-%%VERSION%%/gst/bytestream