aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gxine/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2012-05-23 01:51:52 +0000
committerMartin Wilke <miwi@FreeBSD.org>2012-05-23 01:51:52 +0000
commit58f7c165318f528cafb0b9210f493511e7f2d137 (patch)
tree269c7cdebbd3228691ec2b87e1d4b49d5db951e1 /multimedia/gxine/Makefile
parente569bc0981a9a72f6cc7bc6bae33ea307294874a (diff)
downloadports-58f7c165318f528cafb0b9210f493511e7f2d137.tar.gz
ports-58f7c165318f528cafb0b9210f493511e7f2d137.zip
Notes
Diffstat (limited to 'multimedia/gxine/Makefile')
-rw-r--r--multimedia/gxine/Makefile102
1 files changed, 45 insertions, 57 deletions
diff --git a/multimedia/gxine/Makefile b/multimedia/gxine/Makefile
index 1f9f7417bdaa..baab2aaf21dd 100644
--- a/multimedia/gxine/Makefile
+++ b/multimedia/gxine/Makefile
@@ -6,89 +6,77 @@
#
PORTNAME= gxine
-PORTVERSION= 0.5.905
-PORTREVISION= 6
+PORTVERSION= 0.5.907
CATEGORIES= multimedia
MASTER_SITES= SF/xine/${PORTNAME}/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= An alternative GUI for the Xine media player
-LIB_DEPENDS= xine.2:${PORTSDIR}/multimedia/libxine
+LICENSE= GPLv2
-USE_BZIP2= yes
-USE_AUTOTOOLS= libtool
-USE_GNOME= gtk20 gnomehier
+LIB_DEPENDS= nspr4.1:${PORTSDIR}/devel/nspr \
+ xine.2:${PORTSDIR}/multimedia/libxine
+
+OPTIONS= MOZILLA_PLUGIN "Install Mozilla plugin" off \
+ GNOME "Enable Gnome integration" off \
+ LIRC "Enable lirc support" off
+
+USE_XZ= yes
+USE_GNOME= gnomehack gtk20
+USE_GECKO= libxul
USE_GMAKE= yes
-USE_GCC= 4.2+
-MAKE_ARGS+= LDFLAGS=-shared-libgcc
-CNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--without-hal --with-libintl-prefix=${LOCALBASE}
+USE_AUTOTOOLS= libtool
+CONFIGURE_ENV= MKDIR_P="${MKDIR}"
+CONFIGURE_ARGS= --enable-mozjs --disable-ffjs --disable-seajs \
+ --without-hal --with-libintl-prefix=${LOCALBASE}
INSTALLS_ICONS= yes
-
MAKE_JOBS_SAFE= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
MANLANG= "" de es
MAN1= gxine.1 gxine_client.1
MANCOMPRESSED= no
-OPTIONS= MOZILLA_PLUGIN "Install Mozilla plugin" off \
- GNOME "Enable Gnome integration" off \
- LIRC "Enable lirc support" off
-
.include <bsd.port.options.mk>
-.if defined(WITH_GNOME)
-USE_GNOME+= gnomevfs2 libgnomeui
-CONFIGURE_ARGS+=--with-dbus
+.if defined(WITH_MOZILLA_PLUGIN)
+USE_XORG+= xaw
+USE_WEBPLUGINS= native
+WEBPLUGINS_DIR= ${PREFIX}/lib/gxine
+WEBPLUGINS_FILES=gxineplugin.so
+.include "${PORTSDIR}/www/firefox/Makefile.webplugins"
+PLIST_SUB+= MOZILLA_PLUGIN=""
.else
-CONFIGURE_ARGS+=--disable-integration-wizard --without-dbus
+CONFIGURE_ARGS+=--without-browser-plugin
+PLIST_SUB+= MOZILLA_PLUGIN="@comment "
.endif
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
+.if defined(WITH_GNOME)
+BUILD_DEPENDS+= gnome-screensaver:${PORTSDIR}/x11/gnome-screensaver
+LIB_DEPENDS+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
+RUN_DEPENDS+= gnome-screensaver:${PORTSDIR}/x11/gnome-screensaver
+CONFIGURE_ARGS+=--with-dbus
.else
-USE_GETTEXT= yes
-PLIST_SUB+= NLS=""
+CONFIGURE_ARGS+=--disable-integration-wizard --without-dbus
.endif
.if defined(WITH_LIRC)
LIB_DEPENDS+= lirc_client.2:${PORTSDIR}/comms/lirc
-CONFIGURE_ARGS+= --enable-lirc
-.else
-CONFIGURE_ARGS+= --disable-lirc
-.endif
-
-.if defined(WITHOUT_MOZILLA_PLUGIN)
-LIB_DEPENDS+= js.1:${PORTSDIR}/lang/spidermonkey
-CONFIGURE_ARGS+=--without-browser-plugin --with-spidermonkey
-PLIST_SUB+= MOZILLA_PLUGIN="@comment "
+CONFIGURE_ARGS+=--enable-lirc
.else
-USE_XORG+= xaw
-USE_GECKO= libxul
-USE_WEBPLUGINS= native
-WEBPLUGINS_DIR= ${PREFIX}/lib/gxine
-WEBPLUGINS_FILES=gxineplugin.so
-.include "${PORTSDIR}/www/firefox/Makefile.webplugins"
-LIB_DEPENDS+= nspr4.1:${PORTSDIR}/devel/nspr
-CONFIGURE_ENV+= NSPR_CFLAGS="-I${LOCALBASE}/include/nspr" \
- NSPR_LIBS="-L${LOCALBASE}/lib"
-PLIST_SUB+= MOZILLA_PLUGIN=""
+CONFIGURE_ARGS+=--disable-lirc
.endif
-pre-configure:
- @${REINPLACE_CMD} -e "/^mkdir_p/s:@mkdir_p@:${MKDIR}:" \
- ${WRKSRC}/po/Makefile.in.in
- @${REINPLACE_CMD} -e "/^mkdir_p/s:@mkdir_p@:${MKDIR}:" \
- ${WRKSRC}/misc/po/Makefile.in.in
- @${REINPLACE_CMD} -e "s:@MAKE_PNG_TRUE@:#:g" \
- ${WRKSRC}/pixmaps/Makefile.in
-
-.include <bsd.port.pre.mk>
-
-.if (${OSVERSION}<800000) && defined(WITH_MOZILLA_PLUGIN)
-BROKEN= does not compile with MOZILLA_PLUGIN
-.endif
+post-patch:
+ @${REINPLACE_CMD} -e \
+ '/CFLAGS/s|-I/usr/local/include|| ; \
+ /CFLAGS/s|-L/usr/local/lib|| ; \
+ /CPPFLAGS/s|-I/usr/local/include|| ; \
+ s|XINE_LIST=.*|XINE_LIST=|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e \
+ 's|@MAKE_PNG_TRUE@|#|' ${WRKSRC}/pixmaps/Makefile.in
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>