aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gxine/Makefile
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2003-04-19 18:34:23 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2003-04-19 18:34:23 +0000
commit2e2e978fae91883e7f80be9d4f662b5fe0c80b3e (patch)
tree74c15bd848dc5716ade0c478377567a054b6826b /multimedia/gxine/Makefile
parent38f392c9a9dedea496d0ef0d191b579e254e30af (diff)
downloadports-2e2e978fae91883e7f80be9d4f662b5fe0c80b3e.tar.gz
ports-2e2e978fae91883e7f80be9d4f662b5fe0c80b3e.zip
Notes
Diffstat (limited to 'multimedia/gxine/Makefile')
-rw-r--r--multimedia/gxine/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/multimedia/gxine/Makefile b/multimedia/gxine/Makefile
new file mode 100644
index 000000000000..86dcc561d6c4
--- /dev/null
+++ b/multimedia/gxine/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: gxine
+# Date created: Sa 19 Apr 2003 01:34:06 CEST
+# Whom: Grigori Goronzy <greg@chown.ath.cx>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gxine
+PORTVERSION= 0.3.3
+CATEGORIES= multimedia
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= xine
+
+MAINTAINER= greg@chown.ath.cx
+COMMENT= An alternative GUI for the Xine media player
+
+LIB_DEPENDS= xine.6:${PORTSDIR}/multimedia/libxine
+
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+USE_GNOME= gtk20
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -I${X11BASE}/lib"
+
+MANLANG= "" de
+MAN1= gxine.1
+
+post-patch:
+ @${REINPLACE_CMD} -e 's/browser-plugin//' ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>