aboutsummaryrefslogtreecommitdiff
path: root/multimedia/k9copy-kde4
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2014-01-25 22:41:42 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2014-01-25 22:41:42 +0000
commit2d32eff9fa8f3574f712b14d73392390965ae901 (patch)
tree01c4eba55ab138d8b752659d4a8bda6082f60fee /multimedia/k9copy-kde4
parent932dddc67889a6ce890b059d4ed508b939088482 (diff)
downloadports-2d32eff9fa8f3574f712b14d73392390965ae901.tar.gz
ports-2d32eff9fa8f3574f712b14d73392390965ae901.zip
Notes
Diffstat (limited to 'multimedia/k9copy-kde4')
-rw-r--r--multimedia/k9copy-kde4/Makefile21
-rw-r--r--multimedia/k9copy-kde4/files/patch-CMakeLists.txt4
-rw-r--r--multimedia/k9copy-kde4/files/patch-src-xine-k9xineplayer.cpp26
-rw-r--r--multimedia/k9copy-kde4/files/patch-src_mpeg2_kdecmpeg2.cpp10
4 files changed, 39 insertions, 22 deletions
diff --git a/multimedia/k9copy-kde4/Makefile b/multimedia/k9copy-kde4/Makefile
index 1d2b42edc8ef..cc6b908829d5 100644
--- a/multimedia/k9copy-kde4/Makefile
+++ b/multimedia/k9copy-kde4/Makefile
@@ -11,6 +11,8 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-Source
MAINTAINER= egoliveira@gmail.com
COMMENT= DVD-9 to DVD-5 shrinking application for KDE
+LICENSE= GPLv2
+
LIB_DEPENDS= libxine.so:${PORTSDIR}/multimedia/libxine \
libmpeg2.so:${PORTSDIR}/multimedia/libmpeg2 \
libavcodec0.so:${PORTSDIR}/multimedia/ffmpeg0
@@ -19,8 +21,6 @@ USES= cmake gettext
USE_KDE4= kdeprefix kdelibs automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
-LATEST_LINK= ${PORTNAME}-kde4
-
CFLAGS= -I${LOCALBASE}/include/ffmpeg0
CPPFLAGS= -I${LOCALBASE}/include/ffmpeg0
CXXFLAGS= -I${LOCALBASE}/include/ffmpeg0
@@ -30,20 +30,9 @@ MENCODER_DESC= MEncoder support
MPLAYER_DESC= MPlayer support
DVDAUTHOR_DESC= DVD Author support
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MMENCODER}
-RUN_DEPENDS+= mencoder:${PORTSDIR}/multimedia/mencoder
-.endif
-
-.if ${PORT_OPTIONS:MMPLAYER}
-RUN_DEPENDS+= mplayer:${PORTSDIR}/multimedia/mplayer
-.endif
-
-.if ${PORT_OPTIONS:MDVDAUTHOR}
-RUN_DEPENDS+= dvdauthor:${PORTSDIR}/multimedia/dvdauthor
-.endif
+MENCODER_RUN_DEPENDS= mencoder:${PORTSDIR}/multimedia/mencoder
+MPLAYER_RUN_DEPENDS= mplayer:${PORTSDIR}/multimedia/mplayer
+DVDAUTHOR_RUN_DEPENDS= dvdauthor:${PORTSDIR}/multimedia/dvdauthor
post-patch:
@${REINPLACE_CMD} -e 's,%%LOCALBASE%%,${LOCALBASE},g' ${WRKSRC}/cmake/*.cmake
diff --git a/multimedia/k9copy-kde4/files/patch-CMakeLists.txt b/multimedia/k9copy-kde4/files/patch-CMakeLists.txt
index 24d86ea205fe..4f9fcabc2ee2 100644
--- a/multimedia/k9copy-kde4/files/patch-CMakeLists.txt
+++ b/multimedia/k9copy-kde4/files/patch-CMakeLists.txt
@@ -29,10 +29,10 @@
kde4_add_executable(k9xineplayer ${k9xineplayer_SRCS})
-target_link_libraries(k9copy k9copylib ${KDE4_KDEUI_LIBS} ${KDE4_KDE3SUPPORT_LIBS} -lphonon )
-+target_link_libraries(k9copy k9copylib ${KDE4_KDEUI_LIBS} ${KDE4_KDE3SUPPORT_LIBS} ${PHONON_LIBRARY} )
++target_link_libraries(k9copy k9copylib ${KDE4_KDEUI_LIBS} ${KDE4_KDE3SUPPORT_LIBS} ${KDE4_SOLID_LIBS} ${PHONON_LIBRARY} )
target_link_libraries(k9play k9copylib ${KDE4_KDEUI_LIBS} ${KDE4_KDE3SUPPORT_LIBS} )
-target_link_libraries(k9xineplayer ${KDE4_KDEUI_LIBS} ${KDE4_KDE3SUPPORT_LIBS} -lxine )
-+target_link_libraries(k9xineplayer ${KDE4_KDEUI_LIBS} ${KDE4_KDE3SUPPORT_LIBS} ${XINE_LIBRARY} )
++target_link_libraries(k9xineplayer ${KDE4_KDEUI_LIBS} ${KDE4_KDE3SUPPORT_LIBS} ${XINE_LIBRARY} ${X11_LIBRARIES} )
install(TARGETS k9copy DESTINATION ${BIN_INSTALL_DIR} )
diff --git a/multimedia/k9copy-kde4/files/patch-src-xine-k9xineplayer.cpp b/multimedia/k9copy-kde4/files/patch-src-xine-k9xineplayer.cpp
index 973346785aa9..1492377d3695 100644
--- a/multimedia/k9copy-kde4/files/patch-src-xine-k9xineplayer.cpp
+++ b/multimedia/k9copy-kde4/files/patch-src-xine-k9xineplayer.cpp
@@ -1,6 +1,15 @@
---- src/xine/k9xineplayer.cpp.orig
-+++ src/xine/k9xineplayer.cpp
-@@ -260,8 +260,10 @@ void k9xinePlayer::init(WId _wid) {
+--- src/xine/k9xineplayer.cpp.orig 2009-12-06 10:13:37.000000000 +0000
++++ src/xine/k9xineplayer.cpp 2013-12-06 15:34:35.000000000 +0000
+@@ -251,7 +251,7 @@
+
+ if ((vo_port = xine_open_video_driver(xine,
+ m_vo.toAscii(), XINE_VISUAL_TYPE_X11, (void *) &vis)) == NULL) {
+- printf("I'm unable to initialize '%s' video driver. Giving up.\n", m_vo.toAscii());
++ printf("I'm unable to initialize '%s' video driver. Giving up.\n", m_vo.toAscii().constData());
+ return ;
+ }
+
+@@ -260,8 +260,10 @@
event_queue = xine_event_new_queue(stream);
xine_event_create_listener_thread(event_queue, event_listener, this);
@@ -13,7 +22,16 @@
m_execute=true;
}
-@@ -284,7 +286,8 @@ void k9xinePlayer::quit() {
+@@ -270,7 +272,7 @@
+ running=false;
+ m_title="";
+ if ((!xine_open(stream, m_mrl.toUtf8())) || (!xine_play(stream, 0, 0))) {
+- printf("Unable to open mrl '%s'\n", m_mrl.toUtf8());
++ printf("Unable to open mrl '%s'\n", m_mrl.toUtf8().constData());
+ return ;
+ }
+ QTimer::singleShot (500, this, SLOT (updatePosition ()));
+@@ -284,7 +286,8 @@
void k9xinePlayer::update() {
if (stream && !running ) {
if (m_mutex.tryLock()) {
diff --git a/multimedia/k9copy-kde4/files/patch-src_mpeg2_kdecmpeg2.cpp b/multimedia/k9copy-kde4/files/patch-src_mpeg2_kdecmpeg2.cpp
new file mode 100644
index 000000000000..2bb26d9ea7b5
--- /dev/null
+++ b/multimedia/k9copy-kde4/files/patch-src_mpeg2_kdecmpeg2.cpp
@@ -0,0 +1,10 @@
+--- src/mpeg2/kdecmpeg2.cpp.orig 2009-12-06 10:13:36.000000000 +0000
++++ src/mpeg2/kdecmpeg2.cpp 2013-12-06 15:00:15.000000000 +0000
+@@ -286,6 +286,7 @@
+ }
+ }
+ }
++ return 0;
+ }
+
+ void kDecMPEG2::sync() {