aboutsummaryrefslogtreecommitdiff
path: root/multimedia/kino/Makefile
diff options
context:
space:
mode:
authorPierre Beyssac <pb@FreeBSD.org>2004-04-10 16:49:19 +0000
committerPierre Beyssac <pb@FreeBSD.org>2004-04-10 16:49:19 +0000
commitf3599b1e52e3d95bf9c69930949443a1e3b1bf1a (patch)
tree6668112948867a45ae96ddc6152bd8da8cf23f6c /multimedia/kino/Makefile
parente68c86842345916004c7f6e3a9a07b3470f3516d (diff)
downloadports-f3599b1e52e3d95bf9c69930949443a1e3b1bf1a.tar.gz
ports-f3599b1e52e3d95bf9c69930949443a1e3b1bf1a.zip
Notes
Diffstat (limited to 'multimedia/kino/Makefile')
-rw-r--r--multimedia/kino/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/multimedia/kino/Makefile b/multimedia/kino/Makefile
new file mode 100644
index 000000000000..5c8569d72ef8
--- /dev/null
+++ b/multimedia/kino/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: kino
+# Date created: 10 April 2004
+# Whom: pb@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= kino
+PORTVERSION= 0.7.0
+CATEGORIES= multimedia
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://kino.schirmacher.de/filemanager/download/17/
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= pb@FreeBSD.org
+COMMENT= A DV non-linear video editor
+
+LIB_DEPENDS= dv.4:${PORTSDIR}/multimedia/libdv \
+ glade-2.0:${PORTSDIR}/devel/libglade2 \
+ gnomeui-2.600:${PORTSDIR}/x11-toolkits/libgnomeui \
+ ICE.6:${PORTSDIR}/x11/libICE \
+ intl.6:${PORTSDIR}/devel/gettext \
+ Magick.6:${PORTSDIR}/graphics/ImageMagick \
+ xml2.5:${PORTSDIR}/textproc/libxml2
+
+USE_ICONV= yes
+GNU_CONFIGURE= yes
+USE_X_PREFIX= yes
+CONFIGURE_ENV= CPPFLAGS=-"I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+MAN1= kino.1
+
+.include <bsd.port.mk>