aboutsummaryrefslogtreecommitdiff
path: root/multimedia/kino/files
diff options
context:
space:
mode:
authorPierre Beyssac <pb@FreeBSD.org>2007-03-18 23:30:39 +0000
committerPierre Beyssac <pb@FreeBSD.org>2007-03-18 23:30:39 +0000
commitf2cf562b6852d0952eaff9ce89e340c613af495a (patch)
tree7320dfa3f3631b5a3cce4e3637a7598874f5f4a3 /multimedia/kino/files
parent8876be1498b39b6300c19c450840a3e32621cd2a (diff)
downloadports-f2cf562b6852d0952eaff9ce89e340c613af495a.tar.gz
ports-f2cf562b6852d0952eaff9ce89e340c613af495a.zip
Notes
Diffstat (limited to 'multimedia/kino/files')
-rw-r--r--multimedia/kino/files/patch-Makefile.in11
-rw-r--r--multimedia/kino/files/patch-am19
-rw-r--r--multimedia/kino/files/patch-configure.in38
-rw-r--r--multimedia/kino/files/patch-src::kino_common.cc11
-rw-r--r--multimedia/kino/files/patch-src__displayer.cc37
5 files changed, 40 insertions, 76 deletions
diff --git a/multimedia/kino/files/patch-Makefile.in b/multimedia/kino/files/patch-Makefile.in
deleted file mode 100644
index 4a2dff2277f6..000000000000
--- a/multimedia/kino/files/patch-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in.orig Mon Nov 28 21:15:11 2005
-+++ Makefile.in Mon Nov 28 21:16:37 2005
-@@ -249,7 +249,7 @@
- sharedstatedir = @sharedstatedir@
- sysconfdir = @sysconfdir@
- target_alias = @target_alias@
--SUBDIRS = po src help scripts linux-hotplug pixmaps
-+SUBDIRS = po src help scripts pixmaps
- MAINTAINERCLEANFILES = Makefile.in aclocal.m4 configure config.h.in \
- intltool-extract.in intltool-merge.in intltool-update.in
-
diff --git a/multimedia/kino/files/patch-am b/multimedia/kino/files/patch-am
index c86ba098a72e..b92432fdbefa 100644
--- a/multimedia/kino/files/patch-am
+++ b/multimedia/kino/files/patch-am
@@ -1,6 +1,6 @@
---- src/jogshuttle.cc.orig Mon Mar 15 23:13:46 2004
-+++ src/jogshuttle.cc Tue Apr 13 11:51:37 2004
-@@ -26,7 +26,7 @@
+--- src/jogshuttle.cc.orig Tue Feb 20 07:32:05 2007
++++ src/jogshuttle.cc Sat Mar 17 21:05:33 2007
+@@ -27,7 +27,7 @@
#include <fcntl.h>
#include <unistd.h>
#include <errno.h>
@@ -9,20 +9,15 @@
#include "jogshuttle.h"
#include "preferences.h"
-@@ -343,9 +343,10 @@
+@@ -343,6 +343,7 @@
*/
void JogShuttle::inputCallback( gint source, GdkInputCondition condition )
{
+#if 0
g_return_if_fail( this != NULL );
-- // g_return_if_fail( input_ >= 0 );
-- // g_return_if_fail( input_ == source );
-+ g_return_if_fail( input_ >= 0 );
-+ g_return_if_fail( input_ == source );
- g_return_if_fail( condition == GDK_INPUT_READ );
-
- struct media_ctrl_event ev;
-@@ -402,4 +403,5 @@
+ // g_return_if_fail( input_ >= 0 );
+ // g_return_if_fail( input_ == source );
+@@ -405,4 +406,5 @@
{
return;
}
diff --git a/multimedia/kino/files/patch-configure.in b/multimedia/kino/files/patch-configure.in
index 3af6b9a5416d..04726c22e365 100644
--- a/multimedia/kino/files/patch-configure.in
+++ b/multimedia/kino/files/patch-configure.in
@@ -1,5 +1,5 @@
---- configure.in.orig Tue Apr 25 20:18:28 2006
-+++ configure.in Tue Jul 18 23:14:58 2006
+--- configure.in.orig Thu Mar 8 04:52:54 2007
++++ configure.in Sun Mar 18 00:00:50 2007
@@ -40,32 +40,32 @@
AC_SUBST(LIBDV_CFLAGS)
AC_SUBST(LIBDV_LIBS)
@@ -26,6 +26,13 @@
-AC_CHECK_LIB(rom1394, rom1394_get_node_type, ,
- [AC_MSG_ERROR([Unable to link with librom1394. Check that your have librom1394 installed (usually part of libavc1394) and that the version is 0.4.1 or newer])]
-)
+-
+-AC_CHECK_LIB(pthread, pthread_create, ,
+- [AC_MSG_ERROR([You need the pthread library to compile kino])]
+-)
+-AC_CHECK_LIB(dl, dlopen, ,
+- [AC_MSG_ERROR([You need libdl to compile kino])]
+-)
+#AC_CHECK_HEADER([libavc1394/avc1394.h], ,
+# [AC_MSG_ERROR([avc1394.h not found, install libavc1394-devel])
+#])
@@ -38,13 +45,7 @@
+#AC_CHECK_LIB(rom1394, rom1394_get_node_type, ,
+# [AC_MSG_ERROR([Unable to link with librom1394. Check that your have librom1394 installed (usually part of libavc1394) and that the version is 0.4.1 or newer])]
+#)
-
--AC_CHECK_LIB(pthread, pthread_create, ,
-- [AC_MSG_ERROR([You need the pthread library to compile kino])]
--)
--AC_CHECK_LIB(dl, dlopen, ,
-- [AC_MSG_ERROR([You need libdl to compile kino])]
--)
++
+#AC_CHECK_LIB(pthread, pthread_create, ,
+# [AC_MSG_ERROR([You need the pthread library to compile kino])]
+#)
@@ -52,5 +53,20 @@
+# [AC_MSG_ERROR([You need libdl to compile kino])]
+#)
- # ######################################################################
- # checks for optional packages
+ # LIBIEC61883
+ AC_ARG_WITH(dv1394, AC_HELP_STRING([--with-dv1394],[Use dv1394 instead of libiec61883 for DV I/O (only if you must).]))
+@@ -187,12 +187,12 @@
+ tar -xzf ffmpeg-svn-r8218.tar.gz
+ fi
+ if ! (test -f ffmpeg/config.mak) ; then
+- pushd ffmpeg
++ (cd ffmpeg
+ ./configure --disable-ffserver --disable-ffplay --disable-v4l \
+ --disable-v4l2 --disable-dv1394 --disable-network --disable-zlib \
+ --disable-vhook --build-suffix=-kino --enable-gpl --enable-swscaler \
+ --prefix="$prefix"
+- popd
++ )
+ fi
+ fi
+ ])
diff --git a/multimedia/kino/files/patch-src::kino_common.cc b/multimedia/kino/files/patch-src::kino_common.cc
index 68888f3089ce..9bc6cdcd3dd2 100644
--- a/multimedia/kino/files/patch-src::kino_common.cc
+++ b/multimedia/kino/files/patch-src::kino_common.cc
@@ -1,14 +1,15 @@
---- src/kino_common.cc.orig Fri Dec 15 09:49:52 2006
-+++ src/kino_common.cc Mon Dec 25 23:46:08 2006
-@@ -34,6 +34,7 @@
+--- src/kino_common.cc.orig Wed Mar 7 10:23:12 2007
++++ src/kino_common.cc Sat Mar 17 21:17:18 2007
+@@ -35,6 +35,8 @@
#ifndef _GNU_SOURCE
#define _GNU_SOURCE
#endif
+#include <libgen.h>
++#include <signal.h>
#include <string.h>
#include <stdarg.h>
#include <time.h>
-@@ -1486,7 +1487,8 @@
+@@ -1527,7 +1529,8 @@
Frame *frame = GetFramePool()->GetFrame();
if ( frame != NULL )
{
@@ -18,7 +19,7 @@
GError *gerror = NULL;
this->getPlayList()->GetFrame( this->g_currentFrame, *frame );
-@@ -1521,6 +1523,7 @@
+@@ -1562,6 +1565,7 @@
g_error_free( gerror );
}
g_object_unref( im );
diff --git a/multimedia/kino/files/patch-src__displayer.cc b/multimedia/kino/files/patch-src__displayer.cc
deleted file mode 100644
index df759d03236e..000000000000
--- a/multimedia/kino/files/patch-src__displayer.cc
+++ /dev/null
@@ -1,37 +0,0 @@
---- src/displayer.cc.orig Tue Jan 16 01:52:01 2007
-+++ src/displayer.cc Tue Jan 16 01:55:59 2007
-@@ -573,20 +573,23 @@
- xvImage = ( XvImage * ) XvShmCreateImage( display, port, 0x32595559, 0, width, height, &shmInfo );
-
- shmInfo.shmid = shmget( IPC_PRIVATE, xvImage->data_size, IPC_CREAT | 0777 );
-- shmInfo.shmaddr = ( char * ) shmat( shmInfo.shmid, 0, 0 );
-- xvImage->data = shmInfo.shmaddr;
-- shmInfo.readOnly = 0;
-- if ( !XShmAttach( gdk_display, &shmInfo ) )
-- {
-+ if (shmInfo.shmid < 0) {
-+ perror("shmget");
- gotPort = false;
-- }
-- XSync( display, false );
-- shmctl( shmInfo.shmid, IPC_RMID, 0 );
-+ } else {
-+ shmInfo.shmaddr = ( char * ) shmat( shmInfo.shmid, 0, 0 );
-+ xvImage->data = shmInfo.shmaddr;
-+ shmInfo.readOnly = 0;
-+ if ( !XShmAttach( gdk_display, &shmInfo ) )
-+ {
-+ gotPort = false;
-+ }
-+ XSync( display, false );
-+ shmctl( shmInfo.shmid, IPC_RMID, 0 );
- #if 0
--
-- xvImage = ( XvImage * ) XvCreateImage( display, port, 0x32595559, pix, width , height );
-+ xvImage = ( XvImage * ) XvCreateImage( display, port, 0x32595559, pix, width , height );
- #endif
--
-+ }
- }
- }
- else