aboutsummaryrefslogtreecommitdiff
path: root/multimedia/kino
diff options
context:
space:
mode:
authorPierre Beyssac <pb@FreeBSD.org>2006-07-19 16:52:58 +0000
committerPierre Beyssac <pb@FreeBSD.org>2006-07-19 16:52:58 +0000
commit88c322758fc242d78789f52aa8c48311429262dd (patch)
tree25a6566d076083d576d1c538db080918375b5834 /multimedia/kino
parent53c3693939c03628b9be75770443bc032ffb29f5 (diff)
downloadports-88c322758fc242d78789f52aa8c48311429262dd.tar.gz
ports-88c322758fc242d78789f52aa8c48311429262dd.zip
Notes
Diffstat (limited to 'multimedia/kino')
-rw-r--r--multimedia/kino/Makefile3
-rw-r--r--multimedia/kino/distinfo6
-rw-r--r--multimedia/kino/files/patch-ah11
-rw-r--r--multimedia/kino/files/patch-aj57
-rw-r--r--multimedia/kino/files/patch-ap19
-rw-r--r--multimedia/kino/files/patch-bg11
-rw-r--r--multimedia/kino/files/patch-configure.in43
-rw-r--r--multimedia/kino/files/patch-src__Makefile.in14
-rw-r--r--multimedia/kino/files/patch-src__gtkenhancedscale.c29
-rw-r--r--multimedia/kino/files/patch-src__ieee1394io.cc (renamed from multimedia/kino/files/patch-ai)230
-rw-r--r--multimedia/kino/files/patch-src__ieee1394io.h57
-rw-r--r--multimedia/kino/files/patch-src__kino_extra.h12
-rw-r--r--multimedia/kino/files/patch-src__page_export_1394.cc18
-rw-r--r--multimedia/kino/files/patch-src__playlist.cc108
-rw-r--r--multimedia/kino/files/patch-src__preferences_dialog.cc (renamed from multimedia/kino/files/patch-as)30
-rw-r--r--multimedia/kino/pkg-plist15
16 files changed, 371 insertions, 292 deletions
diff --git a/multimedia/kino/Makefile b/multimedia/kino/Makefile
index 16e077c2c923..fe0eb08494be 100644
--- a/multimedia/kino/Makefile
+++ b/multimedia/kino/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= kino
-PORTVERSION= 0.8.0
-PORTREVISION= 3
+PORTVERSION= 0.9.0
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/multimedia/kino/distinfo b/multimedia/kino/distinfo
index 4e5da9bc8188..9564d6699d5d 100644
--- a/multimedia/kino/distinfo
+++ b/multimedia/kino/distinfo
@@ -1,3 +1,3 @@
-MD5 (kino-0.8.0.tar.gz) = ec945365580d5e21431c76c07d0576bf
-SHA256 (kino-0.8.0.tar.gz) = 3f06abb3dc863689cd44a560d42c203ba882a17f8cdc845e861b854f852a3b0b
-SIZE (kino-0.8.0.tar.gz) = 1498967
+MD5 (kino-0.9.0.tar.gz) = 95c6a550f1f3462efac639132ab6f990
+SHA256 (kino-0.9.0.tar.gz) = 2b975caee1c0f97caf453a0a878387ab7d35f1e774b788c19a603340dc965d74
+SIZE (kino-0.9.0.tar.gz) = 1571415
diff --git a/multimedia/kino/files/patch-ah b/multimedia/kino/files/patch-ah
deleted file mode 100644
index 7efb839eea9a..000000000000
--- a/multimedia/kino/files/patch-ah
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/gtkenhancedscale.c Tue Nov 25 21:51:18 2003
-+++ src/gtkenhancedscale.c Fri Apr 9 17:44:14 2004
-@@ -33,7 +33,7 @@
- #include "gtkenhancedscale.h"
- #include <string.h>
- #include <stdio.h>
--#include <malloc.h>
-+#include <stdlib.h>
- #include <math.h>
-
- #define ENHANCED_SCALE_CLASS(w) GTK_ENHANCED_SCALE_CLASS ( G_OBJECT_GET_CLASS( G_OBJECT( w ) ) )
diff --git a/multimedia/kino/files/patch-aj b/multimedia/kino/files/patch-aj
deleted file mode 100644
index 035676fe3c09..000000000000
--- a/multimedia/kino/files/patch-aj
+++ /dev/null
@@ -1,57 +0,0 @@
---- src/ieee1394io.h.orig Sat Jul 3 02:01:32 2004
-+++ src/ieee1394io.h Thu Aug 12 21:11:41 2004
-@@ -20,10 +20,13 @@
- #ifndef _IEEE1394IO_H
- #define _IEEE1394IO_H 1
-
-+#if 0
- #include <libraw1394/raw1394.h>
- #include <libraw1394/csr.h>
-+#endif
- #include "dv1394.h"
-
-+#include <pthread.h>
- #include <string>
- using std::string;
- #include <deque>
-@@ -115,7 +118,7 @@
- int port;
-
- /// the handle to the ieee1394 subsystem
-- raw1394handle_t handle;
-+ //raw1394handle_t handle;
-
- public:
-
-@@ -128,11 +131,11 @@
- void StopReceive( void );
- bool StartThread( void );
- void StopThread( void );
-- int Handler( int channel, size_t length, quadlet_t *data );
-+ //int Handler( int channel, size_t length, quadlet_t *data );
- void *Thread();
-
- private:
-- static int HandlerProxy( raw1394handle_t handle, int channel, size_t length, quadlet_t *data );
-+ //static int HandlerProxy( raw1394handle_t handle, int channel, size_t length, quadlet_t *data );
- static void* ThreadProxy( void *arg );
- };
-
-@@ -174,7 +177,7 @@
- pthread_mutex_t avc_mutex;
-
- /// the handle to the ieee1394 subsystem
-- raw1394handle_t avc_handle;
-+ //raw1394handle_t avc_handle;
-
- public:
- AVC( int crd = 0 );
-@@ -198,7 +201,7 @@
- int getNodeId( const char *guid );
-
- private:
-- static int ResetHandler( raw1394handle_t handle, unsigned int generation );
-+ //static int ResetHandler( raw1394handle_t handle, unsigned int generation );
-
- };
-
diff --git a/multimedia/kino/files/patch-ap b/multimedia/kino/files/patch-ap
deleted file mode 100644
index 8917e8d0ccad..000000000000
--- a/multimedia/kino/files/patch-ap
+++ /dev/null
@@ -1,19 +0,0 @@
---- src/page_export_1394.cc Tue Nov 25 21:51:16 2003
-+++ src/page_export_1394.cc Fri Apr 9 16:53:22 2004
-@@ -68,6 +68,7 @@
-
- void Export1394::start()
- {
-+#if 0
- static raw1394handle_t handle;
- GtkLabel * load_label
- = GTK_LABEL( lookup_widget ( exportPage->getWidget(),
-@@ -128,7 +129,7 @@
- {
- gtk_widget_set_sensitive ( GTK_WIDGET ( tmp ), FALSE );
- }
--
-+#endif
- }
-
- /** Define active widgets.
diff --git a/multimedia/kino/files/patch-bg b/multimedia/kino/files/patch-bg
deleted file mode 100644
index c6c9fd821d8b..000000000000
--- a/multimedia/kino/files/patch-bg
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/kino_extra.h Tue Jan 7 07:52:29 2003
-+++ src/kino_extra.h Sat Apr 10 12:20:44 2004
-@@ -20,7 +20,7 @@
- #ifndef _KINO_EXTRA_H_
- #define _KINO_EXTRA_H_
-
--#include <stdint.h>
-+#include <sys/types.h>
-
- // This is mandatory for plug-ins to be able to access the functionality here
- // and is mandatory throughout (in fact, the define should be dropped)
diff --git a/multimedia/kino/files/patch-configure.in b/multimedia/kino/files/patch-configure.in
index 65fe89cc554f..3af6b9a5416d 100644
--- a/multimedia/kino/files/patch-configure.in
+++ b/multimedia/kino/files/patch-configure.in
@@ -1,6 +1,6 @@
---- configure.in.orig Mon Nov 21 00:01:31 2005
-+++ configure.in Mon Nov 28 21:39:59 2005
-@@ -40,29 +40,29 @@
+--- configure.in.orig Tue Apr 25 20:18:28 2006
++++ configure.in Tue Jul 18 23:14:58 2006
+@@ -40,32 +40,32 @@
AC_SUBST(LIBDV_CFLAGS)
AC_SUBST(LIBDV_LIBS)
@@ -10,44 +10,47 @@
+#PKG_CHECK_MODULES(LIBRAW1394, libraw1394 >= 1.0.0, AC_DEFINE(HAVE_LIBRAW1394, 1, [libraw1394 present]))
+#AC_SUBST(LIBRAW1394_CFLAGS)
+#AC_SUBST(LIBRAW1394_LIBS)
+ LIBS="$LIBS $LIBRAW1394_LIBS -lm"
+ CFLAGS="$CFLAGS $LIBRAW1394_CFLAGS"
+ # LIBAVC1394 and LIBROM1394
-AC_CHECK_HEADER([libavc1394/avc1394.h], ,
- [AC_MSG_ERROR([avc1394.h not found, install libavc1394-devel])
-])
-AC_CHECK_LIB(avc1394, avc1394_vcr_record, ,
-- [AC_MSG_ERROR([Unable to link with libavc1394. Check that you have libavc1394 installed and that the version is 0.4.1 or newer])],
-- [$LIBRAW1394_CFLAGS $LIBRAW1394_LIBS])
+- [AC_MSG_ERROR([Unable to link with libavc1394. Check that you have libavc1394 installed and that the version is 0.4.1 or newer])]
+-)
-AC_CHECK_HEADER([libavc1394/rom1394.h], ,
- [AC_MSG_ERROR([rom1394.h not found, install libavc1394-devel])
-])
-AC_CHECK_LIB(rom1394, rom1394_get_node_type, ,
-- [AC_MSG_ERROR([Unable to link with librom1394. Check that your have librom1394 installed (usually part of libavc1394) and that the version is 0.4.1 or newer])],
-- [$LIBRAW1394_CFLAGS $LIBRAW1394_LIBS -lm])
+- [AC_MSG_ERROR([Unable to link with librom1394. Check that your have librom1394 installed (usually part of libavc1394) and that the version is 0.4.1 or newer])]
+-)
+#AC_CHECK_HEADER([libavc1394/avc1394.h], ,
+# [AC_MSG_ERROR([avc1394.h not found, install libavc1394-devel])
+#])
+#AC_CHECK_LIB(avc1394, avc1394_vcr_record, ,
-+# [AC_MSG_ERROR([Unable to link with libavc1394. Check that you have libavc1394 installed and that the version is 0.4.1 or newer])],
-+# [$LIBRAW1394_CFLAGS $LIBRAW1394_LIBS])
++# [AC_MSG_ERROR([Unable to link with libavc1394. Check that you have libavc1394 installed and that the version is 0.4.1 or newer])]
++#)
+#AC_CHECK_HEADER([libavc1394/rom1394.h], ,
+# [AC_MSG_ERROR([rom1394.h not found, install libavc1394-devel])
+#])
+#AC_CHECK_LIB(rom1394, rom1394_get_node_type, ,
-+# [AC_MSG_ERROR([Unable to link with librom1394. Check that your have librom1394 installed (usually part of libavc1394) and that the version is 0.4.1 or newer])],
-+# [$LIBRAW1394_CFLAGS $LIBRAW1394_LIBS -lm])
++# [AC_MSG_ERROR([Unable to link with librom1394. Check that your have librom1394 installed (usually part of libavc1394) and that the version is 0.4.1 or newer])]
++#)
-AC_CHECK_LIB(pthread, pthread_create, ,
-- [AC_MSG_ERROR([You need the pthread library to compile kino])],
-- [$LIBRAW1394_CFLAGS $LIBRAW1394_LIBS -lm])
+- [AC_MSG_ERROR([You need the pthread library to compile kino])]
+-)
-AC_CHECK_LIB(dl, dlopen, ,
-- [AC_MSG_ERROR([You need libdl to compile kino])],
-- [$LIBRAW1394_CFLAGS $LIBRAW1394_LIBS -lm])
+- [AC_MSG_ERROR([You need libdl to compile kino])]
+-)
+#AC_CHECK_LIB(pthread, pthread_create, ,
-+# [AC_MSG_ERROR([You need the pthread library to compile kino])],
-+# [$LIBRAW1394_CFLAGS $LIBRAW1394_LIBS -lm])
++# [AC_MSG_ERROR([You need the pthread library to compile kino])]
++#)
+#AC_CHECK_LIB(dl, dlopen, ,
-+# [AC_MSG_ERROR([You need libdl to compile kino])],
-+# [$LIBRAW1394_CFLAGS $LIBRAW1394_LIBS -lm])
++# [AC_MSG_ERROR([You need libdl to compile kino])]
++#)
# ######################################################################
- # checks for optional ALSA packages
+ # checks for optional packages
diff --git a/multimedia/kino/files/patch-src__Makefile.in b/multimedia/kino/files/patch-src__Makefile.in
index da1bfff183ec..bb7d2ae18131 100644
--- a/multimedia/kino/files/patch-src__Makefile.in
+++ b/multimedia/kino/files/patch-src__Makefile.in
@@ -1,6 +1,6 @@
---- src/Makefile.in.bak Fri Nov 25 20:27:49 2005
-+++ src/Makefile.in Mon Nov 28 21:44:34 2005
-@@ -200,8 +200,6 @@
+--- src/Makefile.in.orig Tue Jul 18 23:15:15 2006
++++ src/Makefile.in Tue Jul 18 23:16:30 2006
+@@ -203,8 +203,6 @@
LIBOBJS = @LIBOBJS@
LIBQUICKTIME_CFLAGS = @LIBQUICKTIME_CFLAGS@
LIBQUICKTIME_LIBS = @LIBQUICKTIME_LIBS@
@@ -9,21 +9,21 @@
LIBS = @LIBS@
LIBTOOL = @LIBTOOL@
LIBXML2_CFLAGS = @LIBXML2_CFLAGS@
-@@ -348,8 +346,6 @@
+@@ -352,8 +350,6 @@
EXTRA_kino_SOURCES = cmd_ref.c
kino_LDADD = \
$(LIBDV_LIBS) \
- $(LIBRAW1394_LIBS) \
- $(LIBAVC1394_LIBS) \
+ $(LIBIEC61883_LIBS) \
$(LIBQUICKTIME_LIBS) \
$(ALSA_LIBS) \
- $(LIBXML2_LIBS) \
-@@ -361,8 +357,6 @@
+@@ -366,8 +362,6 @@
kino_LDFLAGS = -export-dynamic
INCLUDES = -Wall \
$(LIBDV_CFLAGS) \
- $(LIBRAW1394_CFLAGS) \
- $(LIBAVC1394_CFLAGS) \
+ $(LIBIEC61883_CFLAGS) \
$(LIBQUICKTIME_CFLAGS) \
$(ALSA_CFLAGS) \
- $(LIBXML2_CFLAGS) \
diff --git a/multimedia/kino/files/patch-src__gtkenhancedscale.c b/multimedia/kino/files/patch-src__gtkenhancedscale.c
new file mode 100644
index 000000000000..7f062c060958
--- /dev/null
+++ b/multimedia/kino/files/patch-src__gtkenhancedscale.c
@@ -0,0 +1,29 @@
+--- src/gtkenhancedscale.c.orig Mon Apr 10 03:56:16 2006
++++ src/gtkenhancedscale.c Wed Jul 19 00:39:53 2006
+@@ -33,7 +33,7 @@
+ #include "gtkenhancedscale.h"
+ #include <string.h>
+ #include <stdio.h>
+-#include <malloc.h>
++#include <stdlib.h>
+ #include <math.h>
+
+ #undef FANCY
+@@ -159,7 +159,7 @@
+ enhanced_scale->adjustment = adjustment;
+ enhanced_scale->num_adjustments = num_adjustments;
+
+- enhanced_scale->handler_id = malloc( num_adjustments );
++ enhanced_scale->handler_id = malloc( num_adjustments * sizeof(*enhanced_scale->handler_id) );
+
+ for ( i = 0;i < num_adjustments;i++ )
+ {
+@@ -254,7 +254,7 @@
+
+ enhanced_scale->trough = gdk_window_new ( widget->window, &attributes, attributes_mask );
+
+- enhanced_scale->slider = malloc( enhanced_scale->num_adjustments );
++ enhanced_scale->slider = malloc( enhanced_scale->num_adjustments * sizeof(*enhanced_scale->slider) );
+ attributes.width = ENHANCED_SCALE_CLASS ( enhanced_scale ) ->arrow_width;
+ attributes.height = ENHANCED_SCALE_CLASS ( enhanced_scale ) ->arrow_height;
+ attributes.event_mask |= ( GDK_BUTTON_MOTION_MASK |
diff --git a/multimedia/kino/files/patch-ai b/multimedia/kino/files/patch-src__ieee1394io.cc
index 4a637ab2f87a..aeb30c4e54f4 100644
--- a/multimedia/kino/files/patch-ai
+++ b/multimedia/kino/files/patch-src__ieee1394io.cc
@@ -1,12 +1,10 @@
---- src/ieee1394io.cc.orig Thu May 19 00:40:12 2005
-+++ src/ieee1394io.cc Thu Jul 14 00:39:30 2005
-@@ -62,11 +62,13 @@
- #include <sys/poll.h>
- #include <errno.h>
+--- src/ieee1394io.cc.orig Mon May 22 00:16:33 2006
++++ src/ieee1394io.cc Tue Jul 18 23:29:20 2006
+@@ -64,9 +64,11 @@
+ #include <time.h>
+ #include <sys/time.h>
+#if 0
- #include <libraw1394/raw1394.h>
- #include <libraw1394/csr.h>
#include <libavc1394/avc1394.h>
#include <libavc1394/avc1394_vcr.h>
#include <libavc1394/rom1394.h>
@@ -14,108 +12,68 @@
#include "ieee1394io.h"
#include "preferences.h"
-@@ -263,7 +265,7 @@
- raw1394Reader::raw1394Reader( int p, int c, int bufSize ) :
- IEEE1394Reader( c, bufSize ), port( p )
- {
-- handle = NULL;
-+ //handle = NULL;
- cerr << ">>> Using raw1394 capture" << endl;
- }
+@@ -388,6 +390,7 @@
-@@ -332,7 +334,8 @@
-
- bool raw1394Reader::Open()
+ bool iec61883Reader::Open( int port )
{
-- bool success;
-+ bool success = false;
+#if 0
- int numcards;
- struct raw1394_portinfo pinf[ 16 ];
- iso_handler_t oldhandler;
-@@ -367,6 +370,7 @@
- cerr << exc << endl;
+ bool success;
+
+ assert( !m_handle );
+@@ -409,6 +412,8 @@
success = false;
}
-+#endif
return success;
- }
-
-@@ -377,11 +381,13 @@
-
- void raw1394Reader::Close()
- {
-+#if 0
- if ( handle != NULL )
- {
- raw1394_destroy_handle( handle );
- handle = NULL;
- }
+#endif
++ return true;
}
- bool raw1394Reader::StartReceive()
-@@ -391,7 +397,7 @@
- /* Starting iso receive */
- try
- {
-- fail_neg( raw1394_start_iso_rcv( handle, channel ) );
-+// fail_neg( raw1394_start_iso_rcv( handle, channel ) );
- success = true;
- }
- catch ( string exc )
-@@ -405,8 +411,8 @@
- void raw1394Reader::StopReceive()
- {
-- if ( handle != NULL )
-- raw1394_stop_iso_rcv( handle, channel );
-+// if ( handle != NULL )
-+// raw1394_stop_iso_rcv( handle, channel );
+@@ -494,6 +499,7 @@
+
+ return 0;
}
++#endif
-@@ -442,6 +448,7 @@
+ /** The thread responsible for polling the raw1394 interface.
+@@ -502,14 +508,19 @@
+ but only in the pthread_testcancel() function.
*/
-
-+#if 0
- int raw1394Reader::HandlerProxy( raw1394handle_t handle, int channel, size_t length, quadlet_t *data )
++#ifdef HAVE_IEC61883
+ void* iec61883Reader::ThreadProxy( void* arg )
{
- raw1394Reader *self = static_cast< raw1394Reader* >( raw1394_get_userdata( handle ) );
-@@ -553,6 +560,7 @@
-
- return 0;
- }
++#if 0
+ iec61883Reader* self = static_cast< iec61883Reader* >( arg );
+ return self->Thread();
+#endif
++ return NULL;
+ }
-
- /** The thread responsible for polling the raw1394 interface.
-@@ -572,6 +580,7 @@
+ void* iec61883Reader::Thread()
+ {
++#if 0
struct pollfd raw1394_poll;
int result;
-
-+#if 0
- raw1394_poll.fd = raw1394_get_fd( handle );
- raw1394_poll.events = POLLIN | POLLERR | POLLHUP | POLLPRI;
-@@ -589,6 +598,7 @@
+@@ -531,6 +542,7 @@
|| ( raw1394_poll.revents & POLLPRI ) ) )
- result = raw1394_loop_iterate( handle );
+ result = raw1394_loop_iterate( m_handle );
}
+#endif
return NULL;
}
+ #endif
+@@ -617,6 +629,7 @@
-@@ -674,6 +684,7 @@
-
- bool dv1394Reader::Open()
+ bool dv1394Reader::Open( int port )
{
+#if 0
int n_frames = DV1394_MAX_FRAMES / 4;
struct dv1394_init init =
{
-@@ -704,6 +715,8 @@
+@@ -647,6 +660,8 @@
}
return true;
@@ -124,7 +82,7 @@
}
-@@ -712,6 +725,7 @@
+@@ -655,6 +670,7 @@
*/
void dv1394Reader::Close()
{
@@ -132,7 +90,7 @@
if ( m_dv1394_fd != -1 )
{
if ( m_dv1394_map != NULL )
-@@ -720,11 +734,13 @@
+@@ -663,11 +679,13 @@
m_dv1394_map = NULL;
m_dv1394_fd = -1;
}
@@ -146,7 +104,7 @@
/* Starting iso receive */
if ( ioctl( m_dv1394_fd, DV1394_START_RECEIVE, NULL ) )
{
-@@ -732,6 +748,8 @@
+@@ -675,6 +693,8 @@
return false;
}
return true;
@@ -155,7 +113,7 @@
}
-@@ -740,6 +758,7 @@
+@@ -683,6 +703,7 @@
bool dv1394Reader::Handler( int handle )
{
@@ -163,7 +121,7 @@
struct dv1394_status dvst;
struct pollfd pol;
int result;
-@@ -826,6 +845,8 @@
+@@ -769,6 +790,8 @@
}
return true;
@@ -172,15 +130,15 @@
}
-@@ -861,6 +882,7 @@
+@@ -805,6 +828,7 @@
- AVC::AVC( int p ) : port( p )
+ AVC::AVC( void ) : port( -1 ), totalPorts( 0 )
{
+#if 0
pthread_mutex_init( &avc_mutex, NULL );
avc_handle = NULL;
- int numcards;
-@@ -897,6 +919,7 @@
+ struct raw1394_portinfo pinf[ 16 ];
+@@ -825,6 +849,7 @@
avc_handle = NULL;
cerr << exc << endl;
}
@@ -188,7 +146,7 @@
return;
}
-@@ -907,6 +930,7 @@
+@@ -835,6 +860,7 @@
AVC::~AVC()
{
@@ -196,7 +154,7 @@
if ( avc_handle != NULL )
{
pthread_mutex_lock( &avc_mutex );
-@@ -914,11 +938,13 @@
+@@ -842,11 +868,13 @@
avc_handle = NULL;
pthread_mutex_unlock( &avc_mutex );
}
@@ -210,8 +168,8 @@
int AVC::ResetHandler( raw1394handle_t handle, unsigned int generation )
{
cerr << "Reset Handler received" << endl;
-@@ -926,7 +952,7 @@
- common->getPageCapture() ->driver_locked = true;
+@@ -854,7 +882,7 @@
+ common->getPageCapture()->driver_locked = true;
return 0;
}
-
@@ -219,23 +177,23 @@
/** See if a node_id is still valid and pointing to an AV/C Recorder.
-@@ -942,6 +968,7 @@
+@@ -870,6 +898,7 @@
int AVC::isPhyIDValid( int phyID )
{
int value = -1;
+#if 0
- pthread_mutex_lock( &avc_mutex );
- if ( avc_handle != NULL )
- {
-@@ -984,6 +1011,7 @@
- }
- }
+ int currentNode, nodeCount;
+ rom1394_directory rom1394_dir;
+
+@@ -934,6 +963,7 @@
+ if ( value == -1 )
+ port = -1;
pthread_mutex_unlock( &avc_mutex );
+#endif
return value;
}
-@@ -992,6 +1020,7 @@
+@@ -942,6 +972,7 @@
*/
void AVC::Noop( void )
{
@@ -243,7 +201,7 @@
struct pollfd raw1394_poll;
raw1394_poll.fd = raw1394_get_fd( avc_handle );
raw1394_poll.events = POLLIN | POLLPRI;
-@@ -1002,11 +1031,13 @@
+@@ -952,11 +983,13 @@
|| ( raw1394_poll.revents & POLLPRI ) )
raw1394_loop_iterate( avc_handle );
}
@@ -257,7 +215,7 @@
pthread_mutex_lock( &avc_mutex );
if ( avc_handle != NULL )
{
-@@ -1018,12 +1049,14 @@
+@@ -968,12 +1001,14 @@
}
}
pthread_mutex_unlock( &avc_mutex );
@@ -272,7 +230,7 @@
pthread_mutex_lock( &avc_mutex );
if ( avc_handle != NULL )
{
-@@ -1040,12 +1073,14 @@
+@@ -990,12 +1025,14 @@
};
nanosleep( &t, NULL );
pthread_mutex_unlock( &avc_mutex );
@@ -287,7 +245,7 @@
pthread_mutex_lock( &avc_mutex );
if ( avc_handle != NULL )
{
-@@ -1058,12 +1093,14 @@
+@@ -1008,12 +1045,14 @@
};
nanosleep( &t, NULL );
pthread_mutex_unlock( &avc_mutex );
@@ -302,7 +260,7 @@
pthread_mutex_lock( &avc_mutex );
if ( avc_handle != NULL )
{
-@@ -1071,12 +1108,14 @@
+@@ -1021,12 +1060,14 @@
avc1394_vcr_rewind( avc_handle, phyID );
}
pthread_mutex_unlock( &avc_mutex );
@@ -317,7 +275,7 @@
pthread_mutex_lock( &avc_mutex );
if ( avc_handle != NULL )
{
-@@ -1084,11 +1123,13 @@
+@@ -1034,11 +1075,13 @@
avc1394_vcr_forward( avc_handle, phyID );
}
pthread_mutex_unlock( &avc_mutex );
@@ -331,7 +289,7 @@
pthread_mutex_lock( &avc_mutex );
if ( avc_handle != NULL )
{
-@@ -1096,11 +1137,13 @@
+@@ -1046,11 +1089,13 @@
avc1394_vcr_next( avc_handle, phyID );
}
pthread_mutex_unlock( &avc_mutex );
@@ -345,7 +303,7 @@
pthread_mutex_lock( &avc_mutex );
if ( avc_handle != NULL )
{
-@@ -1108,11 +1151,13 @@
+@@ -1058,11 +1103,13 @@
avc1394_vcr_previous( avc_handle, phyID );
}
pthread_mutex_unlock( &avc_mutex );
@@ -359,7 +317,7 @@
pthread_mutex_lock( &avc_mutex );
if ( avc_handle != NULL )
{
-@@ -1120,11 +1165,13 @@
+@@ -1070,11 +1117,13 @@
avc1394_vcr_next_index( avc_handle, phyID );
}
pthread_mutex_unlock( &avc_mutex );
@@ -373,7 +331,7 @@
pthread_mutex_lock( &avc_mutex );
if ( avc_handle != NULL )
{
-@@ -1132,11 +1179,13 @@
+@@ -1082,11 +1131,13 @@
avc1394_vcr_previous_index( avc_handle, phyID );
}
pthread_mutex_unlock( &avc_mutex );
@@ -387,7 +345,7 @@
pthread_mutex_lock( &avc_mutex );
if ( avc_handle != NULL )
{
-@@ -1144,11 +1193,13 @@
+@@ -1094,11 +1145,13 @@
avc1394_vcr_record( avc_handle, phyID );
}
pthread_mutex_unlock( &avc_mutex );
@@ -401,7 +359,7 @@
pthread_mutex_lock( &avc_mutex );
if ( avc_handle != NULL )
{
-@@ -1156,12 +1207,14 @@
+@@ -1106,12 +1159,14 @@
avc1394_vcr_trick_play( avc_handle, phyID, speed );
}
pthread_mutex_unlock( &avc_mutex );
@@ -416,7 +374,7 @@
pthread_mutex_lock( &avc_mutex );
if ( avc_handle != NULL )
{
-@@ -1169,11 +1222,13 @@
+@@ -1119,11 +1174,13 @@
val = avc1394_vcr_status( avc_handle, phyID );
}
pthread_mutex_unlock( &avc_mutex );
@@ -430,55 +388,43 @@
pthread_mutex_lock( &avc_mutex );
if ( avc_handle != NULL )
{
-@@ -1202,10 +1257,13 @@
+@@ -1151,12 +1208,14 @@
+
}
pthread_mutex_unlock( &avc_mutex );
- return true;
+#endif
-+ return false;
+ return true;
}
int AVC::getNodeId( const char *guid )
{
+ int value = -1;
+#if 0
pthread_mutex_lock( &avc_mutex );
if ( avc_handle != NULL )
{
-@@ -1228,6 +1286,7 @@
- }
- }
+@@ -1198,6 +1257,7 @@
+ if ( value == -1 )
+ port = -1;
pthread_mutex_unlock( &avc_mutex );
+#endif
- return -1;
+ return value;
}
-@@ -1235,6 +1294,7 @@
- dv1394Writer::dv1394Writer( string device, unsigned int channel, unsigned int nBuffers,
- unsigned int cip_n, unsigned int cip_d, unsigned int syt_offset ) : isInitialised( false )
+@@ -1321,6 +1381,7 @@
+ int iec61883Writer::HandlerProxy( unsigned char *data, int n_dif_blocks,
+ unsigned int dropped, void *callback_data)
{
+#if 0
- m_fd = -1;
- m_deviceName = device;
- m_channel = channel;
-@@ -1244,6 +1304,7 @@
- m_syt_offset = syt_offset;
-
- m_fd = open( m_deviceName.c_str(), O_RDWR );
+ if ( callback_data )
+ {
+ iec61883Writer* writer = static_cast< iec61883Writer* >( callback_data );
+@@ -1330,6 +1391,8 @@
+ {
+ return -1;
+ }
+#endif
++ return -1;
}
-@@ -1259,6 +1320,7 @@
-
- void dv1394Writer::SendFrame( Frame &frame )
- {
-+#if 0
- bool isPAL = frame.IsPAL();
-
- if ( !isInitialised )
-@@ -1283,4 +1345,5 @@
- }
-
- write( m_fd, frame.data, ( isPAL ? DV1394_PAL_FRAME_SIZE : DV1394_NTSC_FRAME_SIZE ) );
-+#endif
- }
diff --git a/multimedia/kino/files/patch-src__ieee1394io.h b/multimedia/kino/files/patch-src__ieee1394io.h
new file mode 100644
index 000000000000..e98b0cdbd40e
--- /dev/null
+++ b/multimedia/kino/files/patch-src__ieee1394io.h
@@ -0,0 +1,57 @@
+--- src/ieee1394io.h.orig Sun May 21 19:14:23 2006
++++ src/ieee1394io.h Tue Jul 18 22:56:29 2006
+@@ -20,8 +20,10 @@
+ #ifndef _IEEE1394IO_H
+ #define _IEEE1394IO_H 1
+
++#if 0
+ #include <libraw1394/raw1394.h>
+ #include <libraw1394/csr.h>
++#endif
+ #ifdef HAVE_IEC61883
+ #include <libiec61883/iec61883.h>
+ #endif
+@@ -29,6 +31,7 @@
+ #include "dv1394.h"
+ #endif
+
++#include <pthread.h>
+ #include <string>
+ using std::string;
+ #include <deque>
+@@ -114,7 +117,7 @@
+ {
+ private:
+ /// the handle to libraw1394
+- raw1394handle_t m_handle;
++ // raw1394handle_t m_handle;
+
+ /// the handle to libiec61883
+ iec61883_dv_fb_t m_iec61883dv;
+@@ -130,7 +133,7 @@
+ void StopReceive( void );
+ bool StartThread( int port );
+ void StopThread( void );
+- int Handler( int length, int complete, unsigned char *data );
++ // int Handler( int length, int complete, unsigned char *data );
+ void *Thread();
+ void ResetHandler( void );
+
+@@ -183,7 +186,7 @@
+ pthread_mutex_t avc_mutex;
+
+ /// the handle to the ieee1394 subsystem
+- raw1394handle_t avc_handle;
++ //raw1394handle_t avc_handle;
+
+ public:
+ AVC( void );
+@@ -211,7 +214,7 @@
+ }
+
+ private:
+- static int ResetHandler( raw1394handle_t handle, unsigned int generation );
++ //static int ResetHandler( raw1394handle_t handle, unsigned int generation );
+
+ };
+
diff --git a/multimedia/kino/files/patch-src__kino_extra.h b/multimedia/kino/files/patch-src__kino_extra.h
new file mode 100644
index 000000000000..0b4e686adb3b
--- /dev/null
+++ b/multimedia/kino/files/patch-src__kino_extra.h
@@ -0,0 +1,12 @@
+--- src/kino_extra.h.orig Thu Apr 13 08:07:40 2006
++++ src/kino_extra.h Tue Jul 18 23:09:33 2006
+@@ -20,7 +20,8 @@
+ #ifndef _KINO_EXTRA_H_
+ #define _KINO_EXTRA_H_
+
+-#include <stdint.h>
++// #include <stdint.h>
++#include <sys/types.h>
+ #include <gtk/gtk.h>
+
+ // This is mandatory for plug-ins to be able to access the functionality here
diff --git a/multimedia/kino/files/patch-src__page_export_1394.cc b/multimedia/kino/files/patch-src__page_export_1394.cc
new file mode 100644
index 000000000000..37c873641437
--- /dev/null
+++ b/multimedia/kino/files/patch-src__page_export_1394.cc
@@ -0,0 +1,18 @@
+--- src/page_export_1394.cc.orig Sun May 21 23:03:27 2006
++++ src/page_export_1394.cc Tue Jul 18 22:59:27 2006
+@@ -63,6 +63,7 @@
+
+ void Export1394::start()
+ {
++#if 0
+ static raw1394handle_t handle;
+ gchar s[ 512 ];
+
+@@ -140,6 +141,7 @@
+ );
+ #endif
+
++#endif
+ }
+
+ /** Define active widgets.
diff --git a/multimedia/kino/files/patch-src__playlist.cc b/multimedia/kino/files/patch-src__playlist.cc
new file mode 100644
index 000000000000..54bd540d0f06
--- /dev/null
+++ b/multimedia/kino/files/patch-src__playlist.cc
@@ -0,0 +1,108 @@
+--- src/playlist.cc.orig Mon Apr 24 07:14:21 2006
++++ src/playlist.cc Wed Jul 19 15:25:22 2006
+@@ -301,7 +301,7 @@
+ return output;
+ }
+
+-typedef bool ( *callback ) ( xmlNodePtr node, void *p );
++typedef bool ( *callback ) ( xmlNodePtr node, void *p, bool *freed );
+
+ typedef struct
+ {
+@@ -340,7 +340,7 @@
+ \param p pointer to MovieInfo struct
+ \result true if file has been found and xml tree walk is done */
+
+-static bool findFile( xmlNodePtr node, void *p )
++static bool findFile( xmlNodePtr node, void *p, bool *freed )
+ {
+ MovieInfo * data = ( MovieInfo* ) p;
+
+@@ -412,7 +412,7 @@
+ \param p pointer to a string containing the project directory
+ \result true if file has been found and xml tree walk is done */
+
+-static bool fillMap( xmlNodePtr node, void *p )
++static bool fillMap( xmlNodePtr node, void *p, bool *freed )
+ {
+ if ( xmlStrcmp( node->name, ( const xmlChar* ) "video" ) == 0 )
+ {
+@@ -468,6 +468,7 @@
+ << " - removing from list" << endl;
+ xmlUnlinkNode( node );
+ xmlFreeNode( node );
++ *freed = true;
+ }
+ }
+ }
+@@ -489,7 +490,7 @@
+ If the scene has been found in the playlist, the file name
+ and first frame number are returned in the private data. */
+
+-static bool findSceneStart( xmlNodePtr node, void *p )
++static bool findSceneStart( xmlNodePtr node, void *p, bool *freed )
+ {
+ int fileCount = 0;
+ MovieInfo *data = ( MovieInfo* ) p;
+@@ -562,7 +563,7 @@
+ }
+
+
+-static bool findSceneEnd( xmlNodePtr node, void *p )
++static bool findSceneEnd( xmlNodePtr node, void *p, bool *freed )
+ {
+ bool found = false;
+ xmlChar *src = NULL;
+@@ -640,7 +641,7 @@
+
+ \note This code requires a <video> node format that is not defined in smil. */
+
+-static bool countFrames( xmlNodePtr node, void *p )
++static bool countFrames( xmlNodePtr node, void *p, bool *freed )
+ {
+ if ( xmlStrcmp( node->name, ( const xmlChar* ) "video" ) == 0 )
+ {
+@@ -686,7 +687,7 @@
+ <video src="file.avi" clipBegin="200" clipEnd="800" \>
+
+ \note This code requires a <video> node format that is not defined in smil. */
+-static bool convertEli( xmlNodePtr node, void *p )
++static bool convertEli( xmlNodePtr node, void *p, bool *freed )
+ {
+ if ( xmlStrcmp( node->name, ( const xmlChar* ) "video" ) == 0 )
+ {
+@@ -741,10 +742,13 @@
+
+ while ( node != NULL && done == false )
+ {
+- done = ( *func ) ( node, p );
+- if ( done == false && node->xmlChildrenNode != NULL )
++ bool freed = false;
++ xmlNodePtr next = node->next;
++ done = ( *func ) ( node, p, &freed );
++ if ( done == false && freed == false
++ && node->xmlChildrenNode != NULL )
+ done = parse( node->xmlChildrenNode, func, p );
+- node = node->next;
++ node = next;
+ }
+ return done;
+ }
+@@ -1724,7 +1728,7 @@
+ return true;
+ }
+
+-static bool relativeMap( xmlNodePtr node, void *p )
++static bool relativeMap( xmlNodePtr node, void *p, bool *freed )
+ {
+ if ( xmlStrcmp( node->name, ( const xmlChar* ) "video" ) == 0 )
+ {
+@@ -1922,7 +1926,7 @@
+ \result true if file has been found and xml tree walk is done
+ */
+
+-static bool checkIfFileUsed( xmlNodePtr node, void *p )
++static bool checkIfFileUsed( xmlNodePtr node, void *p, bool *freed )
+ {
+ if ( xmlStrcmp( node->name, ( const xmlChar* ) "video" ) == 0 )
+ {
diff --git a/multimedia/kino/files/patch-as b/multimedia/kino/files/patch-src__preferences_dialog.cc
index 3c4c70e8b775..a71e08ee7d3d 100644
--- a/multimedia/kino/files/patch-as
+++ b/multimedia/kino/files/patch-src__preferences_dialog.cc
@@ -1,6 +1,6 @@
---- src/preferences_dialog.cc.orig Tue Dec 28 16:22:48 2004
-+++ src/preferences_dialog.cc Thu Jul 14 00:42:56 2005
-@@ -32,8 +32,10 @@
+--- src/preferences_dialog.cc.orig Mon May 22 00:44:30 2006
++++ src/preferences_dialog.cc Tue Jul 18 23:06:23 2006
+@@ -34,8 +34,10 @@
#include "support.h"
#include "commands.h"
#include "message.h"
@@ -11,7 +11,7 @@
/* Declare callbacks for the jogshuttle handling */
static void
-@@ -65,9 +67,13 @@
+@@ -67,9 +69,13 @@
GtkWidget* glade_menuitem;
GtkWidget* widget;
int currentNode, itemCount = 0, currentItem = 0;
@@ -25,34 +25,28 @@
media_ctrl_key *mkeys;
-@@ -321,6 +327,7 @@
+@@ -309,6 +315,7 @@
widget = lookup_widget( dialog, "optionmenu_avc_phyid" );
+#if 0
- #ifdef LIBRAW1394_OLD
-
- if ( ( handle = raw1394_get_handle() ) )
-@@ -383,6 +390,7 @@
- handle = NULL;
+ if ( ( handle = raw1394_new_handle() ) )
+ {
+ raw1394_portinfo ports[MAX_1394_PORTS];
+@@ -370,6 +377,7 @@
+ }
}
}
+#endif
gtk_option_menu_set_menu ( GTK_OPTION_MENU ( widget ), glade_menu );
gtk_option_menu_set_history( GTK_OPTION_MENU( widget ), currentItem );
-@@ -422,6 +430,7 @@
+@@ -406,7 +414,9 @@
void
on_avc_phyid_activate( GtkMenuItem * menu_item, gpointer user_data )
{
+#if 0
- nodeid_t currentNode = ( nodeid_t )( long )user_data;
- static raw1394handle_t handle;
- #ifdef LIBRAW1394_OLD
-@@ -441,6 +450,7 @@
- }
- raw1394_destroy_handle( handle );
- handle = NULL;
+ strncpy( Preferences::getInstance().avcGUID, (char *) user_data, 64 );
+#endif
}
diff --git a/multimedia/kino/pkg-plist b/multimedia/kino/pkg-plist
index 2fd908c11af4..870f05c8cfa2 100644
--- a/multimedia/kino/pkg-plist
+++ b/multimedia/kino/pkg-plist
@@ -71,6 +71,11 @@ share/gnome/kino/help/time.html
share/gnome/kino/help/trim.html
share/gnome/kino/help/ui.html
share/gnome/kino/scripts/help.sh
+share/gnome/kino/scripts/dvdauthor/dvdauthor-k3b.sh
+share/gnome/kino/scripts/dvdauthor/dvdauthor.sh
+share/gnome/kino/scripts/dvdauthor/growisofs.sh
+share/gnome/kino/scripts/dvdauthor/none.sh
+share/gnome/kino/scripts/dvdauthor/qdvdauthor.sh
share/gnome/kino/scripts/exports/extract_chapters
share/gnome/kino/scripts/exports/ffmpeg2theora.sh
share/gnome/kino/scripts/exports/ffmpeg_3gp.sh
@@ -84,8 +89,10 @@ share/gnome/kino/scripts/exports/ffmpeg_h264_dual.sh
share/gnome/kino/scripts/exports/ffmpeg_mp3.sh
share/gnome/kino/scripts/exports/ffmpeg_mp4.sh
share/gnome/kino/scripts/exports/ffmpeg_mp4_dual.sh
+share/gnome/kino/scripts/exports/ffmpeg_utils.sh
share/gnome/kino/scripts/exports/ffmpeg_vcd.sh
share/gnome/kino/scripts/exports/mencoder.sh
+share/gnome/kino/scripts/exports/mencoder_dual.sh
share/gnome/kino/scripts/exports/rawplay.sh
share/gnome/kino/scripts/import/media.sh
share/gnome/kino/scripts/publish/frame.sh
@@ -127,18 +134,22 @@ share/gnome/kino/lumas/symmetric_clock.png
share/gnome/pixmaps/kino.png
share/locale/cs/LC_MESSAGES/kino.mo
share/locale/da/LC_MESSAGES/kino.mo
+share/locale/de/LC_MESSAGES/kino.mo
share/locale/es/LC_MESSAGES/kino.mo
+share/locale/eu/LC_MESSAGES/kino.mo
share/locale/fr/LC_MESSAGES/kino.mo
+share/locale/hu/LC_MESSAGES/kino.mo
share/locale/it/LC_MESSAGES/kino.mo
+share/locale/nb/LC_MESSAGES/kino.mo
share/locale/no/LC_MESSAGES/kino.mo
+share/locale/ru/LC_MESSAGES/kino.mo
share/locale/sv/LC_MESSAGES/kino.mo
-share/locale/nb/LC_MESSAGES/kino.mo
-share/locale/eu/LC_MESSAGES/kino.mo
share/mime/packages/kino.xml
@dirrm include/kino
@dirrm lib/kino-gtk2
@dirrm share/gnome/kino/help
@dirrm share/gnome/kino/lumas
+@dirrm share/gnome/kino/scripts/dvdauthor
@dirrm share/gnome/kino/scripts/exports
@dirrm share/gnome/kino/scripts/import
@dirrm share/gnome/kino/scripts/publish