aboutsummaryrefslogtreecommitdiff
path: root/multimedia/kissdx/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2008-03-23 10:46:18 +0000
committerPav Lucistnik <pav@FreeBSD.org>2008-03-23 10:46:18 +0000
commitfc4d65e932880e5e11b16bacfd844ed850934ea3 (patch)
tree1cb97c3fd29990dc0ffc7ef7c71abb69b25e74ff /multimedia/kissdx/Makefile
parentf74addf13856524b4a92680b9fa1e937fbc00fa9 (diff)
downloadports-fc4d65e932880e5e11b16bacfd844ed850934ea3.tar.gz
ports-fc4d65e932880e5e11b16bacfd844ed850934ea3.zip
Notes
Diffstat (limited to 'multimedia/kissdx/Makefile')
-rw-r--r--multimedia/kissdx/Makefile54
1 files changed, 54 insertions, 0 deletions
diff --git a/multimedia/kissdx/Makefile b/multimedia/kissdx/Makefile
new file mode 100644
index 000000000000..54add11e450e
--- /dev/null
+++ b/multimedia/kissdx/Makefile
@@ -0,0 +1,54 @@
+# New ports collection makefile for: kissdx
+# Date created: 20. November 2007
+# Whom: Simon I. Rigét
+#
+# $FreeBSD$
+#
+
+PORTNAME= kissdx
+PORTVERSION= 0.13.10a
+CATEGORIES= multimedia net
+MASTER_SITES= http://paragi.dk/kiss/
+
+MAINTAINER= freebsd@paragi.dk
+COMMENT= A multimedia streaming server for KiSS/Linksys player
+
+# Dependencies of other packeges
+LIB_DEPENDS= gd:${PORTSDIR}/graphics/gd \
+ jpeg:${PORTSDIR}/graphics/jpeg \
+ dvdread:${PORTSDIR}/multimedia/libdvdread
+
+USE_ICONV= yes
+
+# Man pages
+MAN1= kissdx.1
+
+# RC start and stop service
+USE_RC_SUBR= kissdx
+
+# set enviroment variables for port makefile
+MAKE_ENV= FreeBSD=defined CC="${CC}" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" LOCALBASE=${LOCALBASE}
+
+# Convert CR/LF to LF in source files
+USE_DOS2UNIX= yes
+
+SUB_FILES= pkg-message
+
+# Remove files at uninstall (like pkg-plist)
+PLIST_FILES= etc/kissdx.conf sbin/kissdx sbin/kissd-pretrigger sbin/kissd-posttrigger
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|Linux|Unix|g ; s|/etc/|${PREFIX}/etc/|g' ${WRKSRC}/kissdx.1
+ @${REINPLACE_CMD} -e 's|/etc/|${PREFIX}/etc/|g' ${WRKSRC}/config.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/kissdx ${PREFIX}/sbin/kissdx
+ ${INSTALL_SCRIPT} ${WRKSRC}/kissd-pretrigger ${PREFIX}/sbin/kissd-pretrigger
+ ${INSTALL_SCRIPT} ${WRKSRC}/kissd-posttrigger ${PREFIX}/sbin/kissd-posttrigger
+ ${INSTALL_DATA} ${WRKSRC}/kissdx.conf ${PREFIX}/etc/kissdx.conf
+ ${INSTALL_MAN} ${WRKSRC}/kissdx.1 ${MANPREFIX}/man/man1/kissdx.1
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>