aboutsummaryrefslogtreecommitdiff
path: root/multimedia/kmplayer-kde4/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-03-20 12:46:02 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-03-20 12:46:02 +0000
commit697cfd49dacb7791c7515914b7719788e5302e4e (patch)
treeff1ea3a1c002170f57c6213e9698cec70b0fe92f /multimedia/kmplayer-kde4/Makefile
parent2e3f58916219f770efc6a9c6211540135fcacd14 (diff)
downloadports-697cfd49dacb7791c7515914b7719788e5302e4e.tar.gz
ports-697cfd49dacb7791c7515914b7719788e5302e4e.zip
Notes
Diffstat (limited to 'multimedia/kmplayer-kde4/Makefile')
-rw-r--r--multimedia/kmplayer-kde4/Makefile93
1 files changed, 79 insertions, 14 deletions
diff --git a/multimedia/kmplayer-kde4/Makefile b/multimedia/kmplayer-kde4/Makefile
index 075155a8fbe9..598852ddcafe 100644
--- a/multimedia/kmplayer-kde4/Makefile
+++ b/multimedia/kmplayer-kde4/Makefile
@@ -6,16 +6,24 @@
#
PORTNAME= kmplayer
-PORTVERSION= 0.9.4a
+PORTVERSION= 0.10.0c
+PORTREVISION= # zero
PORTEPOCH= 2
CATEGORIES= multimedia audio kde
-MASTER_SITES= http://kmplayer.kde.org/pkgs/ \
- http://freebsd.ricin.com/ports/distfiles/
-#DISTNAME= ${PORTNAME}-${PORTVERSION:C/\.r/-rc/}
+MASTER_SITES= http://freebsd.ricin.com/ports/distfiles/ \
+ http://kmplayer.kde.org/pkgs/
+DISTNAME= ${PORTNAME}-${PORTVERSION}
MAINTAINER= danny@ricin.com
-COMMENT= KDE frontend to mplayer
+COMMENT= KDE frontend to MPlayer, Xine, GStreamer
+# It seems neither cairo nor npplayer can be disabled if the deps are present
+# So deps must be added here for package consistency/POLA
+PLIST_FILES+= bin/knpplayer
+LIB_DEPENDS= cairo:${PORTSDIR}/graphics/cairo \
+ dbus-glib-1:${PORTSDIR}/devel/dbus-glib \
+ dbus-qt-1:${PORTSDIR}/devel/dbus-qt3 \
+ expat:${PORTSDIR}/textproc/expat2
RUN_DEPENDS= mplayer:${PORTSDIR}/multimedia/mplayer
USE_BZIP2= yes
@@ -23,31 +31,88 @@ USE_KDEBASE_VER=3
USE_XLIB= yes
USE_GMAKE= yes
USE_AUTOTOOLS= libtool:15
+USE_LDCONFIG= yes
+USE_GNOME= atk glib20 gtk20 libxml2 pango # See above
+WANT_GSTREAMER= yes # Can't be set after bsd.port.pre.mk
-OPTIONS= GSTREAMER "Enable gstreamer playback support" off \
- XINE "Enable libxine playback support" off
+OPTIONS= ARTS "ARts audio system support" on \
+ GSTREAMER "GStreamer playback support" off \
+ TUBESTUFF "YouTube and other 'download & play' support" off \
+ XINE "Xine playback support" off
-WANT_GSTREAMER= yes
+CONFIGURE_ENV+= PKG_CONFIG=${LOCALBASE}/bin/pkg-config
post-patch:
# do not try to roll our own mimetypes
- @${REINPLACE_CMD} -E -e \
- 's|^(SUBDIRS.*)mimetypes|\1|' \
+ ${REINPLACE_CMD} -E -e 's|^(SUBDIRS.*)mimetypes|\1|'\
${WRKSRC}/Makefile.in
.include <bsd.port.pre.mk>
+.if defined(WITHOUT_ARTS)
+CONFIGURE_ARGS+=--without-arts
+.endif # WITHOUT_ARTS
+
.if defined(WITH_GSTREAMER)
USE_GSTREAMER+= yes
PLIST_FILES+= bin/kgstplayer
.else
-CONFIGURE_ARGS+= --without-gstreamer
-.endif
+CONFIGURE_ARGS+=--without-gstreamer
+.endif # WITH_GSTREAMER
+
.if defined(WITH_XINE)
LIB_DEPENDS+= xine:${PORTSDIR}/multimedia/libxine
PLIST_FILES+= bin/kxineplayer
.else
-CONFIGURE_ARGS+= --without-xine
-.endif
+CONFIGURE_ARGS+=--without-xine
+.endif # WITH_XINE
+
+.if defined(WITH_TUBESTUFF)
+TUBESTUFF_VER= 20080314
+DISTFILES= tubestuff-${TUBESTUFF_VER}.tbz
+DISTFILES+= ${DISTNAME}.tar.bz2
+BUILD_DEPENDS+= mencoder:${PORTSDIR}/multimedia/mencoder
+USE_PYTHON= yes
+
+post-extract:
+ ${TAR} xvf ${DISTDIR}/tubestuff-${TUBESTUFF_VER}.tbz ${WRKDIR}
+
+pre-patch:
+ ${REINPLACE_CMD} -e 's|PREFIX=/usr/local|PREFIX=${PREFIX}|'\
+ ${WRKDIR}/tubestuff/tubestuff-patch-kmplayerpartbase.cpp.in &&\
+ cd ${WRKDIR}/tubestuff && ./make_patch
+
+do-patch:
+ cd ${WRKSRC} && ${PATCH} <\
+ ${WRKDIR}/tubestuff/patch-kmplayerpartbase.cpp-tubestuff
+
+pre-install:
+ cd ${WRKDIR}/tubestuff && ./make_video && ./make_readme
+ ${REINPLACE_CMD} -e 's|PREFIX=/usr/local|PREFIX=${PREFIX}|'\
+ ${WRKDIR}/tubestuff/make_install
+
+post-install:
+ cd ${WRKDIR}/tubestuff && ./make_install
+
+.if defined(NOPORTDOCS)
+ ${RM} ${PREFIX}/share/apps/kmplayer/tubestuff/README
+.else
+PLIST_FILES+= share/apps/kmplayer/tubestuff/README
+.endif # NOPORTDOCS
+
+PLIST_FILES+= share/apps/kmplayer/tubestuff/altertube-dl \
+ share/apps/kmplayer/tubestuff/blip-dl \
+ share/apps/kmplayer/tubestuff/dailymotion-dl \
+ share/apps/kmplayer/tubestuff/downloading.avi \
+ share/apps/kmplayer/tubestuff/google-dl \
+ share/apps/kmplayer/tubestuff/liveleak-dl \
+ share/apps/kmplayer/tubestuff/metacafe-dl \
+ share/apps/kmplayer/tubestuff/ourmedia-dl \
+ share/apps/kmplayer/tubestuff/playtube \
+ share/apps/kmplayer/tubestuff/pornotube-dl \
+ share/apps/kmplayer/tubestuff/revver-dl \
+ share/apps/kmplayer/tubestuff/youtube-dl \
+ "@dirrm share/apps/kmplayer/tubestuff"
+.endif # WITH_TUBESTUFF
.include <bsd.port.post.mk>