aboutsummaryrefslogtreecommitdiff
path: root/multimedia/libcec
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2014-06-20 23:04:08 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2014-06-20 23:04:08 +0000
commit00eba73aa534ff4d5a277be4ff95f7784a96ce8e (patch)
tree31c2e4aa1c3f0fbe46364f8e0b895b22704b09b1 /multimedia/libcec
parented0547e8b0f26ba72c417b404d0d7065f8190996 (diff)
downloadports-00eba73aa534ff4d5a277be4ff95f7784a96ce8e.tar.gz
ports-00eba73aa534ff4d5a277be4ff95f7784a96ce8e.zip
Notes
Diffstat (limited to 'multimedia/libcec')
-rw-r--r--multimedia/libcec/Makefile15
-rw-r--r--multimedia/libcec/distinfo4
-rw-r--r--multimedia/libcec/files/patch-src__lib__adapter__Pulse-Eight__USBCECAdapterDetection.cpp100
-rw-r--r--multimedia/libcec/pkg-plist12
4 files changed, 18 insertions, 113 deletions
diff --git a/multimedia/libcec/Makefile b/multimedia/libcec/Makefile
index ea21d8a693da..b7215bfae034 100644
--- a/multimedia/libcec/Makefile
+++ b/multimedia/libcec/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= libcec
-PORTVERSION= 2.1.3
-PORTREVISION= 1
+PORTVERSION= 2.1.4
CATEGORIES= multimedia
MASTER_SITES= GH
@@ -15,14 +14,20 @@ LICENSE_FILE= ${WRKSRC}/COPYING
USE_GITHUB= yes
GH_ACCOUNT= Pulse-Eight
-GH_COMMIT= 54be21e
-GH_TAGNAME= ${PORTNAME}-${PORTVERSION}
+GH_COMMIT= 81e3821
+GH_TAGNAME= ${PORTNAME}-${PORTVERSION}-repack
-USES= pathfix pkgconfig
+USES= pathfix pkgconfig libtool
PATHFIX_MAKEFILEIN=Makefile.am
USE_AUTOTOOLS= aclocal autoheader automake autoconf libtoolize
ACLOCAL_ARGS= -I.
AUTOMAKE_ARGS= --add-missing
USE_LDCONFIG= yes
+post-patch:
+ ${REINPLACE_CMD} 's;-Wno-psabi;;' ${WRKSRC}/configure.ac
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libcec.so.2
+
.include <bsd.port.mk>
diff --git a/multimedia/libcec/distinfo b/multimedia/libcec/distinfo
index 384585bfb395..87356263dfe2 100644
--- a/multimedia/libcec/distinfo
+++ b/multimedia/libcec/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libcec-2.1.3.tar.gz) = 2aa88451b528184b02077ee8c6cd10e2f89121a6a05b1b35b4b792b03108a9d1
-SIZE (libcec-2.1.3.tar.gz) = 1087121
+SHA256 (libcec-2.1.4.tar.gz) = b8e869cc16a5c73a0da4443911cfd0e931f17324bdaad8210b0de085db0573ea
+SIZE (libcec-2.1.4.tar.gz) = 1093922
diff --git a/multimedia/libcec/files/patch-src__lib__adapter__Pulse-Eight__USBCECAdapterDetection.cpp b/multimedia/libcec/files/patch-src__lib__adapter__Pulse-Eight__USBCECAdapterDetection.cpp
deleted file mode 100644
index 7e2d53e224d5..000000000000
--- a/multimedia/libcec/files/patch-src__lib__adapter__Pulse-Eight__USBCECAdapterDetection.cpp
+++ /dev/null
@@ -1,100 +0,0 @@
---- ./src/lib/adapter/Pulse-Eight/USBCECAdapterDetection.cpp.orig 2013-05-13 15:09:14.000000000 +0200
-+++ ./src/lib/adapter/Pulse-Eight/USBCECAdapterDetection.cpp 2013-06-12 16:31:03.000000000 +0200
-@@ -61,6 +61,8 @@
- #include <libudev.h>
- }
- #elif defined(__FreeBSD__)
-+#include <sys/param.h>
-+#include <sys/sysctl.h>
- #include <stdio.h>
- #include <unistd.h>
- #endif
-@@ -434,22 +436,77 @@
- }
- #elif defined(__FreeBSD__)
- char devicePath[PATH_MAX + 1];
-+ char infos[512];
-+ char sysctlname[32];
-+ char ttyname[8];
-+ char *pos;
-+ size_t infos_size = sizeof(infos);
- int i;
-
-- for (i = 0; i < 8; ++i)
-+ for (i = 0; ; ++i)
- {
-- (void)snprintf(devicePath, sizeof(devicePath), "/dev/ttyU%d", i);
-- if (strDevicePath && strcmp(devicePath, strDevicePath) != 0)
-+ unsigned int iVendor, iProduct;
-+ memset(infos, 0, sizeof(infos));
-+ (void)snprintf(sysctlname, sizeof(sysctlname),
-+ "dev.umodem.%d.%%pnpinfo", i);
-+ if (sysctlbyname(sysctlname, infos, &infos_size,
-+ NULL, 0) != 0)
-+ break;
-+ pos = strstr(infos, "vendor=");
-+ if (pos == NULL)
- continue;
-- if (!access(devicePath, 0))
-- {
-- snprintf(deviceList[iFound].strComPath, sizeof(deviceList[iFound].strComPath), "%s", devicePath);
-- snprintf(deviceList[iFound].strComName, sizeof(deviceList[iFound].strComName), "%s", devicePath);
-- deviceList[iFound].iVendorId = CEC_VID;
-- deviceList[iFound].iProductId = CEC_VID;
-- deviceList[iFound].adapterType = ADAPTERTYPE_P8_EXTERNAL; // will be overridden when not doing a "quick scan" by the actual type
-- iFound++;
-+ sscanf(pos, "vendor=%x ", &iVendor);
-+
-+ pos = strstr(infos, "product=");
-+ if (pos == NULL)
-+ continue;
-+ sscanf(pos, "product=%x ", &iProduct);
-+
-+ if (iVendor != CEC_VID || (iProduct != CEC_PID && iProduct != CEC_PID2))
-+ continue;
-+
-+ pos = strstr(infos, "ttyname=");
-+ if (pos == NULL)
-+ continue;
-+ sscanf(pos, "ttyname=%s ", ttyname);
-+
-+ (void)snprintf(devicePath, sizeof(devicePath),
-+ "/dev/tty%s", ttyname);
-+
-+ if (strDevicePath) {
-+ char currStrDevicePath[512];
-+ int port = 0;
-+ int devaddr = 0;
-+ memset(currStrDevicePath, 0, sizeof(currStrDevicePath));
-+ memset(infos, 0, sizeof(infos));
-+ (void)snprintf(sysctlname, sizeof(sysctlname),
-+ "dev.umodem.%d.%%location", i);
-+ if (sysctlbyname(sysctlname, infos, &infos_size,
-+ NULL, 0) != 0)
-+ break;
-+
-+ pos = strstr(infos, "port=");
-+ if (pos == NULL)
-+ continue;
-+ sscanf(pos, "port=%d ", &port);
-+
-+ pos = strstr(infos, "devaddr=");
-+ if (pos == NULL)
-+ continue;
-+ sscanf(pos, "devaddr=%d ", &devaddr);
-+
-+ (void)snprintf(currStrDevicePath, sizeof(currStrDevicePath),
-+ "/dev/ugen%d.%d", port, devaddr);
-+
-+ if (strcmp(currStrDevicePath, strDevicePath) != 0)
-+ continue;
- }
-+ snprintf(deviceList[iFound].strComPath, sizeof(deviceList[iFound].strComPath), "%s", devicePath);
-+ snprintf(deviceList[iFound].strComName, sizeof(deviceList[iFound].strComName), "%s", devicePath);
-+ deviceList[iFound].iVendorId = iVendor;
-+ deviceList[iFound].iProductId = iProduct;
-+ deviceList[iFound].adapterType = ADAPTERTYPE_P8_EXTERNAL; // will be overridden when not doing a "quick scan" by the actual type
-+ iFound++;
- }
- #else
- //silence "unused" warnings
diff --git a/multimedia/libcec/pkg-plist b/multimedia/libcec/pkg-plist
index e42150a375c9..92e911e01016 100644
--- a/multimedia/libcec/pkg-plist
+++ b/multimedia/libcec/pkg-plist
@@ -1,11 +1,11 @@
-lib/libcec.so
-lib/libcec.so.2
-lib/libcec.la
-lib/libcec.a
+bin/cec-client
include/libcec/cec.h
include/libcec/cecc.h
-include/libcec/cectypes.h
include/libcec/cecloader.h
-bin/cec-client
+include/libcec/cectypes.h
+lib/libcec.a
+lib/libcec.so
+lib/libcec.so.2
+lib/libcec.so.2.0.1
libdata/pkgconfig/libcec.pc
@dirrm include/libcec