aboutsummaryrefslogtreecommitdiff
path: root/multimedia/libdivxdecore-devel
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-02-11 16:32:06 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-02-11 16:32:06 +0000
commitf376686b25c9aab5eccd66898e56a74f911999ae (patch)
tree85f107e53a0ca000d3e4b8eef9d4879c2834ec2a /multimedia/libdivxdecore-devel
parent433aaf6e07a9e46993455990a0127c937e01f1de (diff)
downloadports-f376686b25c9aab5eccd66898e56a74f911999ae.tar.gz
ports-f376686b25c9aab5eccd66898e56a74f911999ae.zip
Notes
Diffstat (limited to 'multimedia/libdivxdecore-devel')
-rw-r--r--multimedia/libdivxdecore-devel/Makefile40
-rw-r--r--multimedia/libdivxdecore-devel/files/Makefile24
-rw-r--r--multimedia/libdivxdecore-devel/files/patch-src::Makefile.am23
-rw-r--r--multimedia/libdivxdecore-devel/files/patch-src::Makefile.in58
-rw-r--r--multimedia/libdivxdecore-devel/pkg-descr14
-rw-r--r--multimedia/libdivxdecore-devel/pkg-plist6
6 files changed, 56 insertions, 109 deletions
diff --git a/multimedia/libdivxdecore-devel/Makefile b/multimedia/libdivxdecore-devel/Makefile
index 67ef835057a8..c9bd6eb5fa7e 100644
--- a/multimedia/libdivxdecore-devel/Makefile
+++ b/multimedia/libdivxdecore-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libdivxdecore
PORTVERSION= 0.4.0.50
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://download.projectmayo.com/dnload/divxcore/
PKGNAMESUFFIX= -devel
@@ -14,42 +15,25 @@ DISTNAME= decore${PORTVERSION:E}src
MAINTAINER= lioux@FreeBSD.org
-BUILD_DEPENDS= ${NONEXISTENT}:${LIBDIVXDECORE_PORT}:patch
-
-WRKSRC= ${WRKDIR}/${LIBDIVXDECORE_PORT_WRKSRC:C/.+\///}
-
USE_ZIP= yes
EXTRACT_BEFORE_ARGS= -q -a -L
-GNU_CONFIGURE= yes
-USE_GMAKE= yes
-USE_LIBTOOL= yes
-INSTALLS_SHLIB= yes
+MAKE_ARGS= LIB_VERSION="${LIB_VERSION}" PREFIX=${PREFIX}
PLIST_SUB= LIB_VERSION="${LIB_VERSION}"
+INSTALLS_SHLIB= yes
+
+PATCH_WRKSRC= ${WRKDIR}/decore
+WRKSRC= ${WRKDIR}/decore/src
LIB_VERSION= 1
post-extract:
- @${CP} -Rp ${LIBDIVXDECORE_PORT_WRKSRC} ${WRKDIR}
- @${MV} ${WRKSRC}/src ${WRKSRC}/src.old
- @${MV} ${WRKDIR}/decore/src ${WRKSRC}/src
- @${CP} ${WRKSRC}/src.old/Makefile.* ${WRKSRC}/src
.for ext in c h
- @${MV} ${WRKSRC}/src/transferidct.${ext} \
- ${WRKSRC}/src/transferIDCT.${ext}
+ @${MV} ${WRKSRC}/transferidct.${ext} \
+ ${WRKSRC}/transferIDCT.${ext}
.endfor
+ @${CP} ${FILESDIR}/Makefile ${WRKSRC}
-post-install:
- @${LN} -sf ${PORTNAME}.so ${PREFIX}/lib/${PORTNAME}.so.${LIB_VERSION}
-
-.include <bsd.port.pre.mk>
-
-#LIBDIVXDECORE_PORT= ${PORTSDIR}/graphics/libdivxdecore
-LIBDIVXDECORE_PORT= ${.CURDIR}/../libdivxdecore
-LIBDIVXDECORE_PORT_WRKSRC!= cd ${LIBDIVXDECORE_PORT} && ${MAKE} -V WRKSRC
-
-# We will inherit most of the comment files from the non-devel
-# version
-PLIST= ${LIBDIVXDECORE_PORT}/pkg-plist
-DESCR= ${LIBDIVXDECORE_PORT}/pkg-descr
+pre-install:
+ @${MKDIR} ${PREFIX}/include/divx
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/multimedia/libdivxdecore-devel/files/Makefile b/multimedia/libdivxdecore-devel/files/Makefile
new file mode 100644
index 000000000000..ad60db99cf1f
--- /dev/null
+++ b/multimedia/libdivxdecore-devel/files/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+LIB= divxdecore
+SHLIB_MAJOR= ${LIB_VERSION}
+SHLIB_MINOR= 0
+CFLAGS+=-I${.CURDIR} -DLINUX -DO_BINARY=0 -D_DECORE
+SRCS= basic_prediction.c clearblock.c debug.c decore.c \
+ getbits.c idct.c mp4_block.c mp4_decoder.c mp4_header.c \
+ mp4_iquant.c mp4_mblock.c mp4_picture.c mp4_predict.c \
+ mp4_recon.c mp4_tables.c mp4_vars.c mp4_vld.c \
+ postprocess.c store.c transferIDCT.c yuv2rgb.c
+INCS= decore.h
+
+# idea taken from port security/libparanoia
+# hacks around <bsd.lib.mk>, which ignores PREFIX
+.if defined(PREFIX)
+DESTDIR=${PREFIX}/
+.else
+DESTDIR=/usr/local/
+.endif
+INCDIR=include/divx/
+LIBDIR=lib/
+
+.include <bsd.lib.mk>
diff --git a/multimedia/libdivxdecore-devel/files/patch-src::Makefile.am b/multimedia/libdivxdecore-devel/files/patch-src::Makefile.am
deleted file mode 100644
index 5764f3c7c985..000000000000
--- a/multimedia/libdivxdecore-devel/files/patch-src::Makefile.am
+++ /dev/null
@@ -1,23 +0,0 @@
---- src/Makefile.am.orig Fri Mar 9 23:38:01 2001
-+++ src/Makefile.am Fri Mar 9 23:38:08 2001
-@@ -7,6 +7,8 @@
- basic_prediction.h \
- decore.c \
- decore.h \
-+debug.c \
-+debug.h \
- getbits.c \
- global.h \
- idct.c \
-@@ -28,8 +30,11 @@
- portab.h \
- postprocess.c \
- postprocess.h \
-+store.c \
-+store.h \
- transferIDCT.c \
- transferIDCT.h \
-+yuv2rgb.c \
- yuv2rgb.h
-
- libdivxdecoreincludedir = $(includedir)/divx
diff --git a/multimedia/libdivxdecore-devel/files/patch-src::Makefile.in b/multimedia/libdivxdecore-devel/files/patch-src::Makefile.in
deleted file mode 100644
index 07cccff863af..000000000000
--- a/multimedia/libdivxdecore-devel/files/patch-src::Makefile.in
+++ /dev/null
@@ -1,58 +0,0 @@
---- src/Makefile.in.orig Mon Sep 24 14:38:28 2001
-+++ src/Makefile.in Mon Sep 24 14:42:08 2001
-@@ -77,7 +77,7 @@
-
- libdivxdecore_la_LDFLAGS = -module -avoid-version
-
--libdivxdecore_la_SOURCES = basic_prediction.c basic_prediction.h decore.c decore.h getbits.c global.h idct.c idct.h mp4_block.c mp4_block.h mp4_decoder.c mp4_decoder.h mp4_header.c mp4_header.h mp4_mblock.c mp4_mblock.h mp4_picture.c mp4_predict.c mp4_predict.h mp4_recon.c mp4_vld.c mp4_vld.h portab.h postprocess.c postprocess.h transferIDCT.c transferIDCT.h yuv2rgb.h
-+libdivxdecore_la_SOURCES = basic_prediction.c basic_prediction.h decore.c decore.h debug.c debug.h getbits.c global.h idct.c idct.h mp4_block.c mp4_block.h mp4_decoder.c mp4_decoder.h mp4_header.c mp4_header.h mp4_mblock.c mp4_mblock.h mp4_picture.c mp4_predict.c mp4_predict.h mp4_recon.c mp4_vld.c mp4_vld.h portab.h postprocess.c postprocess.h store.c store.h transferIDCT.c transferIDCT.h yuv2rgb.c yuv2rgb.h
-
-
- libdivxdecoreincludedir = $(includedir)/divx
-@@ -97,10 +97,10 @@
- LDFLAGS = @LDFLAGS@
- LIBS = @LIBS@
- libdivxdecore_la_LIBADD =
--libdivxdecore_la_OBJECTS = basic_prediction.lo decore.lo getbits.lo \
-+libdivxdecore_la_OBJECTS = basic_prediction.lo decore.lo debug.lo getbits.lo \
- idct.lo mp4_block.lo mp4_decoder.lo mp4_header.lo mp4_mblock.lo \
- mp4_picture.lo mp4_predict.lo mp4_recon.lo mp4_vld.lo postprocess.lo \
--transferIDCT.lo
-+store.lo transferIDCT.lo yuv2rgb.lo
- CFLAGS = @CFLAGS@
- COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
- LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
-@@ -256,17 +256,18 @@
- done
- basic_prediction.lo basic_prediction.o : basic_prediction.c \
- basic_prediction.h
--decore.lo decore.o : decore.c mp4_decoder.h global.h mp4_header.h \
-+decore.lo decore.o : decore.c debug.h mp4_decoder.h global.h mp4_header.h \
- postprocess.h yuv2rgb.h decore.h
-+debug.lo debug.o : debug.c debug.h global.h mp4_decoder.h
- getbits.lo getbits.o : getbits.c mp4_decoder.h global.h mp4_header.h
- idct.lo idct.o : idct.c
--mp4_block.lo mp4_block.o : mp4_block.c mp4_decoder.h global.h \
-+mp4_block.lo mp4_block.o : debug.h mp4_block.c mp4_decoder.h global.h \
- mp4_header.h mp4_predict.h mp4_vld.h mp4_block.h
- mp4_decoder.lo mp4_decoder.o : mp4_decoder.c mp4_decoder.h global.h \
- mp4_header.h
--mp4_header.lo mp4_header.o : mp4_header.c mp4_decoder.h global.h \
-+mp4_header.lo mp4_header.o : debug.h mp4_header.c mp4_decoder.h global.h \
- mp4_header.h
--mp4_mblock.lo mp4_mblock.o : mp4_mblock.c mp4_decoder.h global.h \
-+mp4_mblock.lo mp4_mblock.o : debug.h mp4_mblock.c mp4_decoder.h global.h \
- mp4_header.h mp4_block.h mp4_mblock.h
- mp4_picture.lo mp4_picture.o : mp4_picture.c mp4_decoder.h global.h \
- mp4_header.h mp4_mblock.h transferIDCT.h postprocess.h \
-@@ -277,8 +278,10 @@
- mp4_header.h basic_prediction.h
- mp4_vld.lo mp4_vld.o : mp4_vld.c mp4_decoder.h global.h mp4_header.h \
- mp4_vld.h
-+store.lo store.o : debug.h mp4_decoder.h global.h store.h store.c
- postprocess.lo postprocess.o : postprocess.c postprocess.h
- transferIDCT.lo transferIDCT.o : transferIDCT.c
-+yuv2rgb.lo yuv2rgb.o : yuv2rgb.c yuv2rgb.h
-
- info-am:
- info: info-am
diff --git a/multimedia/libdivxdecore-devel/pkg-descr b/multimedia/libdivxdecore-devel/pkg-descr
new file mode 100644
index 000000000000..7bad87dd1836
--- /dev/null
+++ b/multimedia/libdivxdecore-devel/pkg-descr
@@ -0,0 +1,14 @@
+Decore [excerpt from OpenDivX Project Mayo site]
+
+"Decore" is our decoder core - that part of the codec that decodes
+video from DivX video bitstream into uncompressed RGB bitmaps. Its
+API is defined in decore.h. The API is another frame-in, frame-out
+scheme, you give it a chunk of OpenDivX bitstream and it comes back
+to you with an uncompressed RGB frame. Like "encore", "decore" is
+truly independent of any other code, making no system calls.
+
+"Decore" is a decoder compliant with MPEG-4 natural video, simple
+profile. It also incorporates a video postprocessor which postprocessor,
+which hides many of the artifacts inherent in low bit-rate video.
+
+WWW: http://www.projectmayo.com/
diff --git a/multimedia/libdivxdecore-devel/pkg-plist b/multimedia/libdivxdecore-devel/pkg-plist
new file mode 100644
index 000000000000..734e4630e1cf
--- /dev/null
+++ b/multimedia/libdivxdecore-devel/pkg-plist
@@ -0,0 +1,6 @@
+include/divx/decore.h
+lib/libdivxdecore.a
+lib/libdivxdecore.so
+lib/libdivxdecore.so.%%LIB_VERSION%%
+lib/libdivxdecore_p.a
+@unexec rmdir %D/include/divx 2>/dev/null || true