aboutsummaryrefslogtreecommitdiff
path: root/multimedia/libdvdnav/files
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-02-19 18:19:44 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-02-19 18:19:44 +0000
commit110caf97e1c68644ab9717fefe8cd71494c17e93 (patch)
tree35eb0b425f731193b4da5d224fd86243ea348705 /multimedia/libdvdnav/files
parent12f6ac1067f54f116b21331ececb769f349762f7 (diff)
Notes
Diffstat (limited to 'multimedia/libdvdnav/files')
-rw-r--r--multimedia/libdvdnav/files/patch-example:Makefile.in22
-rw-r--r--multimedia/libdvdnav/files/patch-ltmain.sh12
-rw-r--r--multimedia/libdvdnav/files/patch-src:vm.c13
3 files changed, 30 insertions, 17 deletions
diff --git a/multimedia/libdvdnav/files/patch-example:Makefile.in b/multimedia/libdvdnav/files/patch-example:Makefile.in
index ca251d2042e6..b06d67ee61fe 100644
--- a/multimedia/libdvdnav/files/patch-example:Makefile.in
+++ b/multimedia/libdvdnav/files/patch-example:Makefile.in
@@ -1,11 +1,11 @@
---- examples/Makefile.in.orig Tue May 21 01:52:35 2002
-+++ examples/Makefile.in Tue May 21 01:52:51 2002
-@@ -116,7 +116,7 @@
- LIBS = @LIBS@
- menus_OBJECTS = menus.$(OBJEXT)
- menus_DEPENDENCIES = $(top_builddir)/src/libdvdnav.la
--menus_LDFLAGS =
-+menus_LDFLAGS = $(THREAD_LIBS)
- COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
- LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
- CCLD = $(CC)
+--- examples/Makefile.in.orig Tue May 20 23:20:12 2003
++++ examples/Makefile.in Thu Feb 12 20:44:41 2004
+@@ -151,7 +151,7 @@
+ noinst_PROGRAMS = menus
+
+ menus_SOURCES = menus.c
+-menus_LDFLAGS = -L$(top_srcdir)/src/
++menus_LDFLAGS = -L$(top_srcdir)/src/ $(THREAD_LIBS)
+ menus_LDADD = $(DVDNAV_LIB)
+ subdir = examples
+ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
diff --git a/multimedia/libdvdnav/files/patch-ltmain.sh b/multimedia/libdvdnav/files/patch-ltmain.sh
index 5608bb37c45f..a74679936e80 100644
--- a/multimedia/libdvdnav/files/patch-ltmain.sh
+++ b/multimedia/libdvdnav/files/patch-ltmain.sh
@@ -1,6 +1,6 @@
---- ltmain.sh.orig Mon Aug 5 16:46:18 2002
-+++ ltmain.sh Mon Aug 5 22:32:19 2002
-@@ -961,6 +961,7 @@
+--- ltmain.sh.orig Tue May 20 23:20:02 2003
++++ ltmain.sh Thu Feb 12 20:46:44 2004
+@@ -973,6 +973,7 @@
;;
-avoid-version)
@@ -8,16 +8,16 @@
avoid_version=yes
continue
;;
-@@ -2507,7 +2508,7 @@
+@@ -2501,7 +2502,7 @@
*)
# Add libc to deplibs on all other systems if necessary.
- if test "$build_libtool_need_lc" = "yes"; then
+ if test $build_libtool_need_lc = "yes"; then
- deplibs="$deplibs -lc"
+ deplibs="$deplibs"
fi
;;
esac
-@@ -4329,10 +4330,12 @@
+@@ -4325,10 +4326,12 @@
fi
# Install the pseudo-library for information purposes.
diff --git a/multimedia/libdvdnav/files/patch-src:vm.c b/multimedia/libdvdnav/files/patch-src:vm.c
new file mode 100644
index 000000000000..4c0c89a916bb
--- /dev/null
+++ b/multimedia/libdvdnav/files/patch-src:vm.c
@@ -0,0 +1,13 @@
+--- src/vm.c.orig Fri Feb 20 00:49:57 2004
++++ src/vm.c Fri Feb 20 00:54:31 2004
+@@ -47,6 +47,10 @@
+ #define lseek64 lseek
+ #endif /* _MSC_VER */
+
++#ifdef __FreeBSD__
++#define lseek64 lseek
++#endif
++
+ /*
+ #define STRICT
+ */