aboutsummaryrefslogtreecommitdiff
path: root/multimedia/libdvdnav/files
diff options
context:
space:
mode:
authorMANTANI Nobutaka <nobutaka@FreeBSD.org>2002-08-05 16:45:03 +0000
committerMANTANI Nobutaka <nobutaka@FreeBSD.org>2002-08-05 16:45:03 +0000
commit7e12c5c287864189c6b87a2de0600440c8fc141e (patch)
tree35fb20ad9fba0eb4f01b9b4c041e225b2d104954 /multimedia/libdvdnav/files
parent9413304a9cde99f2b313fbd4c243c47aa7929a05 (diff)
Update to 0.1.3.
Notes
Notes: svn path=/head/; revision=64051
Diffstat (limited to 'multimedia/libdvdnav/files')
-rw-r--r--multimedia/libdvdnav/files/patch-ltmain.sh36
-rw-r--r--multimedia/libdvdnav/files/patch-src:Makefile.in11
-rw-r--r--multimedia/libdvdnav/files/patch-src:read_cache.c11
3 files changed, 6 insertions, 52 deletions
diff --git a/multimedia/libdvdnav/files/patch-ltmain.sh b/multimedia/libdvdnav/files/patch-ltmain.sh
index 062d77ae1c56..5608bb37c45f 100644
--- a/multimedia/libdvdnav/files/patch-ltmain.sh
+++ b/multimedia/libdvdnav/files/patch-ltmain.sh
@@ -1,6 +1,6 @@
---- ltmain.sh.orig Sat Jun 1 21:12:45 2002
-+++ ltmain.sh Tue Jun 11 22:25:52 2002
-@@ -967,6 +967,7 @@
+--- ltmain.sh.orig Mon Aug 5 16:46:18 2002
++++ ltmain.sh Mon Aug 5 22:32:19 2002
+@@ -961,6 +961,7 @@
;;
-avoid-version)
@@ -8,40 +8,16 @@
avoid_version=yes
continue
;;
-@@ -1054,14 +1055,14 @@
- # These systems don't actually have a C library (as such)
- test "X$arg" = "X-lc" && continue
- ;;
-- *-*-openbsd* | *-*-freebsd*)
-+ *-*-openbsd*)
- # Do not include libc due to us having libc/libc_r.
- test "X$arg" = "X-lc" && continue
- ;;
- esac
- elif test "X$arg" = "X-lc_r"; then
- case $host in
-- *-*-openbsd* | *-*-freebsd*)
-+ *-*-openbsd*)
- # Do not include libc_r directly, use -pthread flag.
- continue
- ;;
-@@ -2468,13 +2469,13 @@
- *-*-netbsd*)
- # Don't link with libc until the a.out ld.so is fixed.
- ;;
-- *-*-openbsd* | *-*-freebsd*)
-+ *-*-openbsd*)
- # Do not include libc due to us having libc/libc_r.
- ;;
+@@ -2507,7 +2508,7 @@
*)
# Add libc to deplibs on all other systems if necessary.
- if test $build_libtool_need_lc = "yes"; then
+ if test "$build_libtool_need_lc" = "yes"; then
- deplibs="$deplibs -lc"
+ deplibs="$deplibs"
fi
;;
esac
-@@ -4273,10 +4274,12 @@
+@@ -4329,10 +4330,12 @@
fi
# Install the pseudo-library for information purposes.
diff --git a/multimedia/libdvdnav/files/patch-src:Makefile.in b/multimedia/libdvdnav/files/patch-src:Makefile.in
deleted file mode 100644
index 5023f7a20523..000000000000
--- a/multimedia/libdvdnav/files/patch-src:Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Makefile.in.orig Sat Jun 1 21:13:58 2002
-+++ src/Makefile.in Sun Jun 2 22:05:27 2002
-@@ -103,7 +103,7 @@
-
- libdvdnav_la_SOURCES = decoder.c dvdnav.c vm.c vmcmd.c read_cache.c navigation.c highlight.c searching.c settings.c
-
--libdvdnav_la_LDFLAGS = $(DVDREAD_LIBS) $(THREAD_LIBS) -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) -release $(LT_RELEASE)
-+libdvdnav_la_LDFLAGS = $(DVDREAD_LIBS) $(THREAD_LIBS) -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE)
-
-
- include_HEADERS = decoder.h dvdnav.h dvdnav_events.h dvdnav_internal.h vm.h vmcmd.h read_cache.h dvd_types.h
diff --git a/multimedia/libdvdnav/files/patch-src:read_cache.c b/multimedia/libdvdnav/files/patch-src:read_cache.c
deleted file mode 100644
index e08d63b9947c..000000000000
--- a/multimedia/libdvdnav/files/patch-src:read_cache.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/read_cache.c.bak Thu Jul 4 02:59:56 2002
-+++ src/read_cache.c Thu Jul 4 02:59:56 2002
-@@ -83,7 +83,7 @@
- #define _MT_TRACE 1
-
- #if _MT_TRACE
--#define dprintf(fmt, args...) fprintf(stderr, "%s: " fmt, __FUNCTION__, ##args);
-+#define dprintf(fmt, args...) fprintf(stderr, "%s: "fmt, __FUNCTION__ ,## args)
- #else
- #define dprintf(fmt, args...) /* Nowt */
- #endif