aboutsummaryrefslogtreecommitdiff
path: root/multimedia/libfame
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-10-19 14:19:13 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-10-19 14:19:13 +0000
commit39ecc1d97fcd23c0aba58fba087f268eedc97b81 (patch)
tree5f54a58cbd4815343486f92ac16042b5eb48cd2d /multimedia/libfame
parent44b51775296d64360cef663df4f8c80fff239feb (diff)
downloadports-39ecc1d97fcd23c0aba58fba087f268eedc97b81.tar.gz
ports-39ecc1d97fcd23c0aba58fba087f268eedc97b81.zip
Enable stage
Use options helpers Strip binaries
Notes
Notes: svn path=/head/; revision=330873
Diffstat (limited to 'multimedia/libfame')
-rw-r--r--multimedia/libfame/Makefile23
-rw-r--r--multimedia/libfame/pkg-plist10
2 files changed, 17 insertions, 16 deletions
diff --git a/multimedia/libfame/Makefile b/multimedia/libfame/Makefile
index 1cfb28067311..4620a2a421dd 100644
--- a/multimedia/libfame/Makefile
+++ b/multimedia/libfame/Makefile
@@ -8,31 +8,19 @@ CATEGORIES= multimedia
MASTER_SITES= SF/fame/${PORTNAME}/${PORTVERSION}
MAINTAINER= multimedia@FreeBSD.org
-COMMENT= A video encoding library
+COMMENT= Video encoding library
USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-MAN3= fame_close.3 fame_encode_frame.3 fame_get_object.3 fame_init.3 \
- fame_open.3 fame_register.3 fame_unregister.3 fame_encode_slice.3 \
- fame_start_frame.3 fame_end_frame.3
-
OPTIONS_DEFINE= SSE MMX
OPTIONS_DEFAULT= MMX
-SSE_DESC= "SSE optimized routines (no effect in this release)"
-
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+SSE_DESC= SSE optimized routines (no effect in this release)
-.if ${PORT_OPTIONS:MSSE}
-CONFIGURE_ARGS+= --enable-sse
-.endif
-
-.if empty(PORT_OPTIONS:MMMX)
-CONFIGURE_ARGS+= --disable-mmx
-.endif
+SSE_CONFIGURE_ON= --enable-sse
+MMX_CONFIGURE_ON= --enable-mmx
post-patch:
@${REINPLACE_CMD} -e 's|$${CONFIG_SHELL-/bin/sh} $$ac_aux_dir|$$ac_aux_dir|' \
@@ -41,4 +29,7 @@ post-patch:
-e 's|AC_DEFUN(AM_PATH_LIBFAME|AC_DEFUN([AM_PATH_LIBFAME]|g' \
${WRKSRC}/libfame.m4 ${WRKSRC}/libfame.m4.in
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libfame-0.9.so.1
+
.include <bsd.port.mk>
diff --git a/multimedia/libfame/pkg-plist b/multimedia/libfame/pkg-plist
index 116d7e7a8783..5b24b740724d 100644
--- a/multimedia/libfame/pkg-plist
+++ b/multimedia/libfame/pkg-plist
@@ -30,4 +30,14 @@ lib/libfame.la
lib/libfame.so
lib/libfame-0.9.so
lib/libfame-0.9.so.1
+man/man3/fame_close.3.gz
+man/man3/fame_encode_frame.3.gz
+man/man3/fame_encode_slice.3.gz
+man/man3/fame_end_frame.3.gz
+man/man3/fame_get_object.3.gz
+man/man3/fame_init.3.gz
+man/man3/fame_open.3.gz
+man/man3/fame_register.3.gz
+man/man3/fame_start_frame.3.gz
+man/man3/fame_unregister.3.gz
share/aclocal/libfame.m4