aboutsummaryrefslogtreecommitdiff
path: root/multimedia/libquicktime
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2010-04-18 16:30:39 +0000
committerMartin Matuska <mm@FreeBSD.org>2010-04-18 16:30:39 +0000
commitb9514e139a9e09d9768f6588c102b2fa67b2b774 (patch)
tree6c42db7e7d0841df6fcb8d2a8e34fd464e1ff920 /multimedia/libquicktime
parent1fbabdcea1a4db222d4842a6c784d0c713b304ef (diff)
downloadports-b9514e139a9e09d9768f6588c102b2fa67b2b774.tar.gz
ports-b9514e139a9e09d9768f6588c102b2fa67b2b774.zip
Notes
Diffstat (limited to 'multimedia/libquicktime')
-rw-r--r--multimedia/libquicktime/Makefile21
1 files changed, 19 insertions, 2 deletions
diff --git a/multimedia/libquicktime/Makefile b/multimedia/libquicktime/Makefile
index 695f4333a4bb..5d3da20441cf 100644
--- a/multimedia/libquicktime/Makefile
+++ b/multimedia/libquicktime/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libquicktime
PORTVERSION= 1.1.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= multimedia
MASTER_SITES= SF
@@ -42,6 +42,7 @@ OPTIONS= OPENGL "Enable OpenGL support" On \
FAAC "Enable FAAC support" Off \
FAAD "Enable FAAD support" On \
X264 "Enable X264 codec support" On \
+ X264_DEV "Require X264 from multimedia/x264-devel" Off \
SCHROEDINGER "Enable dirac support" On \
GTK2 "Enable Gtk+2 Frontend" Off \
OPTIMIZED_CFLAGS "Enable Optimized CFLAGS" Off
@@ -134,9 +135,25 @@ CONFIGURE_ARGS+= --without-faad2
.endif
.if !defined(WITHOUT_X264)
-LIB_DEPENDS+= x264.65:${PORTSDIR}/multimedia/x264
PLIST_SUB+= X264=""
CONFIGURE_ARGS+= --with-x264
+
+# Automatically choose the multimedia/x264-devel port if installed
+. if !defined(WITH_X264_DEV)
+. if exists(${LOCALBASE}/include/x264.h)
+X264_BUILD!= ${GREP} "define X264_BUILD .." ${LOCALBASE}/include/x264.h | ${AWK} '{ print $$3 }'
+. if ${X264_BUILD} == "85"
+_WANT_X264_DEVEL= yes
+. endif
+. endif
+. else
+_WANT_X264_DEVEL=yes
+. endif
+. if defined(_WANT_X264_DEVEL)
+LIB_DEPENDS+= x264.85:${PORTSDIR}/multimedia/x264/devel
+. else
+LIB_DEPENDS+= x264.65:${PORTSDIR}/multimedia/x264
+. endif
.else
PLIST_SUB+= X264="@comment "
CONFIGURE_ARGS+= --without-x264