aboutsummaryrefslogtreecommitdiff
path: root/multimedia/libquvi
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-10-01 20:06:56 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-10-01 20:06:56 +0000
commitd2e6bbd40e7de496bd916e603f0076880bb7ae7b (patch)
treeac84e876f35d3ac9fcc5dadd443be8c6ac732c73 /multimedia/libquvi
parente6cf0b21eb66688f5ae39ed57d90d8fc62e55310 (diff)
downloadports-d2e6bbd40e7de496bd916e603f0076880bb7ae7b.tar.gz
ports-d2e6bbd40e7de496bd916e603f0076880bb7ae7b.zip
Notes
Diffstat (limited to 'multimedia/libquvi')
-rw-r--r--multimedia/libquvi/Makefile16
1 files changed, 13 insertions, 3 deletions
diff --git a/multimedia/libquvi/Makefile b/multimedia/libquvi/Makefile
index 7f7c75228bea..9e4aaecb3b63 100644
--- a/multimedia/libquvi/Makefile
+++ b/multimedia/libquvi/Makefile
@@ -18,20 +18,30 @@ BUILD_DEPENDS= libquvi-scripts>=0.4.0:${PORTSDIR}/multimedia/libquvi-scripts
LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
RUN_DEPENDS:= ${BUILD_DEPENDS}
-OPTIONS_DEFINE= DOCS
+OPTIONS_DEFINE= DOCS LUAJIT
+LUAJIT_DESC= Use LuaJIT instead of Lua
PORTSCOUT= limit:0.4.[0-9]*
CPPFLAGS+= -I${LOCALBASE}/include
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-USES= iconv libtool lua pathfix pkgconfig tar:xz
+USES= iconv libtool pathfix pkgconfig tar:xz
USE_LDCONFIG= yes
PROJECTHOST= quvi
+LUAJIT_LIB_DEPENDS= libluajit-5.1.so:${PORTSDIR}/lang/luajit
+LUAJIT_USES_OFF= lua
+
+.include <bsd.port.options.mk>
+
post-patch:
- @${REINPLACE_CMD} 's/lua-5.1/lua-${LUA_VER}/g' ${WRKSRC}/configure
+.if ${PORT_OPTIONS:MLUAJIT}
+ @${REINPLACE_CMD} 's|lua >= 5.1|luajit|g' ${WRKSRC}/configure
+.else
+ @${REINPLACE_CMD} 's|lua-5.1|lua-${LUA_VER}|g' ${WRKSRC}/configure
+.endif
post-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}/