aboutsummaryrefslogtreecommitdiff
path: root/multimedia/libtheora/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2005-01-13 19:00:03 +0000
committerKoop Mast <kwm@FreeBSD.org>2005-01-13 19:00:03 +0000
commit294465d77e0208308cd8254537e37728e15cb727 (patch)
treef89d7fa36d5e74611845219957f3b3b371b49841 /multimedia/libtheora/Makefile
parentb04b3e88a57332de4d12440dd3748335c1bd94c5 (diff)
downloadports-294465d77e0208308cd8254537e37728e15cb727.tar.gz
ports-294465d77e0208308cd8254537e37728e15cb727.zip
Notes
Diffstat (limited to 'multimedia/libtheora/Makefile')
-rw-r--r--multimedia/libtheora/Makefile20
1 files changed, 6 insertions, 14 deletions
diff --git a/multimedia/libtheora/Makefile b/multimedia/libtheora/Makefile
index 4cbd3bb98a7c..f57a44c49327 100644
--- a/multimedia/libtheora/Makefile
+++ b/multimedia/libtheora/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= libtheora
-PORTVERSION= 1.0.a3
+PORTVERSION= 1.0.a4
CATEGORIES= graphics
-MASTER_SITES= http://www.theora.org/files/
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/.a3/alpha3/}
+MASTER_SITES= http://downloads.xiph.org/releases/theora/
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.a4/alpha4/}
MAINTAINER= kwm@FreeBSD.org
COMMENT= Theora video codec for the Ogg multimedia streaming system
@@ -19,7 +19,8 @@ LIB_DEPENDS= vorbis.3:${PORTSDIR}/audio/libvorbis
WRKSRC= ${WRKDIR}/${DISTNAME}
USE_REINPLACE= yes
-USE_LIBTOOL_VER=13
+USE_BZIP2= yes
+USE_LIBTOOL_VER=15
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include " \
@@ -36,15 +37,6 @@ post-patch:
${WRKSRC}/examples/player_example.c
@${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|g' \
${WRKSRC}/examples/Makefile.in
-
-do-install:
- for i in ${WRKSRC}/lib/.libs/libtheora.so.0 \
- ${WRKSRC}/lib/.libs/libtheora.so \
- ${WRKSRC}/lib/.libs/libtheora.a ; do \
- ${INSTALL_DATA} $$i ${PREFIX}/lib ; \
- done
- @${MKDIR} ${PREFIX}/include/theora
- @${INSTALL_DATA} ${WRKSRC}/include/theora/theora.h \
- ${PREFIX}/include/theora/
+ @${REINPLACE_CMD} -e 's|doc||g' ${WRKSRC}/Makefile.in
.include <bsd.port.mk>