aboutsummaryrefslogtreecommitdiff
path: root/multimedia/libtheora/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-02-25 08:45:59 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-02-25 08:45:59 +0000
commit5c2f313ce7b03e213ab0205baf41133d3a46a5ff (patch)
treef6803513f2d6b9ac08b1cc0266cf3fea3be740b7 /multimedia/libtheora/Makefile
parent77de5d67f67d5b09d42afb720f1f8c9f614bc99c (diff)
Notes
Diffstat (limited to 'multimedia/libtheora/Makefile')
-rw-r--r--multimedia/libtheora/Makefile51
1 files changed, 51 insertions, 0 deletions
diff --git a/multimedia/libtheora/Makefile b/multimedia/libtheora/Makefile
new file mode 100644
index 000000000000..5029ccdb7d7c
--- /dev/null
+++ b/multimedia/libtheora/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: theora
+# Date created: 09 februari 2003
+# Whom: Koop Mast <kwm@rainbow-runner.nl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libtheora
+PORTVERSION= 1.0.a2
+CATEGORIES= graphics
+MASTER_SITES= http://www.theora.org/files/ \
+ http://download.videolan.org/pub/videolan/vlc/0.7.0/contrib/
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.a2/alpha2/}
+
+MAINTAINER= kwm@rainbow-runner.nl
+COMMENT= Theora video codec for the Ogg multimedia streaming system
+
+LIB_DEPENDS= vorbis.3:${PORTSDIR}/audio/libvorbis
+
+WRKSRC= ${WRKDIR}/${DISTNAME}
+
+USE_REINPLACE= yes
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include " \
+ LDFLAGS="-L${LOCALBASE}/lib" \
+ LIBS="${PTHEAD_LIBS}"
+CONFIGURE_ARGS= --disable-sdltest \
+ --enable-shared
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|sdl-config|sdl11-config|g; \
+ s|-O2||g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|SDL/SDL.h|SDL11/SDL.h|g; \
+ s|machine/soundcard.h|sys/soundcard.h|g' \
+ ${WRKSRC}/examples/player_example.c
+ @${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/examples/Makefile.in
+
+do-install:
+ for i in ${WRKSRC}/lib/.libs/libtheora.so.0 \
+ ${WRKSRC}/lib/.libs/libtheora.so \
+ ${WRKSRC}/lib/.libs/libtheora.a ; do \
+ ${INSTALL_DATA} $$i ${PREFIX}/lib ; \
+ done
+ @${MKDIR} ${PREFIX}/include/theora
+ @${INSTALL_DATA} ${WRKSRC}/include/theora/theora.h \
+ ${PREFIX}/include/theora/
+
+.include <bsd.port.mk>