aboutsummaryrefslogtreecommitdiff
path: root/multimedia/libva-intel-driver
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2019-01-17 23:54:42 +0000
committerJan Beich <jbeich@FreeBSD.org>2019-01-17 23:54:42 +0000
commit09384ce004cba35e5d736a6f1d890f754dc488e7 (patch)
tree9db08bc764430fdea1c0eccfb1d7c0753f4a88c9 /multimedia/libva-intel-driver
parent7723e7d2bf16fabcc70a47b9f3e321fea788559a (diff)
multimedia/libva{,-intel-driver}: clean up
- Add BUILD_DEPENDS to intel driver for wl_drm_interface fix - Rewrite gettid() to make it easier to maintain - Update description from upstream - Drop unused v4l_compat dependency - Drop unused USES=alias as <alloca.h> is gone - Drop libGL dependency as intel driver uses libEGL via dlopen on Wayland - Drop --program-prefix after vainfo moved to libva-utils - Drop fmake workaround as USES=gmake is used - Drop -ldl workaround for FreeBSD < 11.2 - Drop RTLD_NODELETE workaround for FreeBSD < 8.0 - Drop GLX_GLXEXT_VERSION workaround for Mesa < 7.8.1 - Drop Created by as the port diverged a lot (even more with Meson) - Hint intel driver isn't actively developed (but still maintained) - Clarify libdrm dependency
Notes
Notes: svn path=/head/; revision=490611
Diffstat (limited to 'multimedia/libva-intel-driver')
-rw-r--r--multimedia/libva-intel-driver/Makefile15
1 files changed, 5 insertions, 10 deletions
diff --git a/multimedia/libva-intel-driver/Makefile b/multimedia/libva-intel-driver/Makefile
index 43a110bea958..a722418cb524 100644
--- a/multimedia/libva-intel-driver/Makefile
+++ b/multimedia/libva-intel-driver/Makefile
@@ -1,16 +1,15 @@
-# Created by: Manuel Creach <manuel.creach@me.com>
# $FreeBSD$
PORTNAME= libva-intel-driver
PORTVERSION= 2.3.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= multimedia
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
PATCHFILES+= f139dafa5917.patch:-p1 # for mesa-libs 18.3+
MAINTAINER= jbeich@FreeBSD.org
-COMMENT= VAAPI driver for Intel GMA 4500 (Gen4) or newer
+COMMENT= VAAPI legacy driver for Intel GMA 4500 (Gen4) or newer
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING
@@ -18,14 +17,12 @@ LICENSE_FILE= ${WRKSRC}/COPYING
ONLY_FOR_ARCHS= amd64 i386
ONLY_FOR_ARCHS_REASON= Only Intel GPUs on x86 are supported
+BUILD_DEPENDS= libva>=2.3.0_3:multimedia/libva
LIB_DEPENDS= libva.so:multimedia/libva \
- libdrm.so:graphics/libdrm
-BUILD_DEPENDS= ${LOCALBASE}/include/linux/videodev2.h:multimedia/v4l_compat
+ libdrm_intel.so:graphics/libdrm
GNU_CONFIGURE= yes
-USES= alias autoreconf compiler:c11 gmake libtool localbase \
- pkgconfig tar:bzip2
-USE_GL= gl
+USES= autoreconf compiler:c11 gmake libtool pkgconfig tar:bzip2
USE_GITHUB= yes
GH_ACCOUNT= intel
@@ -40,8 +37,6 @@ HYBRID_RUN_DEPENDS= ${LOCALBASE}/lib/dri/hybrid_drv_video.so:multimedia/libva-in
HYBRID_CONFIGURE_ENABLE= hybrid-codec
post-patch: .SILENT
- ${REINPLACE_CMD} -e 's/-ldl//' \
- ${WRKSRC}/src/Makefile.am
# XXX Remove va_api_version hack after 2.4.0 update
${REINPLACE_CMD} -e 's|driverdir|& --define-variable prefix=${PREFIX}|' \
-e '/va_api_version/s/1\.4\.0/1.1.0/' \