aboutsummaryrefslogtreecommitdiff
path: root/multimedia/libvpx
diff options
context:
space:
mode:
authorAshish SHUKLA <ashish@FreeBSD.org>2012-06-16 07:22:02 +0000
committerAshish SHUKLA <ashish@FreeBSD.org>2012-06-16 07:22:02 +0000
commitff17abd0531bd728f62e856e4084126f6ba06c5b (patch)
treea38a04a612aba8f6ef26ea290b3b0f12831397c4 /multimedia/libvpx
parent39bf500cc34ca3b086030023b2e9e69b0881bd36 (diff)
downloadports-ff17abd0531bd728f62e856e4084126f6ba06c5b.tar.gz
ports-ff17abd0531bd728f62e856e4084126f6ba06c5b.zip
Notes
Diffstat (limited to 'multimedia/libvpx')
-rw-r--r--multimedia/libvpx/Makefile8
-rw-r--r--multimedia/libvpx/distinfo4
-rw-r--r--multimedia/libvpx/files/patch-build_make_configure.sh14
-rw-r--r--multimedia/libvpx/files/patch-configure13
-rw-r--r--multimedia/libvpx/pkg-plist6
5 files changed, 30 insertions, 15 deletions
diff --git a/multimedia/libvpx/Makefile b/multimedia/libvpx/Makefile
index ed4dce50708b..66461adc9485 100644
--- a/multimedia/libvpx/Makefile
+++ b/multimedia/libvpx/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libvpx
-PORTVERSION= 1.0.0
+PORTVERSION= 1.1.0
CATEGORIES= multimedia
MASTER_SITES= GOOGLE_CODE
DISTNAME= ${PORTNAME}-v${PORTVERSION}
@@ -14,8 +14,8 @@ DISTNAME= ${PORTNAME}-v${PORTVERSION}
MAINTAINER= ashish@FreeBSD.org
COMMENT= VP8 Codec SDK
-BUILD_DEPENDS= ${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash \
- ${LOCALBASE}/bin/yasm:${PORTSDIR}/devel/yasm
+BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash \
+ yasm:${PORTSDIR}/devel/yasm
USE_BZIP2= yes
PROJECTHOST= webm
@@ -83,7 +83,7 @@ post-patch:
@${REINPLACE_CMD} 's|\(link_with_cc\)=gcc|\1=$${CC}|' \
${WRKSRC}/build/make/configure.sh
@${GREP} -Rl '^#!/bin/bash' ${WRKSRC} |${XARGS} ${REINPLACE_CMD} \
- -e 's,#!/bin/bash,#!${LOCALBASE}/bin/bash,g'
+ -e 's,#!/bin/bash,#!/usr/bin/env bash,g'
.if ${OSVERSION} < 700000
@${GREP} -Rl 'LIBVPX_SO.*extralibs' ${WRKSRC} |${XARGS} ${REINPLACE_CMD} \
-e 's/\(LIBVPX_SO.*extralibs[[:space:]]*+=[[:space:]]*\)/\1-lc /g'
diff --git a/multimedia/libvpx/distinfo b/multimedia/libvpx/distinfo
index a53c98df5c00..9463886ec355 100644
--- a/multimedia/libvpx/distinfo
+++ b/multimedia/libvpx/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libvpx-v1.0.0.tar.bz2) = 07cedb0a19a44e6d81d75f52eea864f59ef10c6c725cb860431bec6641eafe21
-SIZE (libvpx-v1.0.0.tar.bz2) = 1641411
+SHA256 (libvpx-v1.1.0.tar.bz2) = 9ce074cf4b3bcd9a49ff93e05485b71c273bfc3685a305e55a0e7fa51beb72c5
+SIZE (libvpx-v1.1.0.tar.bz2) = 1653485
diff --git a/multimedia/libvpx/files/patch-build_make_configure.sh b/multimedia/libvpx/files/patch-build_make_configure.sh
new file mode 100644
index 000000000000..809271a0f18f
--- /dev/null
+++ b/multimedia/libvpx/files/patch-build_make_configure.sh
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- build/make/configure.sh.orig
++++ build/make/configure.sh
+@@ -1135,7 +1135,7 @@
+ print_webm_license() {
+ local destination=$1
+ local prefix=$2
+- local suffix=$3
++ local suffix="$3"
+ shift 3
+ cat <<EOF > ${destination}
+ ${prefix} Copyright (c) 2011 The WebM project authors. All Rights Reserved.${suffix}
diff --git a/multimedia/libvpx/files/patch-configure b/multimedia/libvpx/files/patch-configure
index 819712460213..0a24807ac35e 100644
--- a/multimedia/libvpx/files/patch-configure
+++ b/multimedia/libvpx/files/patch-configure
@@ -1,10 +1,13 @@
+
+$FreeBSD$
+
--- configure.orig
+++ configure
-@@ -125,6 +125,7 @@
- all_platforms="${all_platforms} x86_64-win64-vs9"
- all_platforms="${all_platforms} universal-darwin8-gcc"
- all_platforms="${all_platforms} universal-darwin9-gcc"
+@@ -134,6 +134,7 @@
+ all_platforms="${all_platforms} universal-darwin10-gcc"
+ all_platforms="${all_platforms} universal-darwin11-gcc"
+ all_platforms="${all_platforms} universal-darwin12-gcc"
+all_platforms="${all_platforms} ia64-linux-gcc"
all_platforms="${all_platforms} generic-gnu"
-
+
# all_targets is a list of all targets that can be configured
diff --git a/multimedia/libvpx/pkg-plist b/multimedia/libvpx/pkg-plist
index a997ad6f5a95..44956cf0d7e9 100644
--- a/multimedia/libvpx/pkg-plist
+++ b/multimedia/libvpx/pkg-plist
@@ -4,12 +4,10 @@ bin/vp8_scalable_patterns
include/vpx/vp8.h
include/vpx/vp8cx.h
include/vpx/vp8dx.h
-include/vpx/vp8e.h
include/vpx/vpx_codec.h
include/vpx/vpx_codec_impl_bottom.h
include/vpx/vpx_codec_impl_top.h
include/vpx/vpx_decoder.h
-include/vpx/vpx_decoder_compat.h
include/vpx/vpx_encoder.h
include/vpx/vpx_image.h
include/vpx/vpx_integer.h
@@ -17,6 +15,6 @@ lib/libvpx.a
libdata/pkgconfig/vpx.pc
%%SHARED%%lib/libvpx.so
%%SHARED%%lib/libvpx.so.1
-%%SHARED%%lib/libvpx.so.1.0
-%%SHARED%%lib/libvpx.so.1.0.0
+%%SHARED%%lib/libvpx.so.1.1
+%%SHARED%%lib/libvpx.so.1.1.0
@dirrm include/vpx