aboutsummaryrefslogtreecommitdiff
path: root/multimedia/libxine
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2010-06-19 11:06:36 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2010-06-19 11:06:36 +0000
commit1a03c3ac67fe2325858de3e630795a1a9e0b8368 (patch)
tree3d8c137366c198d21a75e1129e41030c1cce8023 /multimedia/libxine
parent915abc4271b9c66d147119c62d4110f1771ad193 (diff)
downloadports-1a03c3ac67fe2325858de3e630795a1a9e0b8368.tar.gz
ports-1a03c3ac67fe2325858de3e630795a1a9e0b8368.zip
Notes
Diffstat (limited to 'multimedia/libxine')
-rw-r--r--multimedia/libxine/Makefile16
-rw-r--r--multimedia/libxine/distinfo6
-rw-r--r--multimedia/libxine/files/patch-configure85
-rw-r--r--multimedia/libxine/files/patch-src_audio_out_audio_oss_out.c46
-rw-r--r--multimedia/libxine/pkg-plist1
5 files changed, 43 insertions, 111 deletions
diff --git a/multimedia/libxine/Makefile b/multimedia/libxine/Makefile
index 172201b78369..b1166c480ebf 100644
--- a/multimedia/libxine/Makefile
+++ b/multimedia/libxine/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= xine
-PORTVERSION= 1.1.16.3
-PORTREVISION= 10
+PORTVERSION= 1.1.18.1
CATEGORIES= multimedia ipv6
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-lib%20%28${PORTNAME}%20core%29/${PORTVERSION}
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-lib/${PORTVERSION}
PKGNAMEPREFIX= lib
DISTNAME= ${PORTNAME}-lib-${PORTVERSION}
@@ -32,10 +31,10 @@ LIB_DEPENDS= FLAC.10:${PORTSDIR}/audio/flac \
dca.0:${PORTSDIR}/multimedia/libdca
.if !defined(PACKAGE_BUILDING)
-LIB_DEPENDS+= dvdcss.${DVDCSS_LIBVERSION}:${PORTSDIR}/multimedia/libdvdcss
+LIB_DEPENDS+= dvdcss.${DVDCSS_LIBVERSION}:${PORTSDIR}/multimedia/libdvdcss
.endif
-USE_BZIP2= yes
+USE_XZ= yes
USE_GETTEXT= yes
USE_ICONV= yes
GNU_CONFIGURE= yes
@@ -56,6 +55,7 @@ CONFIGURE_ENV= CFLAGS="${CFLAGS} -fno-force-addr -I${LOCALBASE}/include -I${LOCA
CONFIGURE_ARGS= --with-w32-path=${LOCALBASE}/lib/win32 --enable-ipv6 \
--with-external-libmad \
--with-external-libdts --with-libflac --disable-v4l
+MAKE_JOBS_SAFE= yes
OPTIONS= ARTS "Enable aRts support" off \
CACA "Enable libcaca support" off \
@@ -63,7 +63,7 @@ OPTIONS= ARTS "Enable aRts support" off \
JACK "Enable JACK support" off \
GNOMEVFS2 "Enable GnomeVFS2 support" off \
PULSEAUDIO "Enable PulseAudio support" off \
- FFMPEG "Enable external FFMpeg" off \
+ FFMPEG "Enable external FFMpeg" on \
XVMC "Enable XvMC support" off \
SMB "Enable SMB protocol support" off \
AALIB "Enable aalib support" off \
@@ -76,11 +76,11 @@ MAN1= xine-config.1 xine-list-1.1.1
MAN5= xine.5
DOCSDIR= ${PREFIX}/share/doc/xine-lib
-PLIST_SUB= PLUGINSDIR="lib/xine/plugins/1.26"
+PLIST_SUB= PLUGINSDIR="lib/xine/plugins/1.28"
# DVDCSS version hardcoded in src/input/input_dvd.c misc/cdda_server.c
# and src/input/libdvdnav/dvd_input.c (dlopen'ed)
-DVDCSS_LIBVERSION= 3
+DVDCSS_LIBVERSION= 3
.include <bsd.port.pre.mk>
diff --git a/multimedia/libxine/distinfo b/multimedia/libxine/distinfo
index 383fb5de6c65..12b4c7144409 100644
--- a/multimedia/libxine/distinfo
+++ b/multimedia/libxine/distinfo
@@ -1,3 +1,3 @@
-MD5 (xine-lib-1.1.16.3.tar.bz2) = 4f508abf088cf427a731f85634c8260d
-SHA256 (xine-lib-1.1.16.3.tar.bz2) = d25a241efa55dc7d8f482336efa8bb7b9bb9d69b6df8a8a37f2660948fd67b52
-SIZE (xine-lib-1.1.16.3.tar.bz2) = 7468182
+MD5 (xine-lib-1.1.18.1.tar.xz) = 2888985933a955db22aafc91207a7b9f
+SHA256 (xine-lib-1.1.18.1.tar.xz) = fa280f1d0f8592042c178257a312cf837e75580134e02205099e649e38fa6d9b
+SIZE (xine-lib-1.1.18.1.tar.xz) = 5778900
diff --git a/multimedia/libxine/files/patch-configure b/multimedia/libxine/files/patch-configure
index 71497e0a336a..94213399cb60 100644
--- a/multimedia/libxine/files/patch-configure
+++ b/multimedia/libxine/files/patch-configure
@@ -1,85 +1,16 @@
---- configure.orig 2009-05-06 22:57:51.000000000 +0900
-+++ configure 2009-05-06 23:03:23.000000000 +0900
-@@ -10918,6 +10918,12 @@
- fi
- ;;
-
-+ freebsd* | kfreebsd*-gnu | dragonfly*)
-+ archive_cmds='$CC -shared -o $lib $libobjs $deplibs $compiler_flags'
-+ hardcode_direct=no
-+ hardcode_minus_L=yes
-+ ;;
-+
- netbsd* | netbsdelf*-gnu)
- if echo __ELF__ | $CC -E - | $GREP __ELF__ >/dev/null; then
- archive_cmds='$LD -Bshareable $libobjs $deplibs $linker_flags -o $lib'
-@@ -14450,7 +14456,7 @@
- if test -z "$haveit"; then
- LIBICONV="${LIBICONV}${LIBICONV:+ }-L$found_dir"
- fi
-- if test "$hardcode_minus_L" != no; then
-+ if test "$hardcode_minus_L" = no; then
- LIBICONV="${LIBICONV}${LIBICONV:+ }$found_so"
- else
- LIBICONV="${LIBICONV}${LIBICONV:+ }-l$name"
-@@ -19693,12 +19693,6 @@
+--- ./configure.orig 2010-03-06 22:36:24.000000000 +0300
++++ ./configure 2010-06-19 02:21:36.862142625 +0400
+@@ -17061,9 +17061,6 @@
done
- if test "$ac_cv_header_ffmpeg_avutil_h" = "yes" && test "$ac_cv_header_libavutil_avutil_h" = "yes"; then
-- { { $as_echo "$as_me:$LINENO: error: old & new ffmpeg headers found - you need to clean up!" >&5
--$as_echo "$as_me: error: old & new ffmpeg headers found - you need to clean up!" >&2;}
-- { (exit 1); exit 1; }; }
+- as_fn_error "old & new ffmpeg headers found - you need to clean up!" "$LINENO" 5
- fi
--
- { $as_echo "$as_me:$LINENO: result: using external ffmpeg" >&5
+
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: using external ffmpeg" >&5
$as_echo "using external ffmpeg" >&6; }
- else
-@@ -27953,12 +27959,12 @@
- pkg_cv_CACA_CFLAGS="$CACA_CFLAGS"
- else
- if test -n "$PKG_CONFIG" && \
-- { ($as_echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"caca >= 0.99beta14 cucul >= 0.99beta14 \"") >&5
-- ($PKG_CONFIG --exists --print-errors "caca >= 0.99beta14 cucul >= 0.99beta14 ") 2>&5
-+ { ($as_echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"caca >= 0.99beta13 cucul >= 0.99beta13 \"") >&5
-+ ($PKG_CONFIG --exists --print-errors "caca >= 0.99beta13 cucul >= 0.99beta13 ") 2>&5
- ac_status=$?
- $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); }; then
-- pkg_cv_CACA_CFLAGS=`$PKG_CONFIG --cflags "caca >= 0.99beta14 cucul >= 0.99beta14 " 2>/dev/null`
-+ pkg_cv_CACA_CFLAGS=`$PKG_CONFIG --cflags "caca >= 0.99beta13 cucul >= 0.99beta13 " 2>/dev/null`
- else
- pkg_failed=yes
- fi
-@@ -27971,12 +27977,12 @@
- pkg_cv_CACA_LIBS="$CACA_LIBS"
- else
- if test -n "$PKG_CONFIG" && \
-- { ($as_echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"caca >= 0.99beta14 cucul >= 0.99beta14 \"") >&5
-- ($PKG_CONFIG --exists --print-errors "caca >= 0.99beta14 cucul >= 0.99beta14 ") 2>&5
-+ { ($as_echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"caca >= 0.99beta13 cucul >= 0.99beta13 \"") >&5
-+ ($PKG_CONFIG --exists --print-errors "caca >= 0.99beta13 cucul >= 0.99beta13 ") 2>&5
- ac_status=$?
- $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); }; then
-- pkg_cv_CACA_LIBS=`$PKG_CONFIG --libs "caca >= 0.99beta14 cucul >= 0.99beta14 " 2>/dev/null`
-+ pkg_cv_CACA_LIBS=`$PKG_CONFIG --libs "caca >= 0.99beta13 cucul >= 0.99beta13 " 2>/dev/null`
- else
- pkg_failed=yes
- fi
-@@ -27995,9 +28001,9 @@
- _pkg_short_errors_supported=no
- fi
- if test $_pkg_short_errors_supported = yes; then
-- CACA_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "caca >= 0.99beta14 cucul >= 0.99beta14 "`
-+ CACA_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "caca >= 0.99beta13 cucul >= 0.99beta13 "`
- else
-- CACA_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "caca >= 0.99beta14 cucul >= 0.99beta14 "`
-+ CACA_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "caca >= 0.99beta13 cucul >= 0.99beta13 "`
- fi
- # Put the nasty error message in config.log where it belongs
- echo "$CACA_PKG_ERRORS" >&5
-@@ -30662,6 +30668,8 @@
+@@ -23234,6 +23231,8 @@
fi
CFLAGS="$ac_save_CFLAGS"
LIBS="$ac_save_LIBS"
@@ -88,7 +19,7 @@
fi
if test "x$no_libFLAC" = "x" ; then
-@@ -43882,7 +43890,7 @@
+@@ -29752,7 +29751,7 @@
xinelibdir='${libdir}/xine'
xinedatadir='${datadir}/xine'
diff --git a/multimedia/libxine/files/patch-src_audio_out_audio_oss_out.c b/multimedia/libxine/files/patch-src_audio_out_audio_oss_out.c
index 767308552286..fc01ffd9c73a 100644
--- a/multimedia/libxine/files/patch-src_audio_out_audio_oss_out.c
+++ b/multimedia/libxine/files/patch-src_audio_out_audio_oss_out.c
@@ -1,6 +1,6 @@
---- src/audio_out/audio_oss_out.c.orig Mon Apr 16 02:42:15 2007
-+++ src/audio_out/audio_oss_out.c Sun Jul 1 14:42:59 2007
-@@ -163,7 +163,7 @@
+--- ./src/audio_out/audio_oss_out.c.orig 2010-01-15 01:17:54.000000000 +0300
++++ ./src/audio_out/audio_oss_out.c 2010-06-19 01:49:48.446683938 +0400
+@@ -160,7 +160,7 @@
uint32_t bits, uint32_t rate, int mode) {
oss_driver_t *this = (oss_driver_t *) this_gen;
@@ -9,7 +9,7 @@
xprintf(this->xine, XINE_VERBOSITY_DEBUG,
"audio_oss_out: ao_open rate=%d, mode=%d, dev=%s\n", rate, mode, this->audio_dev);
-@@ -295,14 +295,14 @@
+@@ -292,14 +292,14 @@
if (bits==8) {
xprintf(this->xine, XINE_VERBOSITY_DEBUG, "audio_oss_out: SNDCTL_DSP_SETFMT failed for AFMT_U8.\n");
if (tmp != AFMT_U8)
@@ -26,16 +26,16 @@
else
xprintf(this->xine, XINE_VERBOSITY_DEBUG, "audio_oss_out: The AFMT_S16_NE ioctl failed.\n");
return 0;
-@@ -321,7 +321,7 @@
+@@ -318,7 +318,7 @@
tmp = AFMT_AC3;
if (ioctl(this->audio_fd, SNDCTL_DSP_SETFMT, &tmp) < 0 || tmp != AFMT_AC3) {
- xprintf(this->xine, XINE_VERBOSITY_DEBUG,
+ xprintf(this->xine, XINE_VERBOSITY_DEBUG,
- "audio_oss_out: AC3 SNDCTL_DSP_SETFMT failed. %d. Using alternative.\n",tmp);
+ "audio_oss_out: AC3 SNDCTL_DSP_SETFMT failed. %ld. Using alternative.\n",tmp);
tmp = AFMT_S16_LE;
ioctl(this->audio_fd, SNDCTL_DSP_SETFMT, &tmp);
}
-@@ -377,7 +377,7 @@
+@@ -374,7 +374,7 @@
count_info info;
oss_driver_t *this = (oss_driver_t *) this_gen;
@@ -44,7 +44,7 @@
int frames;
struct timeval tv;
-@@ -515,7 +515,7 @@
+@@ -514,7 +514,7 @@
static int ao_oss_get_property (ao_driver_t *this_gen, int property) {
oss_driver_t *this = (oss_driver_t *) this_gen;
@@ -53,16 +53,16 @@
switch(property) {
case AO_PROP_PCM_VOL:
-@@ -524,7 +524,7 @@
-
+@@ -523,7 +523,7 @@
+
if(this->mixer.fd != -1) {
IOCTL_REQUEST_TYPE cmd = 0;
- int v;
+ long v;
-
+
ioctl(this->mixer.fd, SOUND_MIXER_READ_DEVMASK, &audio_devs);
-
-@@ -554,7 +554,7 @@
+
+@@ -553,7 +553,7 @@
static int ao_oss_set_property (ao_driver_t *this_gen, int property, int value) {
oss_driver_t *this = (oss_driver_t *) this_gen;
@@ -71,25 +71,25 @@
switch(property) {
case AO_PROP_PCM_VOL:
-@@ -563,7 +563,7 @@
-
+@@ -562,7 +562,7 @@
+
if(this->mixer.fd != -1) {
IOCTL_REQUEST_TYPE cmd = 0;
- int v;
+ long v;
-
+
ioctl(this->mixer.fd, SOUND_MIXER_READ_DEVMASK, &audio_devs);
-
-@@ -592,7 +592,7 @@
-
+
+@@ -591,7 +591,7 @@
+
if(this->mixer.fd != -1) {
IOCTL_REQUEST_TYPE cmd = 0;
- int v = 0;
+ long v = 0;
-
+
ioctl(this->mixer.fd, SOUND_MIXER_READ_DEVMASK, &audio_devs);
-
-@@ -665,7 +665,7 @@
+
+@@ -664,7 +664,7 @@
static int probe_audio_devices(oss_driver_t *this) {
const char *base_names[2] = {"/dev/dsp", "/dev/sound/dsp"};
int base_num, i;
@@ -98,7 +98,7 @@
int best_rate;
char devname[30];
-@@ -704,9 +704,9 @@
+@@ -703,9 +703,9 @@
oss_class_t *class = (oss_class_t *) class_gen;
config_values_t *config = class->config;
oss_driver_t *this;
diff --git a/multimedia/libxine/pkg-plist b/multimedia/libxine/pkg-plist
index 66d86c0084b0..2d3ee92ec6e9 100644
--- a/multimedia/libxine/pkg-plist
+++ b/multimedia/libxine/pkg-plist
@@ -92,6 +92,7 @@ lib/libxine.so.1
%%PLUGINSDIR%%/xineplug_decode_spucc.so
%%PLUGINSDIR%%/xineplug_decode_spucmml.so
%%PLUGINSDIR%%/xineplug_decode_spudvb.so
+%%PLUGINSDIR%%/xineplug_decode_spuhdmv.so
%%PLUGINSDIR%%/xineplug_decode_sputext.so
%%PLUGINSDIR%%/xineplug_decode_theora.so
%%PLUGINSDIR%%/xineplug_decode_vorbis.so