aboutsummaryrefslogtreecommitdiff
path: root/multimedia/libxine
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2014-10-18 21:10:39 +0000
committerJuergen Lock <nox@FreeBSD.org>2014-10-18 21:10:39 +0000
commitddb6d1d6f79e99c8d06b31a564459acb9d7c53a6 (patch)
tree426e85a5763a8dc36a27558c47361e144d35e6d1 /multimedia/libxine
parent7919b8d58ebe06034536da6acec7c2c45dbb891a (diff)
Notes
Diffstat (limited to 'multimedia/libxine')
-rw-r--r--multimedia/libxine/Makefile10
-rw-r--r--multimedia/libxine/distinfo4
-rw-r--r--multimedia/libxine/files/patch-contrib-libdha-sysdep-pci_freebsd.c11
-rw-r--r--multimedia/libxine/files/patch-include-xine-post.h21
-rw-r--r--multimedia/libxine/files/patch-include-xine-xineutils.h11
-rw-r--r--multimedia/libxine/files/patch-src-combined-ffmpeg-Makefile.in.diff7
-rw-r--r--multimedia/libxine/files/patch-src-post-goom-mmx.h18
-rw-r--r--multimedia/libxine/files/patch-src-post-planar-eq2.c11
-rw-r--r--multimedia/libxine/pkg-plist14
9 files changed, 34 insertions, 73 deletions
diff --git a/multimedia/libxine/Makefile b/multimedia/libxine/Makefile
index 985f4f6bb262..fd5ff208271c 100644
--- a/multimedia/libxine/Makefile
+++ b/multimedia/libxine/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= xine
-PORTVERSION= 1.2.4
-PORTREVISION= 15
+PORTVERSION= 1.2.6
CATEGORIES= multimedia ipv6
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-lib/${PORTVERSION}
PKGNAMEPREFIX= lib
@@ -37,9 +36,10 @@ LIB_DEPENDS= libFLAC.so:${PORTSDIR}/audio/flac \
LIB_DEPENDS+= libdvdcss.so.2:${PORTSDIR}/multimedia/libdvdcss
.endif
-USES= compiler gmake iconv libtool:keepla pathfix perl5 pkgconfig tar:xz
+USES= compiler gmake iconv libtool:keepla pathfix perl5 pkgconfig \
+ execinfo tar:xz
GNU_CONFIGURE= yes
-USE_XORG= x11 xv xinerama
+USE_XORG= x11 xv xinerama xext sm ice
USE_GL= gl glu
USE_PERL5= build
USE_SDL= sdl
@@ -65,7 +65,7 @@ OPTIONS_DEFINE= CACA ESOUND JACK GNOMEVFS2 PULSEAUDIO XVMC SMB AALIB \
DOCSDIR= ${PREFIX}/share/doc/xine-lib
# Please sync with XINE_PLUGINSDIR in multimedia/xine
# and multimedia/vdr-plugin-xineliboutput
-PLUGINSDIR= lib/xine/plugins/2.3
+PLUGINSDIR= lib/xine/plugins/2.5
PLIST_SUB= PLUGINSDIR="${PLUGINSDIR}"
.include <bsd.port.options.mk>
diff --git a/multimedia/libxine/distinfo b/multimedia/libxine/distinfo
index 3968a7e84a5c..6070f7888e52 100644
--- a/multimedia/libxine/distinfo
+++ b/multimedia/libxine/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xine-lib-1.2.4.tar.xz) = 9c5b1b4ef7bd0591962c322a3afa709eeaa5bae664678548f1340e64f43abbdd
-SIZE (xine-lib-1.2.4.tar.xz) = 4954992
+SHA256 (xine-lib-1.2.6.tar.xz) = bd041d738817c7c0c6392a3c0e5bda5a664a47e035135b5a449364f8c9b6a005
+SIZE (xine-lib-1.2.6.tar.xz) = 5020964
diff --git a/multimedia/libxine/files/patch-contrib-libdha-sysdep-pci_freebsd.c b/multimedia/libxine/files/patch-contrib-libdha-sysdep-pci_freebsd.c
deleted file mode 100644
index 8ebf052e796d..000000000000
--- a/multimedia/libxine/files/patch-contrib-libdha-sysdep-pci_freebsd.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- contrib/libdha/sysdep/pci_freebsd.c.orig
-+++ contrib/libdha/sysdep/pci_freebsd.c
-@@ -8,7 +8,7 @@
- /* machine/console.h seems to be outdated by recent FreeBSD *
- * however pcvt_ioctl.h seems to exist for very long time */
- /* #include <machine/console.h>*/
--#include <machine/pcvt_ioctl.h>
-+#include <sys/kbio.h>
- #ifndef GCCUSESGAS
- #define GCCUSESGAS
- #endif
diff --git a/multimedia/libxine/files/patch-include-xine-post.h b/multimedia/libxine/files/patch-include-xine-post.h
deleted file mode 100644
index 19b1eb3ba49d..000000000000
--- a/multimedia/libxine/files/patch-include-xine-post.h
+++ /dev/null
@@ -1,21 +0,0 @@
---- include/xine/post.h.orig
-+++ include/xine/post.h
-@@ -23,6 +23,9 @@
- #ifndef XINE_POST_H
- #define XINE_POST_H
-
-+/* for offsetof() */
-+#include <stddef.h>
-+
- #include <xine.h>
- #include <xine/video_out.h>
- #include <xine/audio_out.h>
-@@ -397,7 +400,7 @@ static xine_post_api_parameter_t temp_p[
-
- #define PARAM_ITEM( param_type, var, enumv, min, max, readonly, descr ) \
- { param_type, #var, sizeof(temp_s.var), \
-- (char*)&temp_s.var-(char*)&temp_s, enumv, min, max, readonly, descr },
-+ offsetof(__typeof__(temp_s), var), enumv, min, max, readonly, descr },
-
- #define END_PARAM_DESCR( name ) \
- { POST_PARAM_TYPE_LAST, NULL, 0, 0, NULL, 0, 0, 1, NULL } \
diff --git a/multimedia/libxine/files/patch-include-xine-xineutils.h b/multimedia/libxine/files/patch-include-xine-xineutils.h
new file mode 100644
index 000000000000..6ab80c8574d5
--- /dev/null
+++ b/multimedia/libxine/files/patch-include-xine-xineutils.h
@@ -0,0 +1,11 @@
+--- include/xine/xineutils.h.orig
++++ include/xine/xineutils.h
+@@ -146,7 +146,7 @@ void *xine_xcalloc(size_t nmemb, size_t
+ * Free allocated memory and set pointer to NULL
+ * @param ptr Pointer to the pointer to the memory block which should be freed.
+ */
+-static inline void _x_freep(void *ptr) {
++static void _x_freep(void *ptr) {
+ void **p = (void **)ptr;
+ free (*p);
+ *p = NULL;
diff --git a/multimedia/libxine/files/patch-src-combined-ffmpeg-Makefile.in.diff b/multimedia/libxine/files/patch-src-combined-ffmpeg-Makefile.in.diff
index a76ddd43be1b..2a94e1640e89 100644
--- a/multimedia/libxine/files/patch-src-combined-ffmpeg-Makefile.in.diff
+++ b/multimedia/libxine/files/patch-src-combined-ffmpeg-Makefile.in.diff
@@ -1,13 +1,12 @@
--- src/combined/ffmpeg/Makefile.in.orig 2013-09-23 15:58:14.000000000 -0500
+++ src/combined/ffmpeg/Makefile.in 2013-09-25 03:25:33.000000000 -0500
-@@ -995,10 +995,7 @@
- avcodec_audio.list: AV_CODECS:=/CODEC_ID_PCM_S16LE/,/CODEC_ID_DVD_SUBTITLE/
+@@ -1037,9 +1037,7 @@ avcodec_audio.list: AV_CODECS:=/CODEC_ID
avcodec_video.list: AV_CODECS:=/CODEC_ID_MPEG1VIDEO/,/CODEC_ID_PCM_S16LE/
--# that weird shell call just yields full path of the avcodec.h file
+ # that weird shell call just yields full path of the avcodec.h file
-avcodec_audio.list avcodec_video.list: $(shell \
- echo '#include "$(srcdir)/ffmpeg_decoder.h"' | $(AV_CPP) -M - |\
-- sed -e 's/ \+/\n/g;' | sed -n -e '/avcodec\.h/p;')
+- sed -e '/avcodec\.h/! d; s%^.* \([^ ]*/avcodec\.h\) .*%\1%')
+avcodec_audio.list avcodec_video.list:
$(AM_V_GEN)echo '#include "$(srcdir)/ffmpeg_decoder.h"' | $(AV_CPP) - |\
sed -e $(AV_CODECS)'! d; s/^[ \t]*//; s/[=,].*//; /^$$/ d' >$@
diff --git a/multimedia/libxine/files/patch-src-post-goom-mmx.h b/multimedia/libxine/files/patch-src-post-goom-mmx.h
deleted file mode 100644
index 11c5bdc65b4c..000000000000
--- a/multimedia/libxine/files/patch-src-post-goom-mmx.h
+++ /dev/null
@@ -1,18 +0,0 @@
---- src/post/goom/mmx.h.orig
-+++ src/post/goom/mmx.h
-@@ -725,13 +725,13 @@ void zoom_filter_xmmx (int prevX, int pr
- { \
- printf("emms()\n"); \
- __asm__ __volatile__ ("emms" \
-- "st(1)","st(2)","st(3)","st(4)","st(5)","st(6)","st(7)"); \
-+ "st","st(1)","st(2)","st(3)","st(4)","st(5)","st(6)","st(7)"); \
- }
-
- #else
-
- #define emms() __asm__ __volatile__ ("emms"::: \
-- "st(1)","st(2)","st(3)","st(4)","st(5)","st(6)","st(7)")
-+ "st","st(1)","st(2)","st(3)","st(4)","st(5)","st(6)","st(7)")
-
- #endif
-
diff --git a/multimedia/libxine/files/patch-src-post-planar-eq2.c b/multimedia/libxine/files/patch-src-post-planar-eq2.c
new file mode 100644
index 000000000000..7a47eea90047
--- /dev/null
+++ b/multimedia/libxine/files/patch-src-post-planar-eq2.c
@@ -0,0 +1,11 @@
+--- src/post/planar/eq2.c.orig
++++ src/post/planar/eq2.c
+@@ -129,7 +129,7 @@ void affine_1d_MMX (eq2_param_t *par, un
+ "movq (%1), %%mm4 \n\t"
+ "pxor %%mm0, %%mm0 \n\t"
+ :
+- : "g" (brvec), "g" (contvec)
++ : "r" (brvec), "r" (contvec)
+ );
+
+ while (h-- > 0) {
diff --git a/multimedia/libxine/pkg-plist b/multimedia/libxine/pkg-plist
index fdf10f615a24..f44058b940bc 100644
--- a/multimedia/libxine/pkg-plist
+++ b/multimedia/libxine/pkg-plist
@@ -44,7 +44,7 @@ include/xine/xmlparser.h
lib/libxine.la
lib/libxine.so
lib/libxine.so.2
-lib/libxine.so.2.3.1
+lib/libxine.so.2.5.0
lib/libxine-interface.la
share/xine-lib/fonts/cetus-16.xinefont.gz
share/xine-lib/fonts/cetus-20.xinefont.gz
@@ -106,6 +106,7 @@ share/xine-lib/fonts/serif-64.xinefont.gz
%%PLUGINSDIR%%/xineplug_decode_gsm610.so
%%WITH_IMAGEMAGICK%%%%PLUGINSDIR%%/xineplug_decode_image.so
%%PLUGINSDIR%%/xineplug_decode_libjpeg.so
+%%PLUGINSDIR%%/xineplug_decode_libvpx.so
%%PLUGINSDIR%%/xineplug_decode_lpcm.so
%%PLUGINSDIR%%/xineplug_decode_mad.so
%%PLUGINSDIR%%/xineplug_decode_mpeg2.so
@@ -230,14 +231,3 @@ share/aclocal/xine.m4
%%NLS%%share/locale/pt_BR/LC_MESSAGES/libxine2.mo
%%NLS%%share/locale/sk/LC_MESSAGES/libxine2.mo
%%NLS%%share/locale/tr/LC_MESSAGES/libxine2.mo
-@dirrm include/xine
-@dirrm %%PLUGINSDIR%%/post
-@dirrmtry %%PLUGINSDIR%%
-@dirrmtry lib/xine/plugins
-@dirrmtry lib/xine
-@dirrm %%DOCSDIR%%/hackersguide
-@dirrm %%DOCSDIR%%
-%%NLS%%@dirrmtry share/locale/en_US/LC_MESSAGES
-%%NLS%%@dirrmtry share/locale/en_US
-@dirrm share/xine-lib/fonts
-@dirrm share/xine-lib