aboutsummaryrefslogtreecommitdiff
path: root/multimedia/lives/Makefile
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2013-06-19 17:00:05 +0000
committerPawel Pekala <pawel@FreeBSD.org>2013-06-19 17:00:05 +0000
commit74a2c68888e61a8f0019f7e19b30f2f2d26161c9 (patch)
tree094b794cd246ef80c87023c74dfd052be44bc180 /multimedia/lives/Makefile
parent4c71708ac71f1017f19d567398ad9497988dd808 (diff)
downloadports-74a2c68888e61a8f0019f7e19b30f2f2d26161c9.tar.gz
ports-74a2c68888e61a8f0019f7e19b30f2f2d26161c9.zip
Notes
Diffstat (limited to 'multimedia/lives/Makefile')
-rw-r--r--multimedia/lives/Makefile44
1 files changed, 18 insertions, 26 deletions
diff --git a/multimedia/lives/Makefile b/multimedia/lives/Makefile
index be6fae4d253d..529673536149 100644
--- a/multimedia/lives/Makefile
+++ b/multimedia/lives/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= lives
-PORTVERSION= 2.0.4
+PORTVERSION= 2.0.5
CATEGORIES= multimedia
MASTER_SITES= http://salsaman.home.xs4all.nl/lives/current/
DISTNAME= LiVES-${PORTVERSION}
@@ -68,32 +68,20 @@ DOC_FILES= AUTHORS BUGS ChangeLog FEATURES GETTING.STARTED README \
PORT_VERBS= lives LiVES _encoder.py midistart midistop smogrify sendOSC
-OPTIONS_DEFINE= DOXYGEN FREI0R
+OPTIONS_DEFINE= DOCS DOXYGEN FREI0R NLS
+OPTIONS_SUB= yes
-.include <bsd.port.options.mk>
+DOXYGEN_BUILD_DEPENDS= ${LOCALBASE}/bin/doxygen:${PORTSDIR}/devel/doxygen
+DOXYGEN_CONFIGURE_OFF= --disable-doxygen
+FREI0R_BUILD_DEPENDS= ${LOCALBASE}/include/frei0r.h:${PORTSDIR}/graphics/frei0r
+FREI0R_RUN_DEPENDS= ${LOCALBASE}/include/frei0r.h:${PORTSDIR}/graphics/frei0r
+NLS_USES= gettext
+NLS_CONFIGURE_OFF= --disable-nls
-.if ${PORT_OPTIONS:MDOCS} && ${PORT_OPTIONS:MDOXYGEN}
-BUILD_DEPENDS+= ${LOCALBASE}/bin/doxygen:${PORTSDIR}/devel/doxygen
-PORTDOCS= html
-.else
-CONFIGURE_ARGS+=--disable-doxygen
-.endif
+.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MFREI0R}
-BUILD_DEPENDS+= ${LOCALBASE}/include/frei0r.h:${PORTSDIR}/graphics/frei0r
-RUN_DEPENDS+= ${LOCALBASE}/include/frei0r.h:${PORTSDIR}/graphics/frei0r
-PLIST_SUB+= FREI0R=""
-.else
+.if ! ${PORT_OPTIONS:MFREI0R}
CONFIGURE_ENV+= ac_cv_header_frei0r_h=no
-PLIST_SUB+= FREI0R="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
.endif
post-patch:
@@ -121,9 +109,13 @@ post-patch:
post-install:
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
-.for file in ${DOC_FILES}
- ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
-.endfor
+ ${INSTALL_DATA} ${DOC_FILES:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+.if ${PORT_OPTIONS:MDOXYGEN}
+ @cd ${PREFIX} && \
+ ${FIND} ${DOCSDIR:S|${PREFIX}/||} ! -type d >> ${TMPPLIST} && \
+ ${FIND} ${DOCSDIR:S|${PREFIX}/||} -type d | ${SORT} -r | \
+ ${SED} 's|^|@dirrm |' >> ${TMPPLIST}
.endif
.include <bsd.port.mk>