aboutsummaryrefslogtreecommitdiff
path: root/multimedia/lsdvd/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-11-11 09:38:57 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-11-11 09:38:57 +0000
commit7bbc6f760206bed19ec49f6a29c2857cb714252b (patch)
tree6b343e9bb57ca27a81aab09147ae07e6ba79c398 /multimedia/lsdvd/Makefile
parentc3e0dedea40289d55b3e912eaa07b4ab2bb01504 (diff)
downloadports-7bbc6f760206bed19ec49f6a29c2857cb714252b.tar.gz
ports-7bbc6f760206bed19ec49f6a29c2857cb714252b.zip
Notes
Diffstat (limited to 'multimedia/lsdvd/Makefile')
-rw-r--r--multimedia/lsdvd/Makefile16
1 files changed, 4 insertions, 12 deletions
diff --git a/multimedia/lsdvd/Makefile b/multimedia/lsdvd/Makefile
index 2814af527523..72147b4e847a 100644
--- a/multimedia/lsdvd/Makefile
+++ b/multimedia/lsdvd/Makefile
@@ -6,17 +6,18 @@
#
PORTNAME= lsdvd
-PORTVERSION= 0.10
-PORTREVISION= 1
+PORTVERSION= 0.15
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= acidrip
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= pav@FreeBSD.org
COMMENT= Print information about the contents and structure of a DVD
LIB_DEPENDS= dvdread.3:${PORTSDIR}/multimedia/libdvdread
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
USE_REINPLACE= yes
PLIST_FILES= bin/lsdvd
@@ -38,13 +39,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|/dev/dvd|${WITH_DVD_DEVICE}|' \
${WRKSRC}/lsdvd.c
-do-build:
- cd ${WRKSRC} && \
- ${CC} ${CFLAGS} -DPACKAGE=\"${PORTNAME}\" -DVERSION=\"${PORTVERSION}\" \
- -DHAVE_LIBDVDREAD=1 -I. -I${LOCALBASE}/include -L${LOCALBASE}/lib \
- -ldvdread lsdvd.c -o lsdvd
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/lsdvd ${PREFIX}/bin
-
.include <bsd.port.post.mk>