aboutsummaryrefslogtreecommitdiff
path: root/multimedia/m2vrequantiser
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2011-09-16 18:34:01 +0000
committerJuergen Lock <nox@FreeBSD.org>2011-09-16 18:34:01 +0000
commit39e880b1edaaf64172efa526ec259f011e16c328 (patch)
tree19da69a5e88cabd5233eec54ef0cb538fad344ff /multimedia/m2vrequantiser
parent2620a877c953512744eae8481ab2d4fb79118a48 (diff)
downloadports-39e880b1edaaf64172efa526ec259f011e16c328.tar.gz
ports-39e880b1edaaf64172efa526ec259f011e16c328.zip
Notes
Diffstat (limited to 'multimedia/m2vrequantiser')
-rw-r--r--multimedia/m2vrequantiser/Makefile22
-rw-r--r--multimedia/m2vrequantiser/distinfo2
-rw-r--r--multimedia/m2vrequantiser/files/patch-main.c11
-rw-r--r--multimedia/m2vrequantiser/pkg-descr8
4 files changed, 43 insertions, 0 deletions
diff --git a/multimedia/m2vrequantiser/Makefile b/multimedia/m2vrequantiser/Makefile
new file mode 100644
index 000000000000..0eca3f079bb5
--- /dev/null
+++ b/multimedia/m2vrequantiser/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: m2vrequantiser
+# Date created: Thu Sep 14 20:47:38 CEST 2011
+# Whom: Juergen Lock <nox@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= m2vrequantiser
+PORTVERSION= 1.1
+CATEGORIES= multimedia
+MASTER_SITES= http://launchpadlibrarian.net/52366061/
+DISTNAME= M2VRequantiser-v${PORTVERSION}
+
+MAINTAINER= nox@FreeBSD.org
+COMMENT= Requantize MPEG-2 streams without recompressing
+
+PATCH_STRIP= -p1
+CFLAGS+= -Duint=unsigned
+MAKE_ARGS+= CC=${CC} CXX=${CXX}
+PLIST_FILES+= bin/M2VRequantiser
+
+.include <bsd.port.mk>
diff --git a/multimedia/m2vrequantiser/distinfo b/multimedia/m2vrequantiser/distinfo
new file mode 100644
index 000000000000..e43022ad5ed6
--- /dev/null
+++ b/multimedia/m2vrequantiser/distinfo
@@ -0,0 +1,2 @@
+SHA256 (M2VRequantiser-v1.1.tar.gz) = e537c7894edc4ae446d71e8f597aa1fcec85c3e76748ba0aaa289cc667c94209
+SIZE (M2VRequantiser-v1.1.tar.gz) = 34472
diff --git a/multimedia/m2vrequantiser/files/patch-main.c b/multimedia/m2vrequantiser/files/patch-main.c
new file mode 100644
index 000000000000..4285203b3b4d
--- /dev/null
+++ b/multimedia/m2vrequantiser/files/patch-main.c
@@ -0,0 +1,11 @@
+--- a/main.c
++++ b/main.c
+@@ -2315,7 +2315,7 @@ int main (int argc, const char * argv[])
+ if (argc < 5) { USAGE }
+ delta_bright = atoi(argv[4]);
+ #else
+- if (argc < 2) { USAGE }
++ if (argc < 3) { USAGE }
+ #endif
+ fact_x = atof(argv[1]);
+ sscanf(argv[2], "%lld", &orim2vsize);
diff --git a/multimedia/m2vrequantiser/pkg-descr b/multimedia/m2vrequantiser/pkg-descr
new file mode 100644
index 000000000000..2cfe6b35a10f
--- /dev/null
+++ b/multimedia/m2vrequantiser/pkg-descr
@@ -0,0 +1,8 @@
+Requantize MPEG-2 streams without recompressing. M2VRequantiser
+accepts raw MPEG2 video data (not VOB) from standard input and
+writes the recompressed frames to standard output.
+
+Usage is :
+ M2VRequantiser recompression_factor inputM2Vsize <input.m2v >output.m2v
+
+WWW: https://launchpad.net/m2vrequantiser