aboutsummaryrefslogtreecommitdiff
path: root/multimedia/miro
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-07-09 09:05:34 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-07-09 09:05:34 +0000
commit86e3a4f76e501dd593412682264942296920db8d (patch)
tree09daa5127ae4ea54cfed2fb92ffd52c0b2bdac34 /multimedia/miro
parent5f9159fbbb6d23ea97276efe8e573a988c02222e (diff)
downloadports-86e3a4f76e501dd593412682264942296920db8d.tar.gz
ports-86e3a4f76e501dd593412682264942296920db8d.zip
Notes
Diffstat (limited to 'multimedia/miro')
-rw-r--r--multimedia/miro/Makefile8
-rw-r--r--multimedia/miro/distinfo6
-rw-r--r--multimedia/miro/files/patch-platform_gtk-x11_setup.py52
-rw-r--r--multimedia/miro/files/patch-portable__util.py15
4 files changed, 50 insertions, 31 deletions
diff --git a/multimedia/miro/Makefile b/multimedia/miro/Makefile
index 46f1a27c8404..6d26cde9704f 100644
--- a/multimedia/miro/Makefile
+++ b/multimedia/miro/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Miro
-PORTVERSION= 2.0.4
+PORTVERSION= 2.0.5
CATEGORIES= multimedia
MASTER_SITES= ftp://ftp.osuosl.org/pub/pculture.org/miro/src/ \
http://ftp.osuosl.org/pub/pculture.org/miro/src/
@@ -21,6 +21,7 @@ LIB_DEPENDS= boost_python.4:${PORTSDIR}/devel/boost-python \
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_bsddb.so:${PORTSDIR}/databases/py-bsddb \
${PYTHON_SITELIBDIR}/pysqlite2/_sqlite.so:${PORTSDIR}/databases/py-pysqlite23 \
${PYTHON_SITELIBDIR}/dbus/glib.py:${PORTSDIR}/devel/py-dbus \
+ ${PYTHON_SITELIBDIR}/gtk-2.0/pynotify/_pynotify.so:${PORTSDIR}/devel/py-notify \
convert:${PORTSDIR}/graphics/ImageMagick
BUILD_WRKSRC= ${WRKSRC}/platform/gtk-x11
@@ -35,7 +36,7 @@ WANT_GSTREAMER= yes
USE_GETTEXT= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_PKGNAME= ${PORTNAME:L}
-MAKE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}"
+MAKE_ENV= CPPFLAGS="${CPPFLAGS}"
INSTALLS_EGGINFO= yes
MANCOMPRESSED= yes
@@ -43,6 +44,8 @@ MAN1= miro.1 miro.real.1
DATADIR= ${PREFIX}/share/${PORTNAME:L}
+CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/www/mozilla/bsd.gecko.mk"
@@ -51,6 +54,7 @@ USE_GSTREAMER+= python
.endif
.if defined(GECKO) && ${GECKO:Mlibxul}!=""
+CPPFLAGS+= -D_WCHAR_T_DECLARED
XPCOM_LIB= ${GECKO}
GTKMOZEMBED_LIB=${GECKO}
XULRUNNER_19= True
diff --git a/multimedia/miro/distinfo b/multimedia/miro/distinfo
index 0915cc9d9ac5..bee090fa9015 100644
--- a/multimedia/miro/distinfo
+++ b/multimedia/miro/distinfo
@@ -1,3 +1,3 @@
-MD5 (Miro-2.0.4.tar.gz) = e6cf48252496b2bddd290f375fc0ca33
-SHA256 (Miro-2.0.4.tar.gz) = 8369fdde6e5939923a97fe7704f4bd238fef9d07d0ea5cda7ffde34b45d765a0
-SIZE (Miro-2.0.4.tar.gz) = 7514648
+MD5 (Miro-2.0.5.tar.gz) = bb589058844b441c8f0bd0b79532ca87
+SHA256 (Miro-2.0.5.tar.gz) = 1857a6606e4a9c5d3e51a71de525df9f4e6c41fdce8d874fc8d9f67b8844c78d
+SIZE (Miro-2.0.5.tar.gz) = 7333786
diff --git a/multimedia/miro/files/patch-platform_gtk-x11_setup.py b/multimedia/miro/files/patch-platform_gtk-x11_setup.py
index 84b2b82f8e39..ce051668eab3 100644
--- a/multimedia/miro/files/patch-platform_gtk-x11_setup.py
+++ b/multimedia/miro/files/patch-platform_gtk-x11_setup.py
@@ -1,6 +1,6 @@
---- platform/gtk-x11/setup.py.orig 2009-03-31 05:04:54.000000000 +0900
-+++ platform/gtk-x11/setup.py 2009-04-14 06:30:46.000000000 +0900
-@@ -111,12 +111,13 @@
+--- platform/gtk-x11/setup.py.orig 2009-06-26 13:15:47.000000000 +0900
++++ platform/gtk-x11/setup.py 2009-07-05 22:35:44.000000000 +0900
+@@ -111,14 +111,15 @@
# XPCOM_LIB = "firefox-xpcom"
# GTKMOZEMBED_LIB = "firefox-gtkmozembed"
# XULRUNNER_19 = False
@@ -11,13 +11,16 @@
+GTKMOZEMBED_LIB = "%%GTKMOZEMBED_LIB%%"
+XULRUNNER_19 = %%XULRUNNER_19%%
- # The name of the boost library. Used for building extensions.
- BOOST_LIB = 'boost_python'
+ # The name of the boost python library. Used for building extensions.
+ # If this is set to None, setup.py will divine the right lib to use.
+ # It should probably be either "boost_python" or "boost_python-mt".
+-BOOST_LIB = None
++BOOST_LIB = 'boost_python'
+BOOST_LIB_PATH = '%%LOCALBASE%%/lib'
###############################################################################
-@@ -282,6 +283,9 @@
+@@ -284,6 +285,9 @@
options_dict['library_dirs'].append(rest)
elif prefix == '-l':
options_dict['libraries'].append(rest)
@@ -27,8 +30,8 @@
else:
options_dict['extra_compile_args'].append(comp)
-@@ -292,7 +296,7 @@
- return options_dict
+@@ -314,7 +318,7 @@
+ print "Using %s" % BOOST_LIB
def compile_xine_extractor():
- rv = os.system("gcc %s -o %s `pkg-config --libs --cflags gdk-pixbuf-2.0 glib-2.0 libxine`" %
@@ -36,7 +39,7 @@
(os.path.join(platform_dir, "xine/xine_extractor.c"), os.path.join(platform_dir, "xine/xine_extractor")))
if rv != 0:
raise RuntimeError("xine_extractor compilation failed. Possibly missing libxine, gdk-pixbuf-2.0, or glib-2.0.")
-@@ -330,7 +334,7 @@
+@@ -352,7 +356,7 @@
exit;
fi
@@ -45,7 +48,7 @@
else
%(runtimelib)smiro.real "$@"
fi
-@@ -343,6 +347,7 @@
+@@ -365,6 +369,7 @@
Extension("miro.fasttypes",
sources = [os.path.join(portable_dir, 'fasttypes.cpp')],
libraries = [BOOST_LIB],
@@ -53,25 +56,22 @@
)
-@@ -378,14 +383,14 @@
- "-DHAVE___INCLUDE_LIBTORRENT_ASIO_HPP=1",
+@@ -401,12 +406,12 @@
"-DHAVE___INCLUDE_LIBTORRENT_ASIO_SSL_STREAM_HPP=1",
"-DHAVE___INCLUDE_LIBTORRENT_ASIO_IP_TCP_HPP=1",
-- "-DHAVE_PTHREAD=1", "-DTORRENT_USE_OPENSSL=1", "-DHAVE_SSL=1",
+ "-DHAVE_PTHREAD=1", "-DTORRENT_USE_OPENSSL=1", "-DHAVE_SSL=1",
- "-DNDEBUG=1", "-O2"]
-+ "-DHAVE_PTHREAD=1", "-DTORRENT_USE_OPENSSL=1",
-+ "-DHAVE_SSL=1"]
++ "-DNDEBUG=1"]
if is_x64():
extra_compile_args.append("-DAMD64")
- # check for mt
- libraries = ['z', 'pthread', 'ssl']
+ libraries = ['z', 'ssl']
- all_libs = []
- if os.path.exists(os.path.join(sysconfig.PREFIX, "lib")):
- all_libs.extend(os.listdir(os.path.join(sysconfig.PREFIX, "lib")))
-@@ -427,6 +432,7 @@
+
+ # get mt or non-mt versions of the boost libraries
+ libraries += [mt_or_not("boost_python"),
+@@ -431,6 +436,7 @@
return Extension("miro.libtorrent",
include_dirs=include_dirs,
libraries=libraries,
@@ -79,7 +79,7 @@
extra_compile_args=extra_compile_args,
sources=sources)
-@@ -549,7 +555,7 @@
+@@ -557,7 +563,7 @@
xlib_ext = \
Extension("miro.plat.xlibhelper",
[ os.path.join(platform_package_dir,'xlibhelper.pyx') ],
@@ -88,7 +88,7 @@
libraries = ['X11'],
)
-@@ -635,31 +641,31 @@
+@@ -643,31 +649,31 @@
# filter out app.config.template (which is handled specially)
files = [f for f in listfiles(resource_dir) \
if os.path.basename(f) != 'app.config.template']
@@ -129,7 +129,7 @@
[os.path.join(platform_dir, 'xine/xine_extractor')]),
]
-@@ -683,7 +689,7 @@
+@@ -691,7 +697,7 @@
def install_app_config(self):
source = os.path.join(resource_dir, 'app.config.template')
@@ -138,7 +138,7 @@
config_file = util.read_simple_config_file(source)
print "Trying to figure out the svn revision...."
-@@ -723,7 +729,7 @@
+@@ -731,7 +737,7 @@
for source in glob (os.path.join (locale_dir, "*.mo")):
lang = os.path.basename(source)[:-3]
@@ -147,7 +147,7 @@
if self.root:
dest = change_root(self.root, dest)
self.mkpath(os.path.dirname(dest))
-@@ -752,7 +758,7 @@
+@@ -760,7 +766,7 @@
#### install_theme installs a specified theme .zip
class install_theme(Command):
@@ -156,7 +156,7 @@
user_options = [("theme=", None, 'ZIP file containing the theme')]
def initialize_options(self):
-@@ -780,7 +786,7 @@
+@@ -788,7 +794,7 @@
raise DistutilsOptionError, "invalid theme file"
self.zipfile = zf
self.theme_name = themeName
diff --git a/multimedia/miro/files/patch-portable__util.py b/multimedia/miro/files/patch-portable__util.py
new file mode 100644
index 000000000000..5dfe713c5436
--- /dev/null
+++ b/multimedia/miro/files/patch-portable__util.py
@@ -0,0 +1,15 @@
+--- portable/util.py.orig 2009-06-26 13:15:52.000000000 +0900
++++ portable/util.py 2009-07-06 02:26:25.000000000 +0900
+@@ -752,7 +752,11 @@
+ self.__add(data)
+
+ def handle_charref(self, ref):
+- self.__add(unichr(int(ref)))
++ if ref.startswith('x'):
++ charnum = int(ref[1:], 16)
++ else:
++ charnum = int(ref)
++ self.__add(unichr(charnum))
+
+ def start_p(self, attributes):
+ self.__add("\n")