aboutsummaryrefslogtreecommitdiff
path: root/multimedia/mkclean/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2018-09-15 09:38:22 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2018-09-15 09:38:22 +0000
commit7492b17025f2327459f9796ca5a179e25add5072 (patch)
treec06012ef58812790486f7a5891234d335b71d964 /multimedia/mkclean/Makefile
parent42612a4c04aa81ce8671ff5666651c3ad275b638 (diff)
downloadports-7492b17025f2327459f9796ca5a179e25add5072.tar.gz
ports-7492b17025f2327459f9796ca5a179e25add5072.zip
Notes
Diffstat (limited to 'multimedia/mkclean/Makefile')
-rw-r--r--multimedia/mkclean/Makefile19
1 files changed, 9 insertions, 10 deletions
diff --git a/multimedia/mkclean/Makefile b/multimedia/mkclean/Makefile
index 8120808aa52f..d75940d73884 100644
--- a/multimedia/mkclean/Makefile
+++ b/multimedia/mkclean/Makefile
@@ -11,26 +11,25 @@ COMMENT= Clean and optimize Matroska and WebM files
LICENSE= BSD3CLAUSE
+BROKEN_aarch64= Does not install: arm-none-linux-gnueabi-gcc: Command not found
+BROKEN_armv6= Does not install: arm-none-linux-gnueabi-gcc: Command not found
+BROKEN_armv7= Does not install: arm-none-linux-gnueabi-gcc: Command not found
+BROKEN_mips64= Does not install: mipsel-linux-gcc: Command not found
+BROKEN_sparc64= Does not install: gmake: GNUmakefile: No such file or directory
+
HAS_CONFIGURE= yes
-USES= iconv gmake tar:bzip2
+USES= iconv localbase:ldflags gmake tar:bzip2
-CFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
+LDFLAGS+= ${ICONV_LIB}
-MAKE_ENV+= "LFLAGS=${LDFLAGS}"
+MAKE_ENV= "LFLAGS=${LDFLAGS}"
MAKEFILE= GNUmakefile
BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}
PLIST_FILES= bin/mkclean \
bin/mkWDclean
-BROKEN_aarch64= Does not install: arm-none-linux-gnueabi-gcc: Command not found
-BROKEN_armv6= Does not install: arm-none-linux-gnueabi-gcc: Command not found
-BROKEN_armv7= Does not install: arm-none-linux-gnueabi-gcc: Command not found
-BROKEN_mips64= Does not install: mipsel-linux-gcc: Command not found
-BROKEN_sparc64= Does not install: gmake: GNUmakefile: No such file or directory
-
post-extract:
@${REINPLACE_CMD} -e 's,/usr/local,$$(DESTDIR)$$(PREFIX),g' ${WRKSRC}/corec/tools/coremake/gcc_mak.inc
@${RM} ${WRKSRC}/libmatroska2/test/test.proj