aboutsummaryrefslogtreecommitdiff
path: root/multimedia/mlt
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2012-09-03 23:16:06 +0000
committerAlberto Villa <avilla@FreeBSD.org>2012-09-03 23:16:06 +0000
commitc53d228cd2c43ebe13127949de480860899e1ba4 (patch)
treec0ebe3152ecccafea67639b7280fc1eb825107c3 /multimedia/mlt
parent0cffb2684402e1d056caafb11026def462ab6897 (diff)
downloadports-c53d228cd2c43ebe13127949de480860899e1ba4.tar.gz
ports-c53d228cd2c43ebe13127949de480860899e1ba4.zip
Notes
Diffstat (limited to 'multimedia/mlt')
-rw-r--r--multimedia/mlt/Makefile16
-rw-r--r--multimedia/mlt/files/patch-src__framework__configure11
-rw-r--r--multimedia/mlt/files/patch-src__modules__avformat__configure20
-rw-r--r--multimedia/mlt/files/patch-src__modules__frei0r__configure11
4 files changed, 48 insertions, 10 deletions
diff --git a/multimedia/mlt/Makefile b/multimedia/mlt/Makefile
index f84620ce786d..87f2796c3ad6 100644
--- a/multimedia/mlt/Makefile
+++ b/multimedia/mlt/Makefile
@@ -10,11 +10,8 @@ COMMENT= Multimedia framework for TV broadcasting
LICENSE= GPLv2 GPLv3 LGPL21
LICENSE_COMB= multi
-LICENSE_FILE_GPLv2= ${WRKSRC}/GPL
-LICENSE_FILE_GPLv3= ${WRKSRC}/GPLv3
-LICENSE_FILE_LGPL21= ${WRKSRC}/COPYING
-LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg
+LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg
# They both install bin/melt.
CONFLICTS_INSTALL= freeze-[0-9]*
@@ -68,8 +65,7 @@ PLIST_SUB+= DV="@comment "
.if ${PORT_OPTIONS:MFFMPEG} || ${PORT_OPTIONS:MVDPAU}
LIB_DEPENDS+= avformat:${PORTSDIR}/multimedia/ffmpeg
-CONFIGURE_ARGS+= --enable-avformat \
- --avformat-swscale
+CONFIGURE_ARGS+= --enable-avformat --avformat-swscale
PLIST_SUB+= FFMPEG=""
.else
CONFIGURE_ARGS+= --disable-avformat
@@ -171,18 +167,18 @@ PLIST_SUB+= VORBIS="@comment "
.endif
pre-configure:
- ${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},g' \
+ ${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},' \
${WRKSRC}/src/modules/avformat/vdpau.c \
${WRKSRC}/src/modules/frei0r/factory.c \
${WRKSRC}/src/modules/jackrack/plugin_mgr.c \
${WRKSRC}/src/modules/linsys/Makefile
- ${REINPLACE_CMD} -e 's,-pthread,${PTHREAD_LIBS},g' \
+ ${REINPLACE_CMD} -e 's,-pthread,${PTHREAD_LIBS},' \
${WRKSRC}/configure
- ${REINPLACE_CMD} -e 's,-lpthread,${PTHREAD_LIBS},g' \
+ ${REINPLACE_CMD} -e 's,-lpthread,${PTHREAD_LIBS},' \
${WRKSRC}/src/framework/Makefile \
${WRKSRC}/src/melt/Makefile \
${WRKSRC}/src/modules/*/Makefile
- ${REINPLACE_CMD} -e 's,$$(libdir)/pkgconfig,${PREFIX}/libdata/pkgconfig,g' \
+ ${REINPLACE_CMD} -e 's,$$(libdir)/pkgconfig,${PREFIX}/libdata/pkgconfig,' \
${WRKSRC}/Makefile
post-install:
diff --git a/multimedia/mlt/files/patch-src__framework__configure b/multimedia/mlt/files/patch-src__framework__configure
new file mode 100644
index 000000000000..831fca751e5b
--- /dev/null
+++ b/multimedia/mlt/files/patch-src__framework__configure
@@ -0,0 +1,11 @@
+--- ./src/framework/configure.orig 2012-09-04 00:19:55.916055280 +0200
++++ ./src/framework/configure 2012-09-04 00:42:27.466054331 +0200
+@@ -4,7 +4,7 @@
+ echo > config.mak
+ if [ "$(uname -s)" = "FreeBSD" ]
+ then
+- printf "#include <sys/param.h>\n int main(){ return 0;}" | gcc -c -x c - >/dev/null 2>&1
++ printf "#include <sys/param.h>\n int main(){ return 0;}" | $CC -c -x c - >/dev/null 2>&1
+ [ "$?" -eq 0 ] && echo "HAVE_SYS_PARAM_H=1" >> config.mak
+ fi
+ exit 0
diff --git a/multimedia/mlt/files/patch-src__modules__avformat__configure b/multimedia/mlt/files/patch-src__modules__avformat__configure
new file mode 100644
index 000000000000..cf6742262a9b
--- /dev/null
+++ b/multimedia/mlt/files/patch-src__modules__avformat__configure
@@ -0,0 +1,20 @@
+--- ./src/modules/avformat/configure.orig 2012-09-04 00:55:19.926196170 +0200
++++ ./src/modules/avformat/configure 2012-09-04 00:43:04.696053595 +0200
+@@ -105,7 +105,7 @@
+
+ if [ "$vdpau" = "true" ]
+ then
+- printf "#include <libavcodec/vdpau.h>\n int main(){ VdpBitstreamBuffer test; test.struct_version; return 0;}" | gcc -I"$static_ffmpeg" $CFLAGS -c -x c - >/dev/null 2>&1
++ printf "#include <libavcodec/vdpau.h>\n int main(){ VdpBitstreamBuffer test; test.struct_version; return 0;}" | $CC -I"$static_ffmpeg" $CFLAGS -c -x c - >/dev/null 2>&1
+ [ "$x11" = "0" -a "$?" = "0" ] && echo "VDPAU=1" >> config.mak
+ fi
+ else
+@@ -141,7 +141,7 @@
+
+ if [ "$vdpau" = "true" ]
+ then
+- printf "#include <libavcodec/vdpau.h>\n int main(){ VdpBitstreamBuffer test; test.struct_version; return 0;}" | gcc -I"$(pkg-config --cflags libavformat)" -I"$shared_ffmpeg/include" $CFLAGS -c -x c - >/dev/null 2>&1
++ printf "#include <libavcodec/vdpau.h>\n int main(){ VdpBitstreamBuffer test; test.struct_version; return 0;}" | $CC -I"$(pkg-config --cflags libavformat)" -I"$shared_ffmpeg/include" $CFLAGS -c -x c - >/dev/null 2>&1
+ [ "$x11" = "0" -a "$?" = "0" ] && echo "VDPAU=1" >> config.mak
+ fi
+ else
diff --git a/multimedia/mlt/files/patch-src__modules__frei0r__configure b/multimedia/mlt/files/patch-src__modules__frei0r__configure
new file mode 100644
index 000000000000..720f82dea44d
--- /dev/null
+++ b/multimedia/mlt/files/patch-src__modules__frei0r__configure
@@ -0,0 +1,11 @@
+--- ./src/modules/frei0r/configure.orig 2012-09-04 00:21:50.609711766 +0200
++++ ./src/modules/frei0r/configure 2012-09-04 00:47:23.666167132 +0200
+@@ -3,7 +3,7 @@
+ if [ "$help" != "1" ]
+ then
+
+- echo "#include <frei0r.h> int main(){ f0r_plugin_info_t test; test.name;return 0;}"| gcc $CFLAGS -c -x c - >/dev/null 2>&1
++ echo "#include <frei0r.h> int main(){ f0r_plugin_info_t test; test.name;return 0;}"| $CC $CFLAGS -c -x c - >/dev/null 2>&1
+
+ if [ "$?" = "1" ]
+ then