aboutsummaryrefslogtreecommitdiff
path: root/multimedia/mlt
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2010-04-29 12:52:43 +0000
committerAlberto Villa <avilla@FreeBSD.org>2010-04-29 12:52:43 +0000
commitbacc829d71429437dd932e81daadc0edff47c059 (patch)
treedb0f8a8a985cdcf0017d95fc12a19d49692ea6aa /multimedia/mlt
parentefc1619c8f4bc34a0b6cc05b578955223a8398a7 (diff)
downloadports-bacc829d71429437dd932e81daadc0edff47c059.tar.gz
ports-bacc829d71429437dd932e81daadc0edff47c059.zip
Notes
Diffstat (limited to 'multimedia/mlt')
-rw-r--r--multimedia/mlt/Makefile11
-rw-r--r--multimedia/mlt/distinfo6
-rw-r--r--multimedia/mlt/files/patch-src__modules__xine__Makefile16
-rw-r--r--multimedia/mlt/files/patch-src__modules__xine__yadif.c111
-rw-r--r--multimedia/mlt/pkg-plist5
5 files changed, 11 insertions, 138 deletions
diff --git a/multimedia/mlt/Makefile b/multimedia/mlt/Makefile
index 48f64a944635..c121ba8195f1 100644
--- a/multimedia/mlt/Makefile
+++ b/multimedia/mlt/Makefile
@@ -5,10 +5,9 @@
# $FreeBSD$
PORTNAME= mlt
-PORTVERSION= 0.5.0
-PORTREVISION= 1
+PORTVERSION= 0.5.4
CATEGORIES= multimedia
-MASTER_SITES= SF
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}
MAINTAINER= avilla@FreeBSD.org
COMMENT= A multimedia framework and video playout server for TV broadcasting
@@ -32,7 +31,7 @@ PORTDOCS= AUTHORS ChangeLog NEWS README docs demo
OPTIONS= AVFORMAT "Avformat module" on \
DV "Quasar DV Codec module" on \
- FREI0R "Frei0r module" on \
+ FREI0R "Frei0r module (broken on FreeBSD 6.X)" on \
GTK2 "GTK2 module" on \
JACKRACK "JACK Rack module" on \
KINO "Kino module" on \
@@ -41,7 +40,7 @@ OPTIONS= AVFORMAT "Avformat module" on \
RESAMPLE "Secret Rabbit Code module" on \
SOX "Sound eXchange module" on \
SSE "SSE support (requires MMX)" off \
- SSE2 "SSE2 support" off \
+ SSE2 "SSE2 support (requires SSE)" off \
VORBIS "Vorbis module" on
.include <bsd.port.pre.mk>
@@ -65,7 +64,7 @@ CONFIGURE_ARGS+= --disable-dv
PLIST_SUB+= DV="@comment "
.endif
-.ifdef(WITH_FREI0R)
+.if defined(WITH_FREI0R) && ${OSVERSION} >= 700042
BUILD_DEPENDS+= ${LOCALBASE}/include/frei0r.h:${PORTSDIR}/graphics/frei0r
CONFIGURE_ARGS+= --enable-frei0r
PLIST_SUB+= FREI0R=""
diff --git a/multimedia/mlt/distinfo b/multimedia/mlt/distinfo
index 0f037b6e2b60..3efc586248a8 100644
--- a/multimedia/mlt/distinfo
+++ b/multimedia/mlt/distinfo
@@ -1,3 +1,3 @@
-MD5 (mlt-0.5.0.tar.gz) = 5e904e02c879d64f1c6fe14c75be0479
-SHA256 (mlt-0.5.0.tar.gz) = 6741488a067a79f0149b3e4f9fc81706017b1d0db8415c0b1a9ae2264882c6bf
-SIZE (mlt-0.5.0.tar.gz) = 796572
+MD5 (mlt-0.5.4.tar.gz) = 09ae3d74691c86dad10c2e13e1844b43
+SHA256 (mlt-0.5.4.tar.gz) = 12ea1f2fc8adeda7db0d31c1270e843d9036a65a81fbeac7c885605397fd458b
+SIZE (mlt-0.5.4.tar.gz) = 802138
diff --git a/multimedia/mlt/files/patch-src__modules__xine__Makefile b/multimedia/mlt/files/patch-src__modules__xine__Makefile
deleted file mode 100644
index adcdb470aede..000000000000
--- a/multimedia/mlt/files/patch-src__modules__xine__Makefile
+++ /dev/null
@@ -1,16 +0,0 @@
---- ./src/modules/xine/Makefile.orig 2010-02-16 07:40:46.000000000 +0100
-+++ ./src/modules/xine/Makefile 2010-02-25 23:10:51.286144467 +0100
-@@ -1,4 +1,4 @@
--CFLAGS += -I../../ -DARCH_X86
-+CFLAGS += -I../../
-
- LDFLAGS += -L../../framework -lmlt
-
-@@ -12,6 +12,7 @@
- filter_deinterlace.o
-
- ifdef MMX_FLAGS
-+CFLAGS += -DARCH_X86
- OBJS += cpu_accel.o
- endif
-
diff --git a/multimedia/mlt/files/patch-src__modules__xine__yadif.c b/multimedia/mlt/files/patch-src__modules__xine__yadif.c
deleted file mode 100644
index 335a4ada0594..000000000000
--- a/multimedia/mlt/files/patch-src__modules__xine__yadif.c
+++ /dev/null
@@ -1,111 +0,0 @@
---- ./src/modules/xine/yadif.c.orig 2010-02-16 07:40:46.000000000 +0100
-+++ ./src/modules/xine/yadif.c 2010-02-25 23:10:51.289144010 +0100
-@@ -34,7 +34,8 @@
-
- static void (*filter_line)(int mode, uint8_t *dst, const uint8_t *prev, const uint8_t *cur, const uint8_t *next, int w, int refs, int parity);
-
--#ifdef __GNUC__
-+#if defined(__GNUC__) && defined(USE_SSE)
-+
- #define LOAD4(mem,dst) \
- "movd "mem", "#dst" \n\t"\
- "punpcklbw %%mm7, "#dst" \n\t"
-@@ -264,6 +265,7 @@
- #endif
-
- // ================= SSE2 =================
-+#ifdef USE_SSE2
- #define PABS(tmp,dst) \
- "pxor "#tmp", "#tmp" \n\t"\
- "psubw "#dst", "#tmp" \n\t"\
-@@ -271,17 +273,19 @@
-
- #define FILTER_LINE_FUNC_NAME filter_line_sse2
- #include "vf_yadif_template.h"
-+#endif
-
- // ================ SSSE3 =================
-+#ifdef USE_SSE3
- #define PABS(tmp,dst) \
- "pabsw "#dst", "#dst" \n\t"
-
- #define FILTER_LINE_FUNC_NAME filter_line_ssse3
- #include "vf_yadif_template.h"
--
- #endif
-
--#endif
-+#endif // GCC 4.2+
-+#endif // GNUC, USE_SSE
-
- static void filter_line_c(int mode, uint8_t *dst, const uint8_t *prev, const uint8_t *cur, const uint8_t *next, int w, int refs, int parity){
- int x;
-@@ -356,15 +360,22 @@
- filter_line = filter_line_c;
- #ifdef __GNUC__
- #if (__GNUC__ > 4 || __GNUC__ == 4 && __GNUC_MINOR__>1)
-+#ifdef USE_SSE3
- if (cpu & AVS_CPU_SSSE3)
- filter_line = filter_line_ssse3;
-- else if (cpu & AVS_CPU_SSE2)
-+ else
-+#endif
-+#ifdef USE_SSE2
-+ if (cpu & AVS_CPU_SSE2)
- filter_line = filter_line_sse2;
- else
- #endif
-+#endif // GCC 4.2+
-+#ifdef USE_SSE
- if (cpu & AVS_CPU_INTEGER_SSE)
- filter_line = filter_line_mmx2;
- #endif
-+#endif // GNUC
- y=0;
- if(((y ^ parity) & 1)){
- memcpy(dst, cur0 + refs, w);// duplicate 1
-@@ -401,14 +412,13 @@
- memcpy(dst + (h-1)*dst_stride, cur0 + (h-1)*refs, w); // copy original
- }
-
--#ifdef __GNUC__
-+#if defined(__GNUC__) && defined(USE_SSE)
- if (cpu >= AVS_CPU_INTEGER_SSE)
- asm volatile("emms");
- #endif
- }
-
--#ifdef __GNUC__
--#ifndef PIC
-+#if defined(__GNUC__) && defined(USE_SSE) && !defined(PIC)
- static attribute_align_arg void YUY2ToPlanes_mmx(const unsigned char *srcYUY2, int pitch_yuy2, int width, int height,
- unsigned char *py, int pitch_y,
- unsigned char *pu, unsigned char *pv, int pitch_uv)
-@@ -486,8 +496,7 @@
- }
- asm ("sfence \n\t emms");
- }
--#endif
--#endif
-+#endif // GNUC, USE_SSE, !PIC
-
- //----------------------------------------------------------------------------------------------
-
-@@ -498,7 +507,7 @@
-
- int h,w;
- int w0 = 0;
--#if defined(__GNUC__) && !defined(PIC)
-+#if defined(__GNUC__) && defined(USE_SSE) && !defined(PIC)
- if (cpu & AVS_CPU_INTEGER_SSE) {
- w0 = (nWidth/8)*8;
- YUY2ToPlanes_mmx(pSrcYUY2, nSrcPitchYUY2, w0, nHeight, pSrcY, srcPitchY, pSrcU, pSrcV, srcPitchUV);
-@@ -529,7 +538,7 @@
- {
- int h,w;
- int w0 = 0;
--#if defined(__GNUC__) && !defined(PIC)
-+#if defined(__GNUC__) && defined(USE_SSE) && !defined(PIC)
- if (cpu & AVS_CPU_INTEGER_SSE) {
- w0 = (nWidth/8)*8;
- YUY2FromPlanes_mmx(pSrcYUY2, nSrcPitchYUY2, w0, nHeight, pSrcY, srcPitchY, pSrcU, pSrcV, srcPitchUV);
diff --git a/multimedia/mlt/pkg-plist b/multimedia/mlt/pkg-plist
index 6ec70c2888f2..6865d4119f54 100644
--- a/multimedia/mlt/pkg-plist
+++ b/multimedia/mlt/pkg-plist
@@ -7,6 +7,7 @@ include/mlt++/MltFactory.h
include/mlt++/MltField.h
include/mlt++/MltFilter.h
include/mlt++/MltFilteredConsumer.h
+include/mlt++/MltFilteredProducer.h
include/mlt++/MltFrame.h
include/mlt++/MltGeometry.h
include/mlt++/MltMultitrack.h
@@ -48,10 +49,10 @@ include/mlt/framework/mlt_tractor.h
include/mlt/framework/mlt_transition.h
include/mlt/framework/mlt_types.h
lib/libmlt++.so
-lib/libmlt++.so.0.5.0
+lib/libmlt++.so.0.5.4
lib/libmlt++.so.3
lib/libmlt.so
-lib/libmlt.so.0.5.0
+lib/libmlt.so.0.5.4
lib/libmlt.so.2
%%AVFORMAT%%lib/mlt/libmltavformat.so
lib/mlt/libmltcore.so