aboutsummaryrefslogtreecommitdiff
path: root/multimedia/mmpython
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-06-10 19:04:24 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-06-10 19:04:24 +0000
commitc220d7c05a48469b7af57b272790b23a78e73c99 (patch)
tree03219b02db43fe0ddeba6ffd53170e1e3ae0de20 /multimedia/mmpython
parent7c916b718723bed5cb856654dfde4ec0c577d819 (diff)
downloadports-c220d7c05a48469b7af57b272790b23a78e73c99.tar.gz
ports-c220d7c05a48469b7af57b272790b23a78e73c99.zip
Notes
Diffstat (limited to 'multimedia/mmpython')
-rw-r--r--multimedia/mmpython/Makefile1
-rw-r--r--multimedia/mmpython/files/patch-disc_discinfo.py32
-rw-r--r--multimedia/mmpython/files/patch-disc_dvdinfo.py27
-rw-r--r--multimedia/mmpython/files/patch-disc_lsdvd.py16
-rw-r--r--multimedia/mmpython/files/patch-disc_vcdinfo.py18
-rw-r--r--multimedia/mmpython/files/patch-video_vcdinfo.py18
6 files changed, 112 insertions, 0 deletions
diff --git a/multimedia/mmpython/Makefile b/multimedia/mmpython/Makefile
index 7a3ad89b9085..1f63fdb4279e 100644
--- a/multimedia/mmpython/Makefile
+++ b/multimedia/mmpython/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mmpython
PORTVERSION= 0.4.2
+PORTREVISION= 1
CATEGORIES= multimedia python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/multimedia/mmpython/files/patch-disc_discinfo.py b/multimedia/mmpython/files/patch-disc_discinfo.py
new file mode 100644
index 000000000000..237958ec15af
--- /dev/null
+++ b/multimedia/mmpython/files/patch-disc_discinfo.py
@@ -0,0 +1,32 @@
+
+$FreeBSD$
+
+--- disc/discinfo.py.orig Thu Jun 10 20:51:51 2004
++++ disc/discinfo.py Thu Jun 10 20:52:32 2004
+@@ -223,22 +223,10 @@
+ else:
+ f = open(device,'rb')
+
+- f.seek(0x0000832d)
+- if os.uname()[0] == 'FreeBSD':
+- # why doesn't seeking to 0x0000832d+40 and reading 32 work?
+- # no idea, do it this way
+- label = f.read(72);
+- label = label[40:72]
+- else:
+- id = f.read(16)
+- f.seek(32808, 0)
+- if os.uname()[0] == 'FreeBSD':
+- # why doesn't seeking to 32808 + 829 and reading 16 work?
+- # no idea, do it this way
+- id = f.read(829);
+- id = id[813:829]
+- else:
+- label = f.read(32)
++ f.seek(32768)
++ id = f.read(829)
++ label = id[40:72]
++ id = id[813:829]
+
+ if CREATE_MD5_ID:
+ id_md5 = md5.new()
diff --git a/multimedia/mmpython/files/patch-disc_dvdinfo.py b/multimedia/mmpython/files/patch-disc_dvdinfo.py
new file mode 100644
index 000000000000..a69022a3bb61
--- /dev/null
+++ b/multimedia/mmpython/files/patch-disc_dvdinfo.py
@@ -0,0 +1,27 @@
+
+$FreeBSD$
+
+--- disc/dvdinfo.py.orig Thu Jun 10 20:53:51 2004
++++ disc/dvdinfo.py Thu Jun 10 20:55:02 2004
+@@ -115,8 +115,8 @@
+
+ # brute force reading of the device to find out if it is a DVD
+ f = open(device,'rb')
+- f.seek(32808, 0)
+- buffer = f.read(50000)
++ f.seek(32768, 0)
++ buffer = f.read(50040)
+
+ if buffer.find('UDF') == -1:
+ f.close()
+@@ -148,8 +148,8 @@
+
+ def isDVDiso(self, f):
+ # brute force reading of the device to find out if it is a DVD
+- f.seek(32808, 0)
+- buffer = f.read(50000)
++ f.seek(32768, 0)
++ buffer = f.read(50040)
+
+ if buffer.find('UDF') == -1:
+ return 0
diff --git a/multimedia/mmpython/files/patch-disc_lsdvd.py b/multimedia/mmpython/files/patch-disc_lsdvd.py
new file mode 100644
index 000000000000..bc3a1e49d6ac
--- /dev/null
+++ b/multimedia/mmpython/files/patch-disc_lsdvd.py
@@ -0,0 +1,16 @@
+
+$FreeBSD$
+
+--- disc/lsdvd.py.orig Thu Jun 10 20:55:34 2004
++++ disc/lsdvd.py Thu Jun 10 20:58:14 2004
+@@ -173,8 +173,8 @@
+
+ # brute force reading of the device to find out if it is a DVD
+ f = open(device,'rb')
+- f.seek(32808, 0)
+- buffer = f.read(50000)
++ f.seek(32768, 0)
++ buffer = f.read(50040)
+
+ if buffer.find('UDF') == -1:
+ f.close()
diff --git a/multimedia/mmpython/files/patch-disc_vcdinfo.py b/multimedia/mmpython/files/patch-disc_vcdinfo.py
new file mode 100644
index 000000000000..f691de2d1338
--- /dev/null
+++ b/multimedia/mmpython/files/patch-disc_vcdinfo.py
@@ -0,0 +1,18 @@
+
+$FreeBSD$
+
+--- disc/vcdinfo.py.orig Thu Jun 10 20:56:21 2004
++++ disc/vcdinfo.py Thu Jun 10 20:56:59 2004
+@@ -62,9 +62,9 @@
+
+ # brute force reading of the device to find out if it is a VCD
+ f = open(device,'rb')
+- f.seek(32808, 0)
+- buffer = f.read(50000)
+- f.close()
++ f.seek(32768, 0)
++ buffer = f.read(50040)
++ f.close()
+
+ if buffer.find('SVCD') > 0 and buffer.find('TRACKS.SVD') > 0 and \
+ buffer.find('ENTRIES.SVD') > 0:
diff --git a/multimedia/mmpython/files/patch-video_vcdinfo.py b/multimedia/mmpython/files/patch-video_vcdinfo.py
new file mode 100644
index 000000000000..767f466bffce
--- /dev/null
+++ b/multimedia/mmpython/files/patch-video_vcdinfo.py
@@ -0,0 +1,18 @@
+
+$FreeBSD$
+
+--- video/vcdinfo.py.orig Thu Jun 10 20:58:51 2004
++++ video/vcdinfo.py Thu Jun 10 20:59:19 2004
+@@ -85,9 +85,9 @@
+
+ # brute force reading of the bin to find out if it is a VCD
+ f = open(bin,'rb')
+- f.seek(32808, 0)
+- buffer = f.read(50000)
+- f.close()
++ f.seek(32768, 0)
++ buffer = f.read(50040)
++ f.close()
+
+ if buffer.find('SVCD') > 0 and buffer.find('TRACKS.SVD') > 0 and \
+ buffer.find('ENTRIES.SVD') > 0: