aboutsummaryrefslogtreecommitdiff
path: root/multimedia/motion/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2005-12-25 21:55:42 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2005-12-25 21:55:42 +0000
commit81a573d7c6a85ae149ac9f44eea2a327a36d13a3 (patch)
tree28c127d6d9f5b44d4c60b3c1ecdae1a92bf9aab6 /multimedia/motion/Makefile
parent406b4e65f3dcb6e970f30adfc9a57d1e7ec99858 (diff)
Notes
Diffstat (limited to 'multimedia/motion/Makefile')
-rw-r--r--multimedia/motion/Makefile80
1 files changed, 80 insertions, 0 deletions
diff --git a/multimedia/motion/Makefile b/multimedia/motion/Makefile
new file mode 100644
index 000000000000..3c78d73cf828
--- /dev/null
+++ b/multimedia/motion/Makefile
@@ -0,0 +1,80 @@
+# New ports collection makefile for: motion
+# Date created: 22 Dec 2005
+# Whom: Angel Carpintero <ack@telefonica.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= motion
+PORTVERSION= 3.2.4
+CATEGORIES= multimedia
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= motion
+
+PATCH_SITES= http://www.lavrsen.dk/twiki/pub/Motion/FreeBSDPatch/
+PATCHFILES= motion-3.2.5-daily.diff.gz motion-3.2.4-port-configure-patch.diff.gz
+PATCH_DIST_STRIP= -p1
+
+MAINTAINER= ack@telefonica.net
+COMMENT= A motion detection application
+
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
+ avcodec.1:${PORTSDIR}/multimedia/ffmpeg
+
+ONLY_FOR_ARCHS= i386 amd64
+
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+MAN1= motion.1
+
+USE_AUTOTOOLS= autoconf:259
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+MANCOMPRESSED= no
+USE_GCC= 3.4+
+
+MAN1= motion.1
+PORTDOCS= CHANGELOG CREDITS README.FreeBSD README \
+ motion_guide.html
+EXAMPLES= motion-dist.conf motion.init-FreeBSD.sh thread1.conf \
+ thread2.conf thread3.conf thread4.conf
+
+OPTIONS= BKTR "Support for TV Capture cards" on
+
+MAKE_ENV+= CC="${CC}"
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITH_BKTR)
+CFLAGS+= -DWITHOUT_V4L
+.endif
+
+.if ${OSVERSION} > 500000
+LIB_DEPENDS+= lthread.[35]:${PORTSDIR}/devel/linuxthreads
+.else
+LIB_DEPENDS+= lthread.[24]:${PORTSDIR}/devel/linuxthreads
+.endif
+
+post-install:
+.if !exists(${PREFIX}/etc/motion.conf)
+ ${INSTALL_DATA} ${PREFIX}/etc/motion.conf.sample ${PREFIX}/etc/motion.conf
+.endif
+ ${MKDIR} ${EXAMPLESDIR}
+.for f in ${EXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${EXAMPLESDIR}
+.endfor
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.if defined(WITH_BKTR)
+ @${ECHO_MSG} "==============================================================================="
+ @${ECHO_MSG} "Please make sure you have bktr(4) kernel support."
+ @${ECHO_MSG} "==============================================================================="
+.endif
+
+.include <bsd.port.post.mk>