aboutsummaryrefslogtreecommitdiff
path: root/multimedia/mp4split
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-05-27 06:19:49 +0000
committerWen Heping <wen@FreeBSD.org>2010-05-27 06:19:49 +0000
commit872233e13d7d32b0048ea43ed1e212499d0915d1 (patch)
tree077928cede5cc06d1c50163cea29fd882048e041 /multimedia/mp4split
parent0bb626ff74de8d08beb9b62aef8ae246f6625852 (diff)
downloadports-872233e13d7d32b0048ea43ed1e212499d0915d1.tar.gz
ports-872233e13d7d32b0048ea43ed1e212499d0915d1.zip
Notes
Diffstat (limited to 'multimedia/mp4split')
-rw-r--r--multimedia/mp4split/Makefile30
-rw-r--r--multimedia/mp4split/distinfo3
-rw-r--r--multimedia/mp4split/pkg-descr4
3 files changed, 37 insertions, 0 deletions
diff --git a/multimedia/mp4split/Makefile b/multimedia/mp4split/Makefile
new file mode 100644
index 000000000000..9d15a6e4a23d
--- /dev/null
+++ b/multimedia/mp4split/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: mp4split
+# Date created: May 26, 2010
+# Whom: Marcus Hermansson <bmhermansson@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mp4split
+PORTVERSION= 1.0.8
+CATEGORIES= multimedia
+MASTER_SITES= http://smoothstreaming.code-shop.com/download/
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= bmhermansson@gmail.com
+COMMENT= Converts MP4 files to Fragmented MP4 and creates manifest files
+
+LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --with-expat
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+PLIST_FILES= bin/mp4split
+
+RESTRICTED= no-commercial-use
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+.include <bsd.port.mk>
diff --git a/multimedia/mp4split/distinfo b/multimedia/mp4split/distinfo
new file mode 100644
index 000000000000..00f9029316ed
--- /dev/null
+++ b/multimedia/mp4split/distinfo
@@ -0,0 +1,3 @@
+MD5 (mp4split-1.0.8.tar.gz) = c31af4c7bf7f516ee2aa7e1dd97ab3f8
+SHA256 (mp4split-1.0.8.tar.gz) = 8fa1dc79014a909b3606f42e921710fae15019d1eec0e4e577ad219ddeecbd4d
+SIZE (mp4split-1.0.8.tar.gz) = 153942
diff --git a/multimedia/mp4split/pkg-descr b/multimedia/mp4split/pkg-descr
new file mode 100644
index 000000000000..0e21bf8ef221
--- /dev/null
+++ b/multimedia/mp4split/pkg-descr
@@ -0,0 +1,4 @@
+This tool converts MP4 files to Fragmented MP4 and also creates the
+necessary manifest files.
+
+WWW: http://smoothstreaming.code-shop.com