aboutsummaryrefslogtreecommitdiff
path: root/multimedia/mpeg4ip-libmp4v2
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-03-14 02:10:35 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-03-14 02:10:35 +0000
commitdbd2d753996251efcfcaf22c11d91a2b79b3a0ee (patch)
tree47caffcb4dc7649c38816e72c6a00bd960b345cd /multimedia/mpeg4ip-libmp4v2
parent0005347301cb2c85fa333e1e921e499dd4106fa9 (diff)
downloadports-dbd2d753996251efcfcaf22c11d91a2b79b3a0ee.tar.gz
ports-dbd2d753996251efcfcaf22c11d91a2b79b3a0ee.zip
Notes
Diffstat (limited to 'multimedia/mpeg4ip-libmp4v2')
-rw-r--r--multimedia/mpeg4ip-libmp4v2/Makefile6
-rw-r--r--multimedia/mpeg4ip-libmp4v2/files/patch-ltmain.sh15
2 files changed, 3 insertions, 18 deletions
diff --git a/multimedia/mpeg4ip-libmp4v2/Makefile b/multimedia/mpeg4ip-libmp4v2/Makefile
index 67493f34a88c..0630d2c257bc 100644
--- a/multimedia/mpeg4ip-libmp4v2/Makefile
+++ b/multimedia/mpeg4ip-libmp4v2/Makefile
@@ -18,7 +18,7 @@ COMMENT= Mpeg-4 library and tools from mpeg4ip
USE_GMAKE= yes
USE_GNOME= gnometarget
-USE_INC_LIBTOOL_VER=15
+USE_LIBTOOL_VER=15
USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}"
@@ -33,8 +33,8 @@ INSTALL_WRKSRC= ${WRKSRC}/lib/mp4v2
BROKEN= "Please remove older version of faad before attempting to build ${PORTNAME}"
.endif
-.if ${OSVERSION} < 502110
-USE_GCC= 3.4
+.if ${OSVERSION} < 500000
+CFLAGS+= -O2
.endif
post-patch:
diff --git a/multimedia/mpeg4ip-libmp4v2/files/patch-ltmain.sh b/multimedia/mpeg4ip-libmp4v2/files/patch-ltmain.sh
deleted file mode 100644
index b7b985b46652..000000000000
--- a/multimedia/mpeg4ip-libmp4v2/files/patch-ltmain.sh
+++ /dev/null
@@ -1,15 +0,0 @@
---- ltmain.sh.orig Thu Sep 30 04:09:46 2004
-+++ ltmain.sh Thu Sep 30 04:11:06 2004
-@@ -5425,10 +5425,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"