aboutsummaryrefslogtreecommitdiff
path: root/multimedia/mpeg4ip/files
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2004-11-10 01:02:45 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2004-11-10 01:02:45 +0000
commit2511267b0fc4c1a7bf5d1396911fe1426a914ed8 (patch)
tree24b39556d45bb3c36e3a8a63ceff7bac44932c9d /multimedia/mpeg4ip/files
parenta2f636b22c166cdd9d0aff3de359058c87bb2228 (diff)
Notes
Diffstat (limited to 'multimedia/mpeg4ip/files')
-rw-r--r--multimedia/mpeg4ip/files/extra-patch-lib::sdp::sdp_decode.c20
-rw-r--r--multimedia/mpeg4ip/files/patch-common::video::libmpeg32::video::Makefile.in16
-rw-r--r--multimedia/mpeg4ip/files/patch-common::video::mpeg4-2000::idct::idct.hpp12
-rw-r--r--multimedia/mpeg4ip/files/patch-gcc3454
-rw-r--r--multimedia/mpeg4ip/files/patch-include::mpeg4ip.h19
-rw-r--r--multimedia/mpeg4ip/files/patch-include::mpeg4ip_byteswap.h22
-rw-r--r--multimedia/mpeg4ip/files/patch-lib::Makefile.in11
-rw-r--r--multimedia/mpeg4ip/files/patch-lib::SDLAudio::ltmain.sh15
-rw-r--r--multimedia/mpeg4ip/files/patch-lib::xvid::bitstream::h263.h30
-rw-r--r--multimedia/mpeg4ip/files/patch-ltmain.sh15
-rw-r--r--multimedia/mpeg4ip/files/patch-mpeg4ip_config.h.in19
-rw-r--r--multimedia/mpeg4ip/files/patch-player::src::codec::mp3::mp3_file.cpp10
-rw-r--r--multimedia/mpeg4ip/files/patch-player::src::mpeg3_rtp_bytestream.cpp29
13 files changed, 208 insertions, 64 deletions
diff --git a/multimedia/mpeg4ip/files/extra-patch-lib::sdp::sdp_decode.c b/multimedia/mpeg4ip/files/extra-patch-lib::sdp::sdp_decode.c
new file mode 100644
index 000000000000..7f37b6259172
--- /dev/null
+++ b/multimedia/mpeg4ip/files/extra-patch-lib::sdp::sdp_decode.c
@@ -0,0 +1,20 @@
+--- lib/sdp/sdp_decode.c.orig Thu Sep 30 01:32:23 2004
++++ lib/sdp/sdp_decode.c Thu Sep 30 01:32:45 2004
+@@ -378,7 +378,7 @@
+ q = NULL;
+ while (p != NULL) {
+ if (new->adj_time == p->adj_time) {
+- sdp_debug(LOG_NOTICE, "Duplicate time %ld in adj description", p->adj_time);
++ sdp_debug(LOG_NOTICE, "Duplicate time %d in adj description", p->adj_time);
+ free(new);
+ return (start);
+ }
+@@ -1580,7 +1580,7 @@
+ continue;
+ }
+ // process <adjustment time> - adjust it from NTP to unix time
+- sscanf(sep, "%ld", &adj_time);
++ sscanf(sep, "%d", &adj_time);
+
+ // Check for negative sign for offset.
+ ADV_SPACE(lptr);
diff --git a/multimedia/mpeg4ip/files/patch-common::video::libmpeg32::video::Makefile.in b/multimedia/mpeg4ip/files/patch-common::video::libmpeg32::video::Makefile.in
new file mode 100644
index 000000000000..9990806a0e5f
--- /dev/null
+++ b/multimedia/mpeg4ip/files/patch-common::video::libmpeg32::video::Makefile.in
@@ -0,0 +1,16 @@
+--- common/video/libmpeg32/video/Makefile.in.orig Tue Sep 28 23:54:37 2004
++++ common/video/libmpeg32/video/Makefile.in Tue Sep 28 23:55:25 2004
+@@ -290,11 +290,11 @@
+ @AMDEP_TRUE@ ./$(DEPDIR)/seek.Plo ./$(DEPDIR)/slice.Plo \
+ @AMDEP_TRUE@ ./$(DEPDIR)/vlc.Plo
+ CCASCOMPILE = $(CCAS) $(AM_CCASFLAGS) $(CCASFLAGS)
+-LTCCASCOMPILE = $(LIBTOOL) --mode=compile $(CCAS) $(AM_CCASFLAGS) \
++LTCCASCOMPILE = $(LIBTOOL) --mode=compile --tag=CC $(CCAS) $(AM_CCASFLAGS) \
+ $(CCASFLAGS)
+ COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
+ $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+-LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) \
++LTCOMPILE = $(LIBTOOL) --mode=compile --tag=CC $(CC) $(DEFS) $(DEFAULT_INCLUDES) \
+ $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+ CCLD = $(CC)
+ LINK = $(LIBTOOL) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
diff --git a/multimedia/mpeg4ip/files/patch-common::video::mpeg4-2000::idct::idct.hpp b/multimedia/mpeg4ip/files/patch-common::video::mpeg4-2000::idct::idct.hpp
new file mode 100644
index 000000000000..14a143f5c2d7
--- /dev/null
+++ b/multimedia/mpeg4ip/files/patch-common::video::mpeg4-2000::idct::idct.hpp
@@ -0,0 +1,12 @@
+--- common/video/mpeg4-2000/idct/idct.hpp.orig Thu Sep 30 01:01:36 2004
++++ common/video/mpeg4-2000/idct/idct.hpp Thu Sep 30 01:01:56 2004
+@@ -22,6 +22,9 @@
+ #ifndef _INT_IDCT_
+ #define _INT_IDCT_ 1
+
++#ifndef BLOCK_SIZE
++#define BLOCK_SIZE 5
++#endif
+
+ #define IDCT_BLOCK_SIZE 8
+ class idct{
diff --git a/multimedia/mpeg4ip/files/patch-gcc34 b/multimedia/mpeg4ip/files/patch-gcc34
index 364db01d9d52..8c485c15e72c 100644
--- a/multimedia/mpeg4ip/files/patch-gcc34
+++ b/multimedia/mpeg4ip/files/patch-gcc34
@@ -1,11 +1,45 @@
---- common/video/mpeg4-2000/idct/idct.hpp.orig Fri Jul 23 01:57:47 2004
-+++ common/video/mpeg4-2000/idct/idct.hpp Fri Jul 23 02:02:41 2004
-@@ -22,7 +22,7 @@
- #ifndef _INT_IDCT_
- #define _INT_IDCT_ 1
+--- common/video/mpeg4-2000/tools/entropy/huffman.cpp.orig Tue Sep 28 22:51:26 2004
++++ common/video/mpeg4-2000/tools/entropy/huffman.cpp Tue Sep 28 22:51:47 2004
+@@ -243,9 +243,6 @@
+ Void CHuffmanTree::printStatistics (Double dEntropy, Double dNOfBits, ostream &stream)
+ {
+ stream<<endl<<endl;
+- stream<<"//Entropy Per Symbol : "<<dEntropy<<endl;
+- stream<<"//Bits Per Symbol : "<<dNOfBits<<endl;
+- stream<<"//Table Efficiency : "<<dEntropy/dNOfBits<<endl;
+ }
--
-+#define BLOCK_SIZE 5
- #define IDCT_BLOCK_SIZE 8
- class idct{
- public:
+ Int CHuffmanCoDec::makeIndexFromSymbolInTable(istream &huffmanTable)
+--- common/video/mpeg4-2000/tools/entropy/bitstrm.cpp.orig Tue Sep 28 22:56:07 2004
++++ common/video/mpeg4-2000/tools/entropy/bitstrm.cpp Tue Sep 28 22:56:25 2004
+@@ -323,7 +323,6 @@
+ if (m_pstrmTrace != NULL) {
+ m_pstrmTrace->width (20);
+ (*m_pstrmTrace) << rgchSymbolName << "= ";
+- (*m_pstrmTrace) << fltValue << "\n";
+ m_pstrmTrace->flush ();
+ }
+ }
+@@ -356,8 +355,6 @@
+ if (m_pstrmTrace != NULL) {
+ m_pstrmTrace->width (20);
+ (*m_pstrmTrace) << rgchSymbolName << "= ";
+- (*m_pstrmTrace) << vctValue.x << ", ";
+- (*m_pstrmTrace) << vctValue.y << "\n ";
+ m_pstrmTrace->flush ();
+ }
+ }
+--- common/video/mpeg4-2000/sys/mode.cpp.orig Tue Sep 28 23:05:10 2004
++++ common/video/mpeg4-2000/sys/mode.cpp Tue Sep 28 23:05:59 2004
+@@ -409,12 +409,6 @@
+ // if (bVOPPrint)
+ cout << "\t" << "Shape:" << "\t\t\t" << nBitsShape << "\n";
+ cout << "\t" << "Total:" << "\t\t\t" << nBitsTotal << "\n";
+- cout << "\t" << "SNR Y:" << "\t\t\t" << dSNRY / nVOPs << " dB\n";
+- cout << "\t" << "SNR U:" << "\t\t\t" << dSNRU / nVOPs << " dB\n";
+- cout << "\t" << "SNR V:" << "\t\t\t" << dSNRV / nVOPs << " dB\n";
+- for(Int iAuxComp=0;iAuxComp<m_iAuxCompCount;iAuxComp++) // MAC (SB) 26-Nov-99
+- cout << "\t" << "SNR A[" << iAuxComp << "]:" << "\t\t" << dSNRA[iAuxComp] / nVOPs << " dB\n";
+- cout << "\n\t" << "average Qp:" << "\t\t" << (Double)nQp / nQMB << "\n\n";
+ cout.flush ();
+ }
diff --git a/multimedia/mpeg4ip/files/patch-include::mpeg4ip.h b/multimedia/mpeg4ip/files/patch-include::mpeg4ip.h
new file mode 100644
index 000000000000..550c65913825
--- /dev/null
+++ b/multimedia/mpeg4ip/files/patch-include::mpeg4ip.h
@@ -0,0 +1,19 @@
+--- include/mpeg4ip.h.orig Wed Sep 29 14:43:52 2004
++++ include/mpeg4ip.h Wed Sep 29 14:44:10 2004
+@@ -160,14 +160,14 @@
+ #include <errno.h>
+ #include <stdlib.h>
+
+-#ifdef HAVE_INTTYPES_H
+ #include <inttypes.h>
+-#endif
+ #ifdef HAVE_STDINT_H
+ #include <stdint.h>
+ #endif
++#if 0
+ #if !defined(HAVE_INTTYPES_H) || !defined(HAVE_STDINT_H)
+ #error "Don't have stdint.h or inttypes.h - no way to get uint8_t"
++#endif
+ #endif
+
+ #include <unistd.h>
diff --git a/multimedia/mpeg4ip/files/patch-include::mpeg4ip_byteswap.h b/multimedia/mpeg4ip/files/patch-include::mpeg4ip_byteswap.h
index b43547f8f560..394dbf83e2bb 100644
--- a/multimedia/mpeg4ip/files/patch-include::mpeg4ip_byteswap.h
+++ b/multimedia/mpeg4ip/files/patch-include::mpeg4ip_byteswap.h
@@ -1,19 +1,28 @@
---- include/mpeg4ip_byteswap.h.orig Wed Nov 13 16:44:43 2002
-+++ include/mpeg4ip_byteswap.h Wed Nov 13 16:44:47 2002
-@@ -26,2 +26,6 @@
+--- include/mpeg4ip_byteswap.h.orig Mon Jul 22 14:27:09 2002
++++ include/mpeg4ip_byteswap.h Sun Nov 7 03:57:01 2004
+@@ -24,6 +24,10 @@
+ #include <config.h>
+ #endif
+#if (defined(__unix__) || defined(unix)) && !defined(USG)
+#include <sys/param.h>
+#endif
+
#if defined(WORDS_BIGENDIAN)
-@@ -51,2 +55,16 @@
- #define B2N_64(x) x = swap64(x)
+ /* All bigendian systems are fine, just ignore the swaps. */
+ #define B2N_16(x) (x)
+@@ -55,6 +59,24 @@
+ * FreeBSD and Solaris don't have <byteswap.h> or any other such
+ * functionality!
+ */
+
+#elif defined(__FreeBSD__) && __FreeBSD_version >= 470000
+#include <sys/endian.h>
+#define B2N_16(x) (be16toh(x))
+#define B2N_32(x) (be32toh(x))
++# if __FreeBSD_version >= 510000
++#define B2N_64(x) (be64toh(x))
++# else
+#define B2N_64(x) \
+ x = ((((x) & 0xff00000000000000) >> 56) | \
+ (((x) & 0x00ff000000000000) >> 40) | \
@@ -23,4 +32,7 @@
+ (((x) & 0x0000000000ff0000) << 24) | \
+ (((x) & 0x000000000000ff00) << 40) | \
+ (((x) & 0x00000000000000ff) << 56))
++# endif
+ #elif defined(__FreeBSD__) || defined(__sun) || defined(__bsdi__) || defined(_WIN32)
+ #define B2N_16(x) \
diff --git a/multimedia/mpeg4ip/files/patch-lib::Makefile.in b/multimedia/mpeg4ip/files/patch-lib::Makefile.in
deleted file mode 100644
index f4bf9cba5d1a..000000000000
--- a/multimedia/mpeg4ip/files/patch-lib::Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/Makefile.in.orig Wed Jan 1 21:46:28 2003
-+++ lib/Makefile.in Wed Jan 1 21:47:39 2003
-@@ -110,7 +110,7 @@
- am__include = @am__include@
- am__quote = @am__quote@
- install_sh = @install_sh@
--SUBDIRS = avi bitstream config_file fposrec gnu mp4 mp4v2 mp4av msg_queue rtp sdp SDL xvid mpeg2t SDL_VisualC
-+SUBDIRS = avi bitstream config_file fposrec gnu mp4 mp4v2 mp4av msg_queue rtp sdp xvid mpeg2t
- subdir = lib
- mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
- CONFIG_HEADER = $(top_builddir)/config.h
diff --git a/multimedia/mpeg4ip/files/patch-lib::SDLAudio::ltmain.sh b/multimedia/mpeg4ip/files/patch-lib::SDLAudio::ltmain.sh
new file mode 100644
index 000000000000..042b9d7965c9
--- /dev/null
+++ b/multimedia/mpeg4ip/files/patch-lib::SDLAudio::ltmain.sh
@@ -0,0 +1,15 @@
+--- lib/SDLAudio/ltmain.sh.orig Sun Nov 7 21:50:06 2004
++++ lib/SDLAudio/ltmain.sh Sun Nov 7 21:50:28 2004
+@@ -5425,10 +5425,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/multimedia/mpeg4ip/files/patch-lib::xvid::bitstream::h263.h b/multimedia/mpeg4ip/files/patch-lib::xvid::bitstream::h263.h
deleted file mode 100644
index 1ef1d92651ef..000000000000
--- a/multimedia/mpeg4ip/files/patch-lib::xvid::bitstream::h263.h
+++ /dev/null
@@ -1,30 +0,0 @@
---- lib/xvid/bitstream/h263.h.orig Wed Nov 13 16:53:29 2002
-+++ lib/xvid/bitstream/h263.h Wed Nov 13 16:55:31 2002
-@@ -25,6 +25,10 @@
- /* #define FFMPEG_VERSION_INT 0x000405 */
- /* #define FFMPEG_VERSION "0.4.5" */
-
-+#if (defined(__unix__) || defined(unix)) && !defined(USG)
-+#include <sys/param.h>
-+#endif
-+
- #ifdef WIN32
- #define CONFIG_WIN32
- #endif
-@@ -69,11 +73,16 @@
- #define DEBUG
- #endif
-
-+#if defined(__FreeBSD__) && __FreeBSD_version >= 470000
-+#include <sys/endian.h>
-+#define be2me_32(x) (be32toh(x))
-+#else
- // code from bits/byteswap.h (C) 1997, 1998 Free Software Foundation, Inc.
- #define bswap_32(x) \
- ((((x) & 0xff000000) >> 24) | (((x) & 0x00ff0000) >> 8) | \
- (((x) & 0x0000ff00) << 8) | (((x) & 0x000000ff) << 24))
- #define be2me_32(x) bswap_32(x)
-+#endif
-
- #define snprintf _snprintf
-
diff --git a/multimedia/mpeg4ip/files/patch-ltmain.sh b/multimedia/mpeg4ip/files/patch-ltmain.sh
new file mode 100644
index 000000000000..b7b985b46652
--- /dev/null
+++ b/multimedia/mpeg4ip/files/patch-ltmain.sh
@@ -0,0 +1,15 @@
+--- ltmain.sh.orig Thu Sep 30 04:09:46 2004
++++ ltmain.sh Thu Sep 30 04:11:06 2004
+@@ -5425,10 +5425,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/multimedia/mpeg4ip/files/patch-mpeg4ip_config.h.in b/multimedia/mpeg4ip/files/patch-mpeg4ip_config.h.in
index cc7d2c744b7e..8bfb7a0aff76 100644
--- a/multimedia/mpeg4ip/files/patch-mpeg4ip_config.h.in
+++ b/multimedia/mpeg4ip/files/patch-mpeg4ip_config.h.in
@@ -1,7 +1,7 @@
---- mpeg4ip_config.h.in.orig Sun Apr 11 10:24:26 2004
-+++ mpeg4ip_config.h.in Sun Apr 11 10:24:48 2004
-@@ -22,13 +22,10 @@
- #undef HAVE_FPOS_T_POS
+--- mpeg4ip_config.h.in.orig Tue May 18 13:31:06 2004
++++ mpeg4ip_config.h.in Wed Sep 29 14:40:59 2004
+@@ -25,16 +25,12 @@
+ #undef HAVE_FPOS_T___POS
/* Define to 1 if you have the `getopt' function. */
-#undef HAVE_GETOPT
@@ -13,12 +13,15 @@
-#undef HAVE_GETOPT_LONG
/* Define to 1 if you have the `getopt_long_only' function. */
- #undef HAVE_GETOPT_LONG_ONLY
-@@ -58,7 +55,6 @@
+-#undef HAVE_GETOPT_LONG_ONLY
+
+ /* Define to 1 if you have the `getrusage' function. */
+ #undef HAVE_GETRUSAGE
+@@ -67,7 +63,6 @@
#undef HAVE_IPv6
/* Define to 1 if you have the `gnugetopt' library (-lgnugetopt). */
-#undef HAVE_LIBGNUGETOPT
- /* Define to 1 if you have the `socket' library (-lsocket). */
- #undef HAVE_LIBSOCKET
+ /* have libmpeg2 decoder library */
+ #undef HAVE_LIBMPEG2
diff --git a/multimedia/mpeg4ip/files/patch-player::src::codec::mp3::mp3_file.cpp b/multimedia/mpeg4ip/files/patch-player::src::codec::mp3::mp3_file.cpp
new file mode 100644
index 000000000000..5a1bed279202
--- /dev/null
+++ b/multimedia/mpeg4ip/files/patch-player::src::codec::mp3::mp3_file.cpp
@@ -0,0 +1,10 @@
+--- player/src/codec/mp3/mp3_file.cpp.orig Wed Sep 29 00:24:31 2004
++++ player/src/codec/mp3/mp3_file.cpp Wed Sep 29 00:28:47 2004
+@@ -126,6 +126,7 @@
+ descptr[1] = strdup(desc);
+ CHECK_AND_FREE(ret);
+ }
++ ret = ID3_v1_genre_description[NULL];
+ ret = ID3_GetAlbum(&myTag);
+ if (ret) {
+
diff --git a/multimedia/mpeg4ip/files/patch-player::src::mpeg3_rtp_bytestream.cpp b/multimedia/mpeg4ip/files/patch-player::src::mpeg3_rtp_bytestream.cpp
new file mode 100644
index 000000000000..43f23b9841cd
--- /dev/null
+++ b/multimedia/mpeg4ip/files/patch-player::src::mpeg3_rtp_bytestream.cpp
@@ -0,0 +1,29 @@
+--- player/src/mpeg3_rtp_bytestream.cpp.orig Thu Sep 30 03:10:31 2004
++++ player/src/mpeg3_rtp_bytestream.cpp Thu Sep 30 03:09:12 2004
+@@ -32,6 +32,10 @@
+ #else
+ #define rtp_message(loglevel, fmt...) message(loglevel, "rtpbyst", fmt)
+ #endif
++
++uint8_t temp_ref;
++int frame_type;
++
+ static rtp_packet *end_of_pak (rtp_packet *start)
+ {
+ while (start->rtp_next->rtp_pak_ts == start->rtp_pak_ts)
+@@ -74,7 +78,6 @@
+ int32_t diff;
+ int correct_hdr;
+ int dropped_seq;
+- uint8_t temp_ref;
+ diff = m_buffer_len - m_bytes_used;
+
+ if (diff > 2) {
+@@ -86,7 +89,6 @@
+ #endif
+ return (m_last_realtime);
+ }
+- int frame_type;
+ m_buffer_len = 0;
+ dropped_seq = 0;
+ while (finished == 0) {