aboutsummaryrefslogtreecommitdiff
path: root/multimedia/mpeg4ip
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2011-06-24 22:39:03 +0000
committerMartin Matuska <mm@FreeBSD.org>2011-06-24 22:39:03 +0000
commitc86cd8cae229c215d0436e0fad7912526e88ae56 (patch)
tree9718027b28c2222e1f4cf5383a9994ac89e71c6e /multimedia/mpeg4ip
parentc5b7f54af87b0635dec438c5adf49045db55b58a (diff)
downloadports-c86cd8cae229c215d0436e0fad7912526e88ae56.tar.gz
ports-c86cd8cae229c215d0436e0fad7912526e88ae56.zip
Notes
Diffstat (limited to 'multimedia/mpeg4ip')
-rw-r--r--multimedia/mpeg4ip/Makefile5
-rw-r--r--multimedia/mpeg4ip/files/patch-server_mp4live_video_ffmpeg.cpp13
2 files changed, 14 insertions, 4 deletions
diff --git a/multimedia/mpeg4ip/Makefile b/multimedia/mpeg4ip/Makefile
index 8310b6d2764c..e5d4865bd490 100644
--- a/multimedia/mpeg4ip/Makefile
+++ b/multimedia/mpeg4ip/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mpeg4ip
PORTVERSION= 1.6.1
-PORTREVISION= 16
+PORTREVISION= 17
CATEGORIES= multimedia audio ipv6 net
MASTER_SITES= LOCAL/ahze
# http://sourceforge.net/forum/forum.php?thread_id=1839453&forum_id=59136
@@ -144,7 +144,8 @@ PLIST_SUB+= XVID="@comment "
BROKEN= Does not compile
.endif
-post-patch:
+#post-patch:
+pre-configure:
@${TOUCH} -f ${WRKSRC}/bootstrapped
# don't compile or use libmp4v2
@${REINPLACE_CMD} -e 's|mp4v2||' \
diff --git a/multimedia/mpeg4ip/files/patch-server_mp4live_video_ffmpeg.cpp b/multimedia/mpeg4ip/files/patch-server_mp4live_video_ffmpeg.cpp
index 2fd02ad2c05e..114e87f57d28 100644
--- a/multimedia/mpeg4ip/files/patch-server_mp4live_video_ffmpeg.cpp
+++ b/multimedia/mpeg4ip/files/patch-server_mp4live_video_ffmpeg.cpp
@@ -1,5 +1,5 @@
---- server/mp4live/video_ffmpeg.cpp.orig 2008-07-27 18:33:54.140404708 -0500
-+++ server/mp4live/video_ffmpeg.cpp 2008-07-27 18:34:54.699683611 -0500
+--- server/mp4live/video_ffmpeg.cpp.orig 2007-01-30 22:53:45.000000000 +0100
++++ server/mp4live/video_ffmpeg.cpp 2011-06-24 22:08:18.167374694 +0200
@@ -121,9 +121,6 @@
m_avctx->bit_rate =
Profile()->GetIntegerValue(CFG_VIDEO_BIT_RATE) * 1000;
@@ -23,3 +23,12 @@
#else
AVRational asp =
{Profile()->GetIntegerValue(CFG_VIDEO_MPEG4_PAR_WIDTH),
+@@ -225,7 +222,7 @@
+ }
+ if (wantKeyFrame) m_picture->pict_type = FF_I_TYPE; //m_picture->key_frame = 1;
+ else //m_picture->key_frame = 0;
+- m_picture->pict_type = 0;
++ m_picture->pict_type = FF_P_TYPE;
+
+ m_picture->data[0] = (uint8_t *)pY;
+ m_picture->data[1] = (uint8_t *)pU;