aboutsummaryrefslogtreecommitdiff
path: root/multimedia/mpeg_stat
diff options
context:
space:
mode:
authorLars Engels <lme@FreeBSD.org>2011-06-21 11:41:52 +0000
committerLars Engels <lme@FreeBSD.org>2011-06-21 11:41:52 +0000
commit2ddef3b2c4f4d088a878bc58ad55bfb2cdacc91b (patch)
tree6cbb5e3f8c60236bb7eaa9d04c857c142e939207 /multimedia/mpeg_stat
parente7b1af21a3ce50f1ef5be8de7c7198b6bd684acb (diff)
Notes
Diffstat (limited to 'multimedia/mpeg_stat')
-rw-r--r--multimedia/mpeg_stat/distinfo1
-rw-r--r--multimedia/mpeg_stat/files/patch-Makefile20
-rw-r--r--multimedia/mpeg_stat/files/patch-main.c19
-rw-r--r--multimedia/mpeg_stat/files/patch-proto.h11
4 files changed, 50 insertions, 1 deletions
diff --git a/multimedia/mpeg_stat/distinfo b/multimedia/mpeg_stat/distinfo
index 83d42564f645..9f69bcb01b12 100644
--- a/multimedia/mpeg_stat/distinfo
+++ b/multimedia/mpeg_stat/distinfo
@@ -1,3 +1,2 @@
-MD5 (mpeg_stat-2.2b-src.tar.gz) = d0eca3833b76855c4e348b39deaf667d
SHA256 (mpeg_stat-2.2b-src.tar.gz) = d8406555f171bf4e76b8e427c0263fdec979db6015acbb2704fa654f82a0a162
SIZE (mpeg_stat-2.2b-src.tar.gz) = 80021
diff --git a/multimedia/mpeg_stat/files/patch-Makefile b/multimedia/mpeg_stat/files/patch-Makefile
new file mode 100644
index 000000000000..100cb95b8ee5
--- /dev/null
+++ b/multimedia/mpeg_stat/files/patch-Makefile
@@ -0,0 +1,20 @@
+--- Makefile.orig 2011-06-21 13:24:59.000000000 +0200
++++ Makefile 2011-06-21 13:34:51.000000000 +0200
+@@ -3,7 +3,7 @@
+ # Should make just about anywhere... If you have problems,
+ # check out porting.c first
+
+-CC = gcc
++CC ?= gcc
+
+ # at present, no include directories needed
+ # Except on our OSF3.0, where -I/usr/include is needed (why? I dont know).
+@@ -19,7 +19,7 @@
+ # Do not use it if it takes none (SunOS, HPUX, OSF1 )
+ # It works either way, just gets rid of a warning.
+
+-CFLAGS = -I/usr/include $(DEBUGFLAG) $(INCLUDEDIR)
++CFLAGS += -I/usr/include $(DEBUGFLAG) $(INCLUDEDIR)
+
+ # for SunOS cc, just use the above
+ # for cc on HPUX:
diff --git a/multimedia/mpeg_stat/files/patch-main.c b/multimedia/mpeg_stat/files/patch-main.c
new file mode 100644
index 000000000000..375ad5fcdd0e
--- /dev/null
+++ b/multimedia/mpeg_stat/files/patch-main.c
@@ -0,0 +1,19 @@
+--- main.c.orig 1995-08-04 21:09:21.000000000 +0200
++++ main.c 2011-06-21 13:38:25.000000000 +0200
+@@ -164,7 +164,7 @@
+ *--------------------------------------------------------------
+ */
+
+-void
++int
+ main(argc, argv)
+ int argc;
+ char **argv;
+@@ -534,6 +534,7 @@
+
+ realTimeStart = ReadSysClock();
+ mpegVidRsrc(0, theStream);
++ return (0);
+ }
+
+
diff --git a/multimedia/mpeg_stat/files/patch-proto.h b/multimedia/mpeg_stat/files/patch-proto.h
new file mode 100644
index 000000000000..1112fb216c57
--- /dev/null
+++ b/multimedia/mpeg_stat/files/patch-proto.h
@@ -0,0 +1,11 @@
+--- proto.h.orig 2011-06-21 13:38:56.000000000 +0200
++++ proto.h 2011-06-21 13:37:22.000000000 +0200
+@@ -87,7 +87,7 @@
+ #else
+ void int_handler P((int signum ));
+ #endif
+-void main P((int argc , char **argv ));
++int main P((int argc , char **argv ));
+ void Usage P((void ));
+ void DoDitherImage P((unsigned char *l , unsigned char *Cr , unsigned char *Cb , unsigned char *disp , int h , int w ));
+