aboutsummaryrefslogtreecommitdiff
path: root/multimedia/mpgtx
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-10-23 19:40:43 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-10-23 19:40:43 +0000
commit507080cae32aef4569a6fae73a0b6b54903509fc (patch)
tree7e71834a92a776a595243e77e3947d5b521d2715 /multimedia/mpgtx
parentc3d50bb4e93df71b0e9f77e62e1420c356ec559c (diff)
downloadports-507080cae32aef4569a6fae73a0b6b54903509fc.tar.gz
ports-507080cae32aef4569a6fae73a0b6b54903509fc.zip
Notes
Diffstat (limited to 'multimedia/mpgtx')
-rw-r--r--multimedia/mpgtx/Makefile1
-rw-r--r--multimedia/mpgtx/files/patch-chunkTab.cxx21
2 files changed, 22 insertions, 0 deletions
diff --git a/multimedia/mpgtx/Makefile b/multimedia/mpgtx/Makefile
index f9ef703ab22d..a14bbdb6b583 100644
--- a/multimedia/mpgtx/Makefile
+++ b/multimedia/mpgtx/Makefile
@@ -8,6 +8,7 @@
PORTNAME= mpgtx
PORTVERSION= 1.3.1
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/multimedia/mpgtx/files/patch-chunkTab.cxx b/multimedia/mpgtx/files/patch-chunkTab.cxx
new file mode 100644
index 000000000000..cd96a6812631
--- /dev/null
+++ b/multimedia/mpgtx/files/patch-chunkTab.cxx
@@ -0,0 +1,21 @@
+--- chunkTab.cxx.orig Sat Dec 11 18:33:22 2004
++++ chunkTab.cxx Fri Sep 30 11:29:15 2005
+@@ -142,7 +142,7 @@
+ off_t part,nparts;
+ chunk* tempchunk = new chunk;
+ tempchunk->file = 0;
+- tempchunk->from = -1;
++ tempchunk->from = 0;
+ tempchunk->to = -1;
+ tempchunk->to_included = false;
+ tempchunk->from_included = false;
+@@ -626,7 +626,7 @@
+ for (i = 1; i <= n; i++) {
+ tempchunk = new chunk;
+ tempchunk->file = 0;
+- tempchunk->from = -1;
++ tempchunk->from = 0;
+ tempchunk->to = -1;
+ tempchunk->to_included = true;
+ tempchunk->from_included = false;
+