aboutsummaryrefslogtreecommitdiff
path: root/multimedia/mplayer/Makefile.options
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2010-09-02 19:56:12 +0000
committerRene Ladan <rene@FreeBSD.org>2010-09-02 19:56:12 +0000
commit92f38f55f854e8e4c2577cd688e6a8b166cb6ac1 (patch)
tree3dcab3b494af91ebad41ceb7649907b720520e9d /multimedia/mplayer/Makefile.options
parentc45a36f4ac767040718621f07379c1773cbc0a04 (diff)
- correctly pick up dependency on libvpx if selected in options
- remove mencoder dependency on mplayer, the two ports can now be installed independently. - remove dependency on liba52 as this is handled by internal libavcodec - correctly handle dependency on external libschroedinger PR: ports/149534 Submitted by: maintainer Tested by: Christopher Key [cjk32 cam.ac.uk]
Notes
Notes: svn path=/head/; revision=260438
Diffstat (limited to 'multimedia/mplayer/Makefile.options')
-rw-r--r--multimedia/mplayer/Makefile.options8
1 files changed, 7 insertions, 1 deletions
diff --git a/multimedia/mplayer/Makefile.options b/multimedia/mplayer/Makefile.options
index 666b96017b06..c47aa0aacb16 100644
--- a/multimedia/mplayer/Makefile.options
+++ b/multimedia/mplayer/Makefile.options
@@ -84,10 +84,16 @@ LIB_DEPENDS+= theora.0:${PORTSDIR}/multimedia/libtheora
CONFIGURE_ARGS+= --disable-theora
.endif
+.if defined(WITH_VPX)
+LIB_DEPENDS+= vpx.0:${PORTSDIR}/multimedia/libvpx
+.else
+CONFIGURE_ARGS+= --disable-libvpx-lavc
+.endif
+
.if defined(WITH_SCHROEDINGER)
LIB_DEPENDS+= schroedinger-1.0.3:${PORTSDIR}/multimedia/schroedinger
.else
-CONFIGURE_ARGS+= --disable-libschroedinger
+CONFIGURE_ARGS+= --disable-libschroedinger-lavc
.endif
.if defined(WITH_LIBMPCDEC)