aboutsummaryrefslogtreecommitdiff
path: root/multimedia/mplayer/Makefile.options
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2014-04-27 14:22:25 +0000
committerThomas Zander <riggs@FreeBSD.org>2014-04-27 14:22:25 +0000
commitfd39b1ac01f5235aa5a3416c508455c5993fdc3e (patch)
tree94111a7ea6e11cde62f01ccd92a2d962cca278ae /multimedia/mplayer/Makefile.options
parent85d711de42bb2c23fd80d4eab7a8674caaa243ee (diff)
downloadports-fd39b1ac01f5235aa5a3416c508455c5993fdc3e.tar.gz
ports-fd39b1ac01f5235aa5a3416c508455c5993fdc3e.zip
Notes
Diffstat (limited to 'multimedia/mplayer/Makefile.options')
-rw-r--r--multimedia/mplayer/Makefile.options64
1 files changed, 32 insertions, 32 deletions
diff --git a/multimedia/mplayer/Makefile.options b/multimedia/mplayer/Makefile.options
index be8b8b06759f..fa111c12ee28 100644
--- a/multimedia/mplayer/Makefile.options
+++ b/multimedia/mplayer/Makefile.options
@@ -10,7 +10,7 @@
# Feature options:
# These options influence some general behaviour of mplayer. Almost all of the featues,
# for example all the codecs, are selected via the OPTIONS framework.
-# The following options WITH_DVD_DEVICE, WITH_CDROM_DEVICE, WITH_LANG are *not*
+# The following options WITH_DVD_DEVICE, WITH_CDROM_DEVICE, are *not*
# selected via the options framework and must be set via make.conf or by passing
# the variable to make during build, e.g. make WITH_DVD_DEVICE=/dev/cd0
#
@@ -22,19 +22,10 @@
# WITH_CDROM_DEVICE=/path/to/desired/device
# default: /dev/cd0
# This option changes the default cdrom device, maybe useful for VCDs
-#
-# WITH_LANG=<your choice>
-# default: en
-# Enables language support bg, cz, de, dk, en, es, fr, gr, hu, it, ko, nl, no, pl, pt_BR, ro, ru, sk, tr, uk, zh
-#
# Non-OPTIONS knob handling
# =========================
-.if defined(WITH_LANG)
-CONFIGURE_ARGS+=--language=${WITH_LANG}
-.endif
-
.if defined(WITH_DVD_DEVICE)
DEFAULT_DVD_DEVICE=${WITH_DVD_DEVICE}
.else
@@ -57,12 +48,6 @@ DEFAULT_KERN_HZ=1024
# Non-simplified OPTIONS handling
# ===============================
-.if ${PORT_OPTIONS:MESOUND}
-USE_GNOME+= esound
-.else
-CONFIGURE_ARGS+= --disable-esd
-.endif
-
.if ${PORT_OPTIONS:MIPV6}
CATEGORIES+= ipv6
.else
@@ -99,22 +84,6 @@ CONFIGURE_ARGS+= --disable-tv-v4l1 \
# Build system handling (including OPTIONS)
# =========================================
-#On i386, gcc runs out of general purpose registers when
-#trying to compile a debug version with the default flags.
-.if ${PORT_OPTIONS:MDEBUG}
-WITH_DEBUG= yes
-CONFIGURE_ARGS+= --enable-debug
-.if ${ARCH} == "i386"
-DEBUG_FLAGS= -g -fomit-frame-pointer
-.endif
-.else
-.if ${PORT_OPTIONS:MOCFLAGS}
-CFLAGS+= -O3 -fomit-frame-pointer -ffast-math
-.else
-CFLAGS+= -O -fomit-frame-pointer
-.endif #OCFLAGS
-.endif #DEBUG
-
# Supported architectures for clang
.if ${ARCH} == "amd64" || ${ARCH} == "i386"
MPLAYER_CLANG_SUPPORTED_ARCH= yes
@@ -167,6 +136,34 @@ MAKE_ENV+= COMPILER_PATH=${LOCALBASE}/bin
.endif
.endif
+
+# Extra build options for debugging and profiling
+# ===============================================
+
+#On i386, gcc runs out of general purpose registers when
+#trying to compile a debug version with the default flags.
+.if ${PORT_OPTIONS:MDEBUG}
+WITH_DEBUG= yes
+CONFIGURE_ARGS+= --enable-debug
+.if ${ARCH} == "i386" && !defined(WITH_BASE_CLANG)
+DEBUG_FLAGS= -g -fomit-frame-pointer
+.endif
+.else
+.if ${PORT_OPTIONS:MOCFLAGS}
+CFLAGS+= -O3 -fomit-frame-pointer -ffast-math
+.else
+CFLAGS+= -O -fomit-frame-pointer
+.endif #OCFLAGS
+.endif #DEBUG
+
+.if ${PORT_OPTIONS:MPROFILE}
+CONFIGURE_ARGS+= --enable-profile
+LDFLAGS+= -pg
+.endif
+
+# Edge case: binary codecs on i386, mostly superseded by internal ffmpeg
+# ======================================================================
+
.if ${ARCH} == "i386" || ${ARCH} == "amd64"
.if ${PORT_OPTIONS:MWIN32} && !defined(PACKAGE_BUILDING) && ${ARCH} == "i386"
RUN_DEPENDS+= ${CODEC_DETECTION_FILE}:${CODEC_PORT}
@@ -180,6 +177,9 @@ CONFIGURE_ARGS+= --disable-win32dll \
.endif # ARCH == i386/amd64
+# Additional extra libraries handling
+# ===================================
+
.if defined(EXTRA_LIBS)
CONFIGURE_ARGS+= --extra-libs="${EXTRA_LIBS}"
.endif