aboutsummaryrefslogtreecommitdiff
path: root/multimedia/mplayer/Makefile
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2014-02-17 22:34:40 +0000
committerThomas Zander <riggs@FreeBSD.org>2014-02-17 22:34:40 +0000
commitd73825cf2cb3c1f10b7d119c40b5d9fbc4245de9 (patch)
tree145df39f4ad119a39ec06ba13d3a951c7d1a98bc /multimedia/mplayer/Makefile
parent278314702d1ed1dfd7c469a185cfbc5a4abfbadb (diff)
- Drop support for pre-8.3 systems
- Convert old LIB_DEPENDS to new format - Fix staging breakage for PREFIX!=LOCALBASE - Fix bug passing wrong CONFIGURE_ARGS when using DEBUG (causes dangling dependencies in debug builds) - Bump PORTREVISION - Update maintainer e-mail address Approved by: thierry (mentor) MFH: 2014Q1
Notes
Notes: svn path=/head/; revision=344827
Diffstat (limited to 'multimedia/mplayer/Makefile')
-rw-r--r--multimedia/mplayer/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index 1fe972e06b18..0e67dddde693 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mplayer
PORTVERSION= ${MPLAYER_PORT_VERSION}
-PORTREVISION= 0
+PORTREVISION= 1
COMMENT= High performance media player supporting many formats
@@ -37,8 +37,6 @@ WIN32_DESC?= Install win32 binary codecs
X11DGA_DESC?= X11 DGA video driver support
X11VM_DESC?= X11 VidMode support
-#MANCOMPRESSED= no
-
SUB_FILES= pkg-message
CONFFILES= example.conf input.conf menu.conf dvb-menu.conf
@@ -96,7 +94,7 @@ CONFIGURE_ARGS+=--disable-dga1 --disable-dga2
.endif
.if ${PORT_OPTIONS:MOPENGL}
USE_XORG+= glproto
-LIB_DEPENDS+= GL:${PORTSDIR}/graphics/libGL
+LIB_DEPENDS+= libGL.so:${PORTSDIR}/graphics/libGL
.else
CONFIGURE_ARGS+=--disable-gl
.endif
@@ -178,7 +176,7 @@ post-install:
.if ${PORT_OPTIONS:MGUI} && ${PORT_OPTIONS:MX11}
@${LN} -sf ${PREFIX}/bin/mplayer ${STAGEDIR}${PREFIX}/bin/gmplayer
@(cd ${STAGEDIR}${MAN1PREFIX}/man/man1 && ${LN} -sf mplayer.1.gz gmplayer.1.gz)
- ${CP} -f ${WRKSRC}/etc/mplayer256x256.png ${STAGEDIR}${LOCALBASE}/share/pixmaps/mplayer.png
+ ${CP} -f ${WRKSRC}/etc/mplayer256x256.png ${STAGEDIR}${PREFIX}/share/pixmaps/mplayer.png
.endif
.include <bsd.port.post.mk>