aboutsummaryrefslogtreecommitdiff
path: root/multimedia/mplayer/Makefile
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2017-01-14 12:48:30 +0000
committerThomas Zander <riggs@FreeBSD.org>2017-01-14 12:48:30 +0000
commit72923f111f4b157b9b67dc6f332472595c44628d (patch)
treeb57faf5fd83ee70586e7dd17e7bc743475a2aadf /multimedia/mplayer/Makefile
parentd41f933bc5ee1ed7c6c32b312f5e0abe22bb0ebd (diff)
Notes
Diffstat (limited to 'multimedia/mplayer/Makefile')
-rw-r--r--multimedia/mplayer/Makefile38
1 files changed, 1 insertions, 37 deletions
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index 3ffb2758d289..9653fa7796fb 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -49,7 +49,7 @@ USES+= iconv pkgconfig
OPTIONS_SUB= yes
.include "${.CURDIR}/../../multimedia/mplayer/Makefile.optvars"
-.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
CONFIGURE_ARGS+= --disable-arts \
--disable-directfb \
@@ -65,42 +65,6 @@ CONFIGURE_ARGS+= --disable-arts \
--disable-musepack \
--disable-theora
-.if ${PORT_OPTIONS:MX11}
-USE_XORG= x11 xext xproto xscrnsaver
-.if ${PORT_OPTIONS:MXVIDEO}
-USE_XORG+= xv
-.else
-CONFIGURE_ARGS+=--disable-xv
-.endif
-.if ${PORT_OPTIONS:MX11DGA}
-USE_XORG+= xxf86dga
-.else
-CONFIGURE_ARGS+=--disable-dga1 --disable-dga2
-.endif
-.if ${PORT_OPTIONS:MOPENGL}
-USE_GL+= gl
-.else
-CONFIGURE_ARGS+=--disable-gl
-.endif
-.if ${PORT_OPTIONS:MXINERAMA}
-USE_XORG+= xinerama xineramaproto
-.else
-CONFIGURE_ARGS+=--disable-xinerama
-.endif
-.if ${PORT_OPTIONS:MX11VM}
-USE_XORG+= xxf86vm
-.else
-CONFIGURE_ARGS+=--disable-vm
-.endif
-.if ${PORT_OPTIONS:MXVMC}
-USE_XORG+= xvmc
-CONFIGURE_ARGS+=--enable-xvmc --with-xvmclib=XvMCW
-.endif
-.else #X11
-CONFIGURE_ARGS+=--disable-x11
-.endif
-
-.include <bsd.port.pre.mk>
.include "${.CURDIR}/../../multimedia/mplayer/Makefile.options"
BROKEN_armv6= Fails to compile: Error: garbage following instruction -- vmov s16,SCALE