aboutsummaryrefslogtreecommitdiff
path: root/multimedia/mplayer2
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2015-08-27 16:59:39 +0000
committerJan Beich <jbeich@FreeBSD.org>2015-08-27 16:59:39 +0000
commit81282d934dbac4674260383960d64547e29c7700 (patch)
treec748dbb7e2f107d2f84fb9605c49a3eea27ce1ed /multimedia/mplayer2
parent3a314ae589329abc7b72d89570068008576cae06 (diff)
downloadports-81282d934dbac4674260383960d64547e29c7700.tar.gz
ports-81282d934dbac4674260383960d64547e29c7700.zip
Notes
Diffstat (limited to 'multimedia/mplayer2')
-rw-r--r--multimedia/mplayer2/Makefile15
-rw-r--r--multimedia/mplayer2/files/patch-configure49
-rw-r--r--multimedia/mplayer2/files/patch-libvo_vo__v4l2.c12
-rw-r--r--multimedia/mplayer2/files/patch-stream_stream__pvr.c10
-rw-r--r--multimedia/mplayer2/files/patch-stream_stream__radio.c21
5 files changed, 98 insertions, 9 deletions
diff --git a/multimedia/mplayer2/Makefile b/multimedia/mplayer2/Makefile
index 9ab3ee604539..51157e4b0f8c 100644
--- a/multimedia/mplayer2/Makefile
+++ b/multimedia/mplayer2/Makefile
@@ -43,7 +43,7 @@ MPLAYER2_PORT_VERSION= 2.0.${MPLAYER2_SNAPSHOT_DATE:S/-//g}
OPTIONS_DEFINE= DEBUG RTC IPV6 SMB LIBBLURAY DV THEORA \
X11 XINERAMA OPENGL SDL VDPAU GIF CACA \
MAD SPEEX CDIO LADSPA REALPLAYER \
- JACK PULSEAUDIO PORTAUDIO ASS LIRC
+ JACK PULSEAUDIO PORTAUDIO ASS LIRC V4L
OPTIONS_DEFAULT=X11 ASS
.if !defined(PACKAGE_BUILDING)
@@ -179,14 +179,13 @@ BUILD_DEPENDS+= realplay:${PORTSDIR}/multimedia/linux-realplayer
CONFIGURE_ARGS+= --disable-real
.endif
-#.if ${PORT_OPTIONS:MV4L}
-#BUILD_DEPENDS+= ${LOCALBASE}/include/linux/videodev2.h:${PORTSDIR}/multimedia/v4l_compat
-#LIB_DEPENDS+= libv4l2.so:${PORTSDIR}/multimedia/libv4l
-#CONFIGURE_ARGS+= --enable-tv-v4l2
-#LIBS+= -lv4l2
-#.else
+.if ${PORT_OPTIONS:MV4L}
+BUILD_DEPENDS+= ${LOCALBASE}/include/linux/videodev2.h:${PORTSDIR}/multimedia/v4l_compat
+LIB_DEPENDS+= libv4l2.so:${PORTSDIR}/multimedia/libv4l
+LIBS+= -lv4l2
+.else
CONFIGURE_ARGS+= --disable-tv-v4l2
-#.endif
+.endif
.if ${PORT_OPTIONS:MASS}
LIB_DEPENDS+= libass.so:${PORTSDIR}/multimedia/libass
diff --git a/multimedia/mplayer2/files/patch-configure b/multimedia/mplayer2/files/patch-configure
index 3c97ffe84abe..e0e9b4f2095d 100644
--- a/multimedia/mplayer2/files/patch-configure
+++ b/multimedia/mplayer2/files/patch-configure
@@ -18,7 +18,54 @@
# for crosscompilation, we cannot execute the program, be happy if we can link statically
cc_check $THREAD_CFLAGS $_ld_tmp && (tmp_run || test "$_ld_static") && _ld_pthread="$_ld_tmp" && _pthreads=yes && break
done
-@@ -5296,7 +5296,7 @@ RST2MAN = $_rst2man
+@@ -3961,11 +3961,7 @@ if test "$_v4l2" = auto ; then
+ cat > $TMPC << EOF
+ #include <sys/time.h>
+ #include <linux/videodev2.h>
+-#include <linux/version.h>
+ int main(void) {
+-#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,22)
+-#error kernel headers too old, need 2.6.22
+-#endif
+ struct v4l2_ext_controls ctrls;
+ ctrls.ctrl_class = V4L2_CTRL_CLASS_MPEG;
+ return 0;
+@@ -4940,7 +4936,7 @@ echores "$_tv_dshow"
+ echocheck "Video 4 Linux 2 TV interface"
+ if test "$_tv_v4l2" = auto ; then
+ _tv_v4l2=no
+- if test "$_tv" = yes && linux ; then
++ if test "$_tv" = yes ; then
+ header_check_broken sys/time.h linux/videodev2.h && _tv_v4l2=yes
+ elif test "$_tv" = yes && test "$sys_videoio_h" = "yes" ; then
+ _tv_v4l2=yes
+@@ -4983,7 +4979,7 @@ echores "$_radio_capture"
+ echocheck "Video 4 Linux 2 Radio interface"
+ if test "$_radio_v4l2" = auto ; then
+ _radio_v4l2=no
+- if test "$_radio" = yes && linux ; then
++ if test "$_radio" = yes ; then
+ header_check linux/videodev2.h && _radio_v4l2=yes
+ fi
+ fi
+@@ -5000,6 +4996,7 @@ echocheck "*BSD BrookTree 848 Radio inte
+ _radio_bsdbt848=no
+ cat > $TMPC <<EOF
+ #include <sys/types.h>
++#include <sys/ioctl.h>
+ $def_ioctl_bt848_h_name
+ #ifdef IOCTL_BT848_H_NAME
+ #include IOCTL_BT848_H_NAME
+@@ -5024,7 +5021,7 @@ fi
+ echocheck "Video 4 Linux 2 MPEG PVR interface"
+ if test "$_pvr" = auto ; then
+ _pvr=no
+- if test "$_tv_v4l2" = yes && linux ; then
++ if test "$_tv_v4l2" = yes ; then
+ cat > $TMPC <<EOF
+ #include <sys/time.h>
+ #include <linux/videodev2.h>
+@@ -5296,7 +5293,7 @@ RST2MAN = $_rst2man
EXESUF = $_exesuf
EXESUFS_ALL = .exe
diff --git a/multimedia/mplayer2/files/patch-libvo_vo__v4l2.c b/multimedia/mplayer2/files/patch-libvo_vo__v4l2.c
new file mode 100644
index 000000000000..123966770096
--- /dev/null
+++ b/multimedia/mplayer2/files/patch-libvo_vo__v4l2.c
@@ -0,0 +1,12 @@
+--- libvo/vo_v4l2.c.orig 2015-08-26 13:36:16 UTC
++++ libvo/vo_v4l2.c
+@@ -33,9 +33,7 @@
+ #include <unistd.h>
+ #include <stdlib.h>
+ #include <inttypes.h>
+-#include <linux/types.h>
+ #include <linux/videodev2.h>
+-#include <linux/ioctl.h>
+
+ #include "mp_msg.h"
+ #include "subopt-helper.h"
diff --git a/multimedia/mplayer2/files/patch-stream_stream__pvr.c b/multimedia/mplayer2/files/patch-stream_stream__pvr.c
new file mode 100644
index 000000000000..454d21394570
--- /dev/null
+++ b/multimedia/mplayer2/files/patch-stream_stream__pvr.c
@@ -0,0 +1,10 @@
+--- stream/stream_pvr.c.orig 2015-08-26 13:37:03 UTC
++++ stream/stream_pvr.c
+@@ -37,7 +37,6 @@
+ #include <fcntl.h>
+ #include <inttypes.h>
+ #include <poll.h>
+-#include <linux/types.h>
+ #include <linux/videodev2.h>
+
+ #include "mp_msg.h"
diff --git a/multimedia/mplayer2/files/patch-stream_stream__radio.c b/multimedia/mplayer2/files/patch-stream_stream__radio.c
new file mode 100644
index 000000000000..df446aa93485
--- /dev/null
+++ b/multimedia/mplayer2/files/patch-stream_stream__radio.c
@@ -0,0 +1,21 @@
+--- stream/stream_radio.c.orig 2015-08-26 13:37:17 UTC
++++ stream/stream_radio.c
+@@ -40,17 +40,12 @@
+ #ifdef IOCTL_BT848_H_NAME
+ #include IOCTL_BT848_H_NAME
+ #endif
+-
+-#else /* CONFIG_RADIO_BSDBT848 */
+-
+-#include <linux/types.h>
++#endif
+
+ #ifdef CONFIG_RADIO_V4L2
+ #include <linux/videodev2.h>
+ #endif
+
+-#endif // !IOCTL_BT848_H_NAME
+-
+
+ #include "stream.h"
+ #include "libmpdemux/demuxer.h"